Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: TaskMgr.exe won't run. How to restore permissions and functionality?

26 Jan 2014   #1

TaskMgr.exe won't run. How to restore permissions and functionality?

I have recently removed some "alternative" process manager reporting software and cannot get TaskMgr.exe to run now.

C:\windows\system32> taskmgr.exe
hourglass appears and then disappears. No process information and no dialog.

Likewise for Start> Run> taskmgr.exe

If however, a parameter is given, it will pop up a Process Explorer dialog box describing USAGE: Process Explorer [/e][/t]...
however all these should be optional (no parameter required). With no parameter, nothing appears (as described above) but with a parameter, the Usage dialog box appears for ANY parameter, including the allowed parameters.

NOTE: I observed the properties and see that READ and Read & Execute are allowed, however all the users and permissions are greyed out. Other EXE files in the system32 directory can be changed for permissions, but not this one. How do I restore control of permissions? I suspect that may lead me to why it's not working.

My System SpecsSystem Spec
26 Jan 2014   #2

Windows 7 32 bit

From SysInternals forum:
Uncheck the sub menu of "Options->Replace Task Manager" .
My System SpecsSystem Spec
28 Jan 2014   #3


Actually, I was trying several replacements, although Sysinternals happens to have been one of them.

So, you inspired me to re-install sysinternals. The trouble is, the replace/restore option does not work properly now. The help file reads:
"Select the Replace Task Manager entry under the Options menu to have Process Explorer execute instead of Task Manager when you launch Task Manager. ... After replacing Task Manager the menu item renames to Restore Task Manager and selecting it removes Process Explorer's association."

Well, that does not happen. It always stays at "replace task manager".

This returns me to my original conundrum about permissions.
My System SpecsSystem Spec

28 Jan 2014   #4


So, after deleting all references in the registry to SYSINTERNALS and still having the problem, I found an entry for TASKMGR.EXE
Deleting HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\taskmgr.exe
seems to have done the trick. TaskMgr.exe launches now, as expected.
My System SpecsSystem Spec
28 Jan 2014   #5

Windows 7 32 bit

Glad you got it. Unfortunately the Registry will never be documented. The effective method is to watch what programs change. Regshot utility is handy in that regard.
My System SpecsSystem Spec

 TaskMgr.exe won't run. How to restore permissions and functionality?

Thread Tools

Similar help and support threads
Thread Forum
How do I restore my File Permissions?
I no longer have the "Write Permissions" that I had before. Nor can I "See" all the folders that I used to. Of course, I suspect I have shot myself in the foot. Again. . . Yes, I have tried a Registry Backup or two with no luck. I took this snapshot of my C Drive "Properties" via Right Click and...
General Discussion
Restore default registry permissions
Hi everybody, I'm not sure what messed up my registry keys but the administrators users can't open them anymore on my Windows 7 machine. So I'd like a method that reset them to the default settings. I found one way, which would be to set everything with Administrators full control, but that is...
BSOD Help and Support
Restore Access Permissions on C: Drive after changing in cmd
So, I'm an idiot. I need someone to help me reset ownership and permissions for the c: drive on a hdd. I'm not well versed in cmd so I can't seem to figure it out. My bf's laptop overheated (so I thought, he was streaming a baseball game, not much else I think, when it shut down unexpectedly...
Installation & Setup
Restore permissions error
Took full back up (AMOMEI Backupper) on W7 64 bit Ultimate OS Now trying to restore ... Mounted Backup image .. as only need to copy one folder & its contents. about 140MB gone in OK .... but some files in one folder won't copy get errror: "You'll need Administrator permission to copy...
Backup and Restore
Restore security permissions to default settings??
How to restore security permissions to default settings? Hello, I had problems sharing files on my network and I went to different support forums looking for answers. I changed user permissions on my (D/) drive and tried to add "Everyone" following instructions from other forum, I did something...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:07.
Twitter Facebook Google+