Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot change read-only, permissions or ownership of files

25 Feb 2014   #1

Windows 7
Cannot change read-only, permissions or ownership of files


Was playing a game recently and wanted to mod it. Found I didn't have permission to save changes to a notepad document. Checked if it was read only and it was, so I went to the game folder and unchecked the read only box in properties. It asked for permission, I gave it, spent a few seconds going through all the files in the folder it was in and then I clicked OK. Still couldn't save the file, and found that the Read Only box had been REHIGHLIGHTED.

So I go to Properties / Security and notice a few things. There is only one user account on this computer and it's an admin account, yet there are 5 accounts here, CREATOR OWNER, SYSTEM, Administrators, Users and TrustedInstaller. Don't know what that's all about. Anyway I couldn't change their permissions to full control. So I went to Ownership, and added the Administrators account as the owner, before it was some other account that wasn't any of the above.

Now I could add the full controls to all the accounts which I did. The problem persisted, the Read-Only checkbox would rehighlight after I unchecked it, apply, and OK. So I tried changing the owner to my User account. The problem persisted.

If I go to Security, Advanced, Permissions, I try to add Full Control to any of the accounts, but what it does is it creates a second copy of that account with full controls that I can remove, while the User account which has Read-Only permissions stays as an unremovable account. So I get a User account with full control and a User account with limited control. And the problem persists.

Any ideas/suggestions?

My System SpecsSystem Spec
25 Feb 2014   #2

W7 Pro SP1 64bit

Welcome to the Seven Forums.

Open Notepad with elevated privileges.
(Start > Notepad > Right click on the notepad shortcut > Run as admin......)

Navigate to the file to be changed from within Notepad.
(File > Open > Navigate to the file)

Let us know if that works.
My System SpecsSystem Spec

 Cannot change read-only, permissions or ownership of files

Thread Tools

Similar help and support threads
Thread Forum
SOLVED: TrustedInstaller, Access Denied, Permissions, Change Ownership
This thread is related to, How to remove trustedinstaller Solved - Windows 7 Help Forums, which did not solve the TrustedInstaller, Access denied, permissions issue for me. However, I did over come the problem, and wanted to pass on what I did for others to use. Below, my actions to regain...
System Security
change ownership/permissions to HDD
OS: Win7 ultimate + SP1 x64 I added 2 old HDD and I can write and delete files but there are things I cannot do with this drives like organize (move folders) how can I change ownership/permissions for these 2 old drives? I tried using annoyances' takeown and Mainz univ. chown and it didn't...
Hardware & Devices
Cannot take ownership/cannot change permissions for windows folder
Hello all! All this started when I just wanted to change the way the clock looked to a custom one. I go to the Windows Sidebar folder to locate the Gadgets folder for the clocks, and I try to make backups of a few of the files in the clocks folder by moving some of them to a new folder I...
General Discussion
set read-only permissions for folders and files
I have an image of my the hard drive from my XP system on an external drive. I'd like to copy the entire file structure to the windows 7 hard drive, retaining the folder structure. Then I'd like to set all the folders, sub-folders, and files to read-only to protect myself from accidentally...
General Discussion
Stuck on 'read only' after ownership, permission change
I'm set as an administrator, I've taken ownership of Program Files folder via my account, and I've set myself to full permissions - yet I STILL can't get it to release from Read Only, which makes it impossible to install certain softwares. WTH?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:07.
Twitter Facebook Google+