Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: First post... Issues with MBR

27 Oct 2009   #1

Windows 7, 64 bit
First post... Issues with MBR


My first post here. I don't hang out in Windows help forums but when you need them I'm glad they are there!!

OK, here's my story. I received my upgrade copy of Windows 7 the other day and couldn't wait to get to the weekend to get it installed and say "bye bye crapy Vista". All was going well on Sunday. Backed up my files and then proceeded to install Windows 7 (rather than upgrade, it's cleaner that way, plus my old Windows and settings are stored in Windows.old folder so no biggie).

OK, next morning I get up and proceed to get my programs installed. I'm going along, getting things installed and key codes entered and tweaking settings as I go along. I come to my Utilities folder with all those exe's and zips within and install a bunch of those (including Winzip, WinRAR and what not) then I come upon Acronis .... partitioning and boot software... OK cool, just in case I need that sure why not?? It was version 10.... little did I realize it was going to affect my boot sector. So at one point I needed to reboot... so I did....

Got past the BIOS and all that and up pops the Acronis software... WTF?? I look and do not see Windows 7 as a bootable OS! Months and months ago I messed around with Ubuntu Linux and had to install Grub to boot into it. What a frigging mess that made of things. I ended up loosing it all. Had to reinstall Windows Vista (luckily the Windows.old folder was there so I was able to recover most of my files and settings). So I THOUGHT that old boot sector had been wiped out. Guess not.

So there I am stuck in this Acronis UI looking at what? TWO instances of Linux to boot into, in which I KNOW neither exists because I wiped out those partitions months ago and yet Acronis found the OLD boot sector and did not find Windows 7, being that it was a version too old to do that!

Through many moments of frustration (to put it lightly) I got back into Windows, went on line and immediately went to the Acronis web site and bought tech help ($10.00 down the drain). I sat there for 1/2 hour waiting for someone to help me and then he told me that since I used the wrong version of Acronis that it was out of his hands. My answer back was "Oh, so I'm out $10.00, NICE! I waited for a response and eventually gave up. I won't ever buy from them again and I'm thoroughly fed up with them and their "support". My fault I know but you know, you pay for support you expect them to at least give you options. Oh he did give me an option... you can buy the newest version which will fix your issue....

So anyway, I also created a "Repair Disk" and booted back out and in and repaired the issue. Kind of...

Now I'm getting this message when I boot in.....

"Non system disk, press any key to continue" I hit the Enter key and then I boot into Windows.

How can I fix that??

Also I had a question about using the "Repair Disk". If you had to use the Command Prompt and you want to fix the MBR you would type in what exactly??

fix mbr
or .....?

Thanks and sorry for the long story but hope that gives folks enough info. I can build a computer from scratch but I know little about boot sectors, command line commands or anything like that!!



My System SpecsSystem Spec
27 Oct 2009   #2

XP, Seven, 2008R2

Quote   Quote: Originally Posted by RAMWolff
If you had to use the Command Prompt and you want to fix the MBR you would type in what exactly??
How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows
My System SpecsSystem Spec
27 Oct 2009   #3

Windows 7, 64 bit

Hey, thanks for the link!! Very helpful. I'll be sure to print that out when I get home tonight!!

Richard ;-)~
My System SpecsSystem Spec

28 Oct 2009   #4

Windows 7, 64 bit

OK, tried that and I'm met with the following message when trying the FixMbr and FixBoot options:

... is not recognized as an internal or external command, operable program or batch file.

So not sure what to do at this point. Bootrec.exe just seems to offer up the commands but nothing more. I thought it would act as a gateway to allow the commands to be used but to no avail.

Please help me resolve this if anyone can... quite frustrated.

Thanks so much!

My System SpecsSystem Spec
28 Oct 2009   #5

XP_Pro, W7_7201, W7RC.vhd, SciLinux5.3, Fedora12, Fedora9_2x, OpenSolaris_09-06

1. Go here:

Windows 7 - Tutorial Index

2. Click on the "M" letter, at top.

3. On the new page, about the fifth entry down, there's something like:
"... Restore MBR ..."

4. See if that helps...

5. Bookmark the link shown in Step #1, for your future references...
My System SpecsSystem Spec
28 Oct 2009   #6

Windows 7, 64 bit

I'll give it a try. Thanks much!!

Richard ;-)~
My System SpecsSystem Spec
28 Oct 2009   #7

Windows 7, 64 bit

OK, did at the tutorial suggested. Booted with the Windows 7 DVD rather than the Recovery Disk I had created. Got the X:\Sources> option and began working my way down the drive letters (writing down each one that was valid and showed files after entering the DIR command)

I NEVER found a drive that was my DVD drive. I have my DVD and DVD Writer drives set as R and W (Read and Write), it's just the way my brain works. None of these drives in the Command Prompt showed the drives contents so there was no way for me to move on to step 6 on.....

Not sure what to do now.... This is getting quite annoying. Seems that commands that should work, don't or things that are there are not being found when typing in the commands properly!!
My System SpecsSystem Spec
28 Oct 2009   #8
Microsoft MVP

Windows 7 Ultimate 32bit SP1

There is another command (to try) in this article How to repair MBR on Windows 7 |
My System SpecsSystem Spec
28 Oct 2009   #9

Windows 7, 64 bit

A bud of mine on another forum gave me the correct command to get the MBR fixed...

at the prompt type
bootrec /fixmbr
press enter

Now not sure what was happening with my DVD drives not being found when using the source command in the Command Prompt but at least that's fixed now.

It would be nice to get the old Linux GRUB boot manager out of the other drive though. Not sure how to look for that. Seems to be hidden. Sneaky!!
My System SpecsSystem Spec

 First post... Issues with MBR

Thread Tools

Similar help and support threads
Thread Forum
OS deadlock issues persisting post-OS reinstall
So I've been running into this issue within the last month where I'll be either gaming, website browsing, or listening to music, and my PC will stutter for a brief second and then everything will lock up. I won't be able to move my mouse and keyboard stops working. However, the screen doesn't...
BSOD Help and Support
First build issues; Freeze after POST beep
hello! so im building my first PC but i'm experiencing a problem :( my motherboard (Biostar Hi-Fi A88W 3D) beeps POST beep but it doesn't let me press any keys on my keyboard for bios/etc. The screen kind of freezes on the boot up logo with the options to proceed. I've tried jump clearing CMOS,...
PC Custom Builds and Overclocking
Performance Issues,i tried everything possible(Detailed post)
Hi there,I'm sorry for the general title,but I didn't find a way to put it any better. I'm currently sitting on an Acer Aspire 5830TG with Windows 7 on it,the computer is 9 months old.I will list It's characteristics if needed,but the core is that it has plenty enough specs to NOT have the...
Performance & Maintenance
My first post, Sims 1 issues
Hello everyone, I'm glad to actually have found this community and have heard from a few friends that if you have issues with some PC related things, this is the place to go. But enough flattery on my part, let me get to my issue. I recently went through my CD book and found my old Sims 1 CD....
Yes, another post about wireless issues
I've been searching for a solution to this, but haven't found one yet, so I thought I'd try here to see if anyone had an idea. I just upgraded to Windows 7 three days ago. Before upgrading, I was able to connect to my work wifi just fine. After upgrading, I connected to my wifi and my...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:52.
Twitter Facebook Google+