Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot Delete File in Windows 7 x64

22 Mar 2014   #1
ArchitectEngine

windows 7 x64 Pro
 
 
Cannot Delete File in Windows 7 x64

I have logged in as I always do as an ADMINISTRATOR..... I am trying to delete a file in by C: drive to allow for more room to install more programs. When I right click and select DELETE it says I require permission from Adminstrators to make changes to this folder.

I then go to the folder, right click on it select SECURITY, go to ADVANCED, then to OWNER and I have currently have ownership of the folder. So what is the problem?


My System SpecsSystem Spec
.
22 Mar 2014   #2
bigmck

Windows 7 Home Premium 32-Bit - Build 7600 SP1
 
 

When the prompt comes up that says "You Require Administrator Permission", there should be something on it to click so that you immediately have the permission.
My System SpecsSystem Spec
22 Mar 2014   #3
ArchitectEngine

windows 7 x64 Pro
 
 

Nothing like that comes up......
My System SpecsSystem Spec
.

22 Mar 2014   #4
ArchitectEngine

windows 7 x64 Pro
 
 

When I right click to DELETE....All that it says is that You need permission to perform this action You require permission from ( Name of administrator I am logged in as) to make changes to this folder I get TRY AGAIN OR CANCEL
My System SpecsSystem Spec
22 Mar 2014   #5
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64
 
 

Some files Windows 7 won't let you delete. Could you tell us what you are trying to delete?
My System SpecsSystem Spec
23 Mar 2014   #6
paul1149

Linux Lite 3.2 x64; Windows 7, 8.1
 
 

Make sure you also have ownership of child objects. When you take ownership there's a box you need to check.

Take Ownership of file
My System SpecsSystem Spec
23 Mar 2014   #7
Brink

64-bit Windows 10 Pro
 
 

Hello ArchitectEngine, and welcome to Seven Forums.

In addition, you might see if you may be able to delete the file with the free program Unlocker.

Hope this helps, :)
Shawn
My System SpecsSystem Spec
Reply

 Cannot Delete File in Windows 7 x64




Thread Tools




Similar help and support threads
Thread Forum
Windows Fails to Delete a File, Can't Even Identify It
Hey, everyone. Recently, I've gotten into music production with FL Studio, and I just exported a song. For some reason, the exported file can't be run by any program, and my computer is really slow. I'm 90% sure it's this file that's slowing my computer. My CPU load is constantly at 100%, with...
General Discussion
Unable to delete a file,can't delete it can't shred it,
I looked at my firewall events earlier and i saw a file had been trying to connect to the internet but had been blocked by my firewall. Whenever i install a program i am unsure of i block the exe file from connecting to the internet until i'm happy its a safe program. The file is...
General Discussion
How do you delete a file Windows can't find?
Hey there. I'm trying to clean my computer up a little, but for some reason, there's a file that it "could not find", even though it's showing it right on the desktop! What happened? The screen clipping is attached. If you're wondering, that's a Google Chrome extension installer. Garbage. ...
General Discussion
How to delete previous windows file.
I re-installed Windows 7 from (C: ) to (D: ) and it had left program files, program files (x86), and windows. I was able to find a command prompt that changed the ownership of the files and allowed me to delete the proram files but it will not work on the windows folder and I can't find any...
Performance & Maintenance
unable to delete a file (windows says its in use)
Well it happens to both of my video files (mkv) right after i've extracted the file. What puzzled me is that it says windows explorer is using it which i ddn't even play the video. I tried looking around in task manager trying to stop the process but stopping explorer.exe would end up closing...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App