Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Services disabled and unable to start, no internet, no firewall, etc.

24 Mar 2014   #1

Windows 7 Home 64-bit
Services disabled and unable to start, no internet, no firewall, etc.

Hello sevenforums

After having absolutely no issues when I shut the computer down, to the computer acting strange and having several issues at the next startup. The issues are mainly related to the network, but not limited to it, so I decided to post it here, but unsure if it is the correct forum.

Note: I'm translating all messages from Danish to English, so they might not be completely accurate.

Issues are currently that I am not able to connect to the internet with the message: "service or group dependency failed to start". I'm unable to turn on the firewall with the following error: "Error 0x8007042c". Several services are't starting and I am unable to start them, I get "Error 5: Access denied", I was able to fix this on the diagnostic politic service, by editing permission in the registry editor at two folders called WMI and DPS. I'm currently scanning the computer with MSE, but I somewhat feel this is going to be a waste of time, but it is currently my last resort, except repair with Win7 CD or formatting of course. In my my task manager there is currently nothing taking CPU power at all, yet CPU use is at 30-50%, I'm guessing MSE is using CPU power, but why is it not listed?

So far I have tried the following:
sfc /scannow (Found no issues)
netsh reset
Changing permission in registry to get diagnostic tools working (Which then found no issues or where unable to fix it)

Any ideas or suggestions?

My System SpecsSystem Spec
31 Mar 2014   #2

Windows 7 32 bit

Do you have a Restore Point from before the issue? It sounds like it can't hurt to run it if so. Also I would try a full scan with Malwarebytes Antimalware if the Restore Point doesn't eliminate the problem.

Edit: MBAM free version is just fine for scanning.
My System SpecsSystem Spec
31 Mar 2014   #3

Windows 10 Pro

It sounds like a serious infection to me.

Alternatively you can use this here:

Services - Restore Default Services in Windows 7

To download the services and restore the ones you are having issues with.
My System SpecsSystem Spec

31 Mar 2014   #4

Windows 7 32 bit

It sounds like a serious infection to me.
Yeah. I'm thinking the OP should check for a rootkit. But let's see if MBAM shows anything.
My System SpecsSystem Spec

 Services disabled and unable to start, no internet, no firewall, etc.

Thread Tools

Similar help and support threads
Thread Forum
Unable to start Windows Firewall
I did a clean install of Windows 7 Professional x64. I installed all the usual programs (Microsoft Security Essentials, Firefox, etc). In under a day, I was infected with a virus (the Win 7 Antivirus 2012). I believe it was a false "Update Adobe Flash Player" window that did it. I removed it...
System Security
Unable to start windows firewall
I am using windows 7 – 64 bit ultimate. My firewall has not been running for a long while. I am using Kaspersky internet security 2016. I tried uninstalling it. But still my firewall doesn’t run. I went to services.msc using the Run command and tried to start my firewall but I got this error. ...
System Security
Windows firewall blocking .exe file even after firewall is disabled
Hey everyone, This is my first post, and first time I've not been able to solve my problem by searching previous hopefully someone can help me out. I'm trying to install a downloaded .exe file, and Windows firewall is blocking it regardless of whether the firewall is active or not; the...
System Security
Security Center and Firewall Services are disabled on each boot
Hi all, I have this weird issue with my windows 7. The security centre service and the Windows Firewall are always on disabled status after each boot. The start-up type is Automatic for both of them but it won't stick after a boot has been placed. Please help me solve this issue. ...
System Security
Start up options disabled in services
Hello guys, Please help, my Start up buttons are disabled in services. I 'm not able to start or stop the services as both the buttons are disabled. Earlier it were working but it is not active now. please check the attachments
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:09.
Twitter Facebook