Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SSD boot record borked -will boot to windows normally with CD in drive

16 Apr 2014   #1

Windows 7 X64 Home Premium
SSD boot record borked -will boot to windows normally with CD in drive

Hello, I'm Henry.

I'm fairly new to Windows 7 though I have lots of experience with Windows XP.
I forced myself to upgrade before the April 8th deadline though I knew I would loathe the experience.

This build is about three weeks old. I put in a Sandisk X110 64GB SSD and I have a WD 500GB drive.
I also had my XP build on a 2000GB WD drive. When Win7 installed it setup a dual boot with the old XP installation.
In typical MS fashion it gave me no options of where to store the boot information.

I installed Win7 to the SSD and am using the HDD as a location for everything not system related.

A week and a half ago I removed the dual boot setup as it was no longer needed, but had to go through the setup to fix the boot record etc. Seemed to have worked fine except the installation now shows the installation as "Windows 7 (recovered)". It WAS working without issue. None at all. Then this morning for some unknown reason the system decided that my router was an "unknown network". I have two routers, one is connected to the cable modem downstairs the other is set to pass through. All of this was working normally until it stopped this morning.
(Cannot use wireless due to interference in old building w/ steel beams, aluminum electrical wire and foil air duct).
I reset everything including the computer. That's when the real problem began: the system now hangs at the "verifying DMI pool" and shows a series of dots as it is doing so.
It stops before noting success and hangs. It does this unless I put in a bootable CD or use the F12 key to select the boot device.
I fixed the (extremely annoying!) networking issue with the reset but the boot problem remains.

I went through the Windows 7 repair option. Let it do it's thing. Tried the "bootrec /fixmbr" which reported success, but "bootrec /scanos" says there are "0" OS found.
Likewise "bootrec /rebuildbcd" also completes with "0" OS repaired. Neither fixmbr nor rebuildbcd options fixed the problem though they both reported no errors and instead success.
The GUI option to fix whatever is making windows not boot also reported "0" OS were fixed though my installation shows up in the box except for the aforementioned
"(recovered)" part appended onto it.

The only way to boot is through the aforementioned F12 or bootable CD.

The BIOS on this mainboard doesn't have an explicit option to set the SATA ports to AHCI. Setting SATA ports to Advanced seems to be the option (per several online threads
about the G41M-ES2L) to make it work right and that is what I set it to prior to installing windows 7.
No changes to these settings have been made thought since I installed windows. I checked that they are unchanged.

So after all of the above how do I make it go back to working? I looked in Disk Manager under Windows 7 and YES the SSD is Active and shows as the "Boot, Active, Crash Dump, Primary".
The HDD shows as "System, Active, Primary". I'm not sure why it made the HDD active when I formatted it since I don't remember doing that part.
But I suspect if it wasn't I think I might not be booting at all.

Through all of this the computer works just fine once I get into windows. I'm using the system to type this and there are no issues whatsoever.

So the only way I can boot normally is with either the CD in the drive or by using F12 and selected the HDD.
It's obviously a borked MBR, but how do I make it fix it if bootrec is not showing the installation? Is there a way to force it to detect the installation?

One other thing of note: we had a power brownout during a hard thunderstorm two days ago. The computer restarted and checked the drives for consistency.
All tests passed without issue. I even ran the test a second time manually to be sure. No errors found. I also let it do the check before startup and again no errors found.

What am I missing? I seem to have done everything I know to check and/or do. What else should I do?


My System SpecsSystem Spec
16 Apr 2014   #2
Microsoft MVP


Hi Henry -

I thought you deleted XP so am not sure why the System flag is still on the hard drive. It signifies the partition which is booting Win7, but also needs to be marked Active to successfully do so.

To repair this, unplug the HD and run Startup Repair - Run 3 Separate Times which will attempt to repair and then write the System boot files to Win7 partition since they were never put there but instead added to XP during installation.

Once Win7 partition starts, is labeled System Active and boots itself, you can plug back in the other HD making sure SSD remains set first drive to boot in BIOS, mark the HD partition Inactive which should keep it from interfering although the best way to do this is move the data off and delete the old System partition. Partition - Mark as Inactive - Windows 7 Forums
My System SpecsSystem Spec
16 Apr 2014   #3

Windows 7 X64 Home Premium

I am not sure how all this got started. I had long ago removed the XP partition and wiped it in favor of two partitions I was storing backups of two friends' computers that I upgraded to windows 7. Both partitions have windows XP not windows 7. These were cloned using clonezilla or cloneHDD to make 1:1 images as backup. The first of these partitions also was a flagged as a bootable drive, but it wasn't affecting anything. I was able to unplug the drive without issue.

This boot problem happened today and I suspect that power failure on Monday is related. I used a copy of Puppy Linux with GParted to switch the boot flag on the second HDD off. Seemed to work. Also found the boot flag on the 2TB HDD turned on and switch that off too.

I was able to still get back into windows 7 through the work around after doing these two changes.

I tried to run the repair options and ran into the infiinte hang of the repair tool. It just sat there for two hours doing nothing.
I restarted and then it wouldn't boot from the prior work around options anymore.

I ran the repair thing a few times and it kept hanging during the supposed repair. That made things worse. Error 0xe000000c. Bootrec and fixmbr did nothing. fixboot and
repairbcd option each got me element not found.

I finally re-ordered the cables to the SATA ports. I also disconnected the 2TB HDD so I only have the 64GB SSD and 500GB HDD. The bios shows the SSD at top as Master, the CD/DVD drive Slave and HDD as MASTER on the second channel or whatever. BIOS is set for Enhanced which allows only six SATA ports and no IDE. Also supposed to be AHCI in this mode as I said before. This is how it was set before so no changes here.

I ran the repair thing with nothing but the SSD. This worked, but it broke the symbolic or whatever link between the HDD and SSD.
Now, I can boot normally but the user profiles I had before are now corrupted.

I should have went and tried to live with the CD or F12. After everything has been fixed the second HDD where I had moved USERS and most any program that could be stored there in Program files is now broken. I'll have to go and totally reinstall. This will be the second time actually.

BTW, the SSD really is not being properly detected by the repair program. Running the bootrec program on the now-fixed boot record yields me the answer that the number of OS found is "0" same as before. This in spite of the fact that I can now boot normally with the above issue of borked profile(s). The same result from showos number of OS found is "0".

I wish I never bothered to try and fix it. I don't restart often though I use sleep mode a lot to turn off computer.
My System SpecsSystem Spec

16 Apr 2014   #4
Microsoft MVP


Sometimes running the Rebuild Command after backing up and deleting the BCD file can overcome what you describe: How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows

You can also rebuild the User folders onto C so they can be moved again to the HD using Option Two here: User Folders - Restore Default Location - Windows 7 Forums

Your idea to reinstall is probably best. This time make absolutely sure you unplug all other drives and peripherals so that Win7 has its own boot manager.

Since beta we have helped with tens of thousands of installs here, and what has worked best is compiled in Clean Reinstall - Factory OEM Windows 7 which works the same for retail installs and will assure you get and keep a perfect install.
My System SpecsSystem Spec
17 Apr 2014   #5

Windows 7 X64 Home Premium

In spite of the fact that I can now boot normally the rebuild command tells me element not found.

Not sure what is going on there. Anyway, I fixed the broken user profile by setting the S1D registry key right. It was pointed at a null entry and needed to be fixed back to the right location. I think rebooting w/o the HDD containing the USER profile caused the problem. I didn't expect to boot into windows during one of the restarts and it went too fast to hit a key to make it boot from CD that time. All this extra headache from that one reboot. Still I don't know why this began in the first place. It began with the 'unknown network' bug that has plagued Vista and it seems windows 7 too. (I ran into it at a friend's house after having her computer here on my network it wouldn't ID her cable modem as more than an 'unknown network'.) Resetting the modem and router fixed that but why did resetting my system create all the rest of this crap I've gone through all afternoon? I'd like to know why so I can either prevent it or fix it right the (hopefully not!) next time it might happen in one go not hours of goofing around with it.
My System SpecsSystem Spec

 SSD boot record borked -will boot to windows normally with CD in drive

Thread Tools

Similar help and support threads
Thread Forum
MBR - Restore Windows 7 Master Boot Record
How to Restore the Windows 7 MBR (Master Boot Record) If you have been dual booting with Linux, then you probably know one of the Linux boot managers like Grub or LILO has been installed in the MBR of your hard drive. What can you do when you no longer want Linux on that hard drive? This...
Windows 7 boot issue with master boot record
Hello, My Old hard drive has Windows Vista Ultimate 64 bit installed on it. I purchased the Windows 7 Home Premium upgrade and ran the upgrade. Removed the Vista hard drive, and can not start Windows 7. Only issue on this system, I have upgraded two other systems without any problem. SSD...
Installation & Setup
Dual boot Win 7 / Ubuntu 12.04 borked.
I am a new member of this forum and a Windows user for the first time in ten years (Win2K). I have been running my Windows 7 install for two weeks on my home built, desktop box. When I originally installed Win 7, I erased my Linux system and let the Windows 7 installer choose which of my two...
Installation & Setup
Formated Drive and erased Master Boot Record
I'll get right to it cause this is serious for me and I screwed up royaly. My original OS Windows 7 was on a normal hard drive and I installed a second copy of Windows 7 on a new SSD drive that I got and used it as my primary and left everything on the old one just didn't delete it. When the time...
Installation & Setup
Dual-booting nightmare: XP & 7, flashed BIOS, now boot-up is borked:
Ok, I'll try and be clear and succinct, but I APOLOGIZE in advance for the super length here! Here's the essential "backstory" of what was/is going on, and where I am right now: Had an XP machine for 4 years; two months ago, I bought and added in another HD. At reboot, I put in my Win 7 64...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:04.
Twitter Facebook Google+