Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: A "unique" (?) problem with non-functioning right-click

20 Apr 2014   #1

Windows 7 Professional, 64-bit, Service Pack 1
A "unique" (?) problem with non-functioning right-click

I have what seems to be a unique right-click problem. After searching a bit, I found nothing that seemed to relate exactly to my issue.

My system is as listed in "My System Specs" (OS, CPU, motherboard, etc.).

On my system, there are setup a limited user account set, my own account (administrator-level), and also the built-in administrator account (unhidden and renamed).


Right-click is non-functional. No context menus appear anywhere at any time.


The application key on my Microsoft Natural Elite keyboard *does* bring up context menus (discovered this by chance).

Right-clicking with the mouse *does* bring up context menus in the limited user account, as well as in the built-in administrator account.

When running in Windows XP mode from my own account (I need this mode to run an application I use), the non-functioning right-click issue persists.

This problem arose seemingly “out of nowhere”. The only thing I had done recently was to run the “All tasks” (“mygodmode”) application–just as a matter of curiosity.


1. I have run SFC. No change.

2. I have run checks for malware, viruses. No issues.

3. I have run ShellExView and ShellMnView. No change.

4. I have changed the USB ports into which the mouse and keyboard are connected. No change

5. I have updated the drivers for the mouse and keyboard. No change.

6. I have uninstalled, then reinstalled the drivers for the mouse and keyboard. No change.

7. I have tried a different mouse. No change (behavior is the same as with the Wireless Laser Mouse 5000 I use).

8. I have switched the left-right buttons on the mouse from the driver software/control panel. No change. It’s just the left-click that doesn’t work. Switching back to default takes me back to my problem. At least I know the issue is not in the mouse itself.

9. I turned off system restore and then back on again. No change. (I saw that this worked for someone else.)

10. Uninstalled “Mygodmode”. Reinstalled it. Uninstalled it again. No change at any time.

11. Disconnected the keyboard (in case of a conflict of some sort?). No change.


I will connect a different keyboard (late tomorrow) to see if doing so has any effect.


I’d prefer not to do a repair-reinstall, as I might not be able to reinstall Windows XP mode, which I use for a particular application.

I would appreciate any thoughts about how to resolve the issue I’m having.

My System SpecsSystem Spec
20 Apr 2014   #2

Windows 7 32 bit

Please take a look here and see if it applies.
My System SpecsSystem Spec
20 Apr 2014   #3

Windows 7 Professional, 64-bit, Service Pack 1

I appreciate your pointing me to that link, Miles. I made the change in both places in the registry, but I am still without any context menus. Thanks for the help.

On a whim, I decided to disconnect the keyboard (have added an item 11 to my initial post). Still nothing.
My System SpecsSystem Spec

20 Apr 2014   #4

Windows 7 32 bit

Too bad. Thought I might have gotten lucky with that hit. There is something that disables right click because public library computers I've used have it disabled totally. Are you running any AutoHotkey programs in the task tray? If one has a bug it could "eat" the right click. I suspect it may be something like that because the keyboard menu key works.
My System SpecsSystem Spec
20 Apr 2014   #5

Windows 7 Professional, 64-bit, Service Pack 1



Your suggestion of looking into an AutoHotKey program was on the mark.

Last night--after way too many hours on the system--I was adding two hot keys and remember seeing the right-click defined as part of the new sequence. I corrected it so that the Windows key would be used, but only the left one. For the Windows key on the right of the keyboard, the "right-click" from the mouse remained in the definition, but I did not realize that until reading your message.

I went into my hot key application a few moments ago, and there it was: a right-click being used instead of the Windows key to the right of the spacebar. As you suspected, my right mouse button was getting "eaten".

The hot key definition has been corrected, and all is well.

It really does help to have others look at a problem one is having.

Thank you very, very much! :):):)
My System SpecsSystem Spec
21 Apr 2014   #6

Windows 7 32 bit

You are quite welcome. Glad it's resolved.
My System SpecsSystem Spec

 A "unique" (?) problem with non-functioning right-click

Thread Tools

Similar help and support threads
Thread Forum
Unable to right click-open with "there was a problem starting shimgvw"
I am having an issue opening various file formats in various applications via the right-click "Open With" context menu. Every time I try, I get the following error message: there was a problem starting C:\Windows\shimgvw.dll A Dynamic Link Library (DLL) initialization routine failed. It...
General Discussion
Aero Peek, scroll-wheel click/"click-and-hold" scrolling does not work
So, every once in a while I come across this strange issue: 1. Aero Peek suddenly stops working When I hover my mouse over windows on the taskbar, the windows preview will flash for a fraction of a second and then vanish, if I'm moving my mouse along the taskbar the window preview will quickly...
General Discussion
When I click "install now", it's saying "No device drivers were found"
Ok, now I get another problem... When I click "install now", I get a msg box that is saying 'no device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK' What should I do now?
Installation & Setup
Windows 7's "Search Programs and Files" is not functioning properly
Windows 7's "Search Programs and Files" is not functioning properly, it searches some folders, but ignores some others (which are newer), and when I choose "search again in: computer" it finds the ignored folders. any comments would be highly appreciated
General Discussion
Icons not functioning "align to grid"
Hello!my folder icons in windows 7 are not functioning"align to grid"
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:30.
Twitter Facebook Google+