Restart and select proper boot device error (no access to BIOS)


  1. Posts : 2
    Windows 7 Home Premium 64 bit
       #1

    Restart and select proper boot device error (no access to BIOS)


    Sorry if this is in the wrong subforum.

    A few months ago I built a new computer. Had no issues with it until now. I recently decided I wanted to setup multiple monitors and needed to move my tower to make more room. I unplugged all the external cables, moved the tower and plugged them back in. It booted absolutely fine yesterday after I moved it and I didn't do very much with it (small bit of gaming, watching some videos and web browsing).

    Today when I turned it on the PC will display the MSI Motherboard screen (with the press F11 or Delete prompt) before cutting to the "Restart and select proper boot device" error.

    Specs are as follows (to the best of my knowledge):
    MSI Z87-643 Gaming Motherboard
    GTX-760 Nvidia MSI Graphics Card
    16GB RAM
    i5 4670K Processor

    2x 1TB Hard Drives
    1x 128GB SSD (This has the OS and a few programs (just Office and Adobe CS6))

    OS is Windows 7 Home Premium 64 bit


    So far I've checked some of the internal cables, they all seem to be connected securely and the PC worked fine yesterday and hasn't been moved since. I've tried unplugging all my peripherals (also have a 4TB external HD) but that doesn't help.

    Furthermore I am UNABLE to access the BIOS. Not sure what is going on but when I boot the PC the lights on my keyboard flash on momentarily before cutting out. If I remove the USB and replace it so that it is almost fully in the socket then the lights stay on but in neither case does the keyboard have any functionality. So I can't access the BIOS or boot menu nor can I press any key when the error appears. I've tried it in several USB ports and the same thing happens in each one. I've also tried another keyboard which still provided no functionality. I know the keyboard work as they connect and function fine with my phone.

    Finally I've tried putting the original disk in the drive and seeing if anything happens but it doesn't change anything.

    So any ideas?
    Thanks
      My Computer

  2.    #2

    Try another method to Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS. You need to be able to enter BIOS setup to check if HD is detected and work through the other steps for Troubleshooting Windows 7 Failure to Start.

    But it sounds like it could be a mobo problem. As a last resort try another blank HD, or wipe with Diskpart Clean Command to see if Win7 installation media will autostart as it should, Clean Install Windows 7 to see how that goes.
      My Computer


  3. Posts : 2
    Windows 7 Home Premium 64 bit
    Thread Starter
       #3

    Thanks for your help. In the end I didn't need to try clearing the CMOS. I got back from work and decided to try one last thing: disconnecting all the hard drives so that just the SSD was connected. Took the case apart, looked at my cabling and realised it was going to take too long so I'd do it tomorrow. Just for good measure I decided to make sure again that all the cables were pushed right in. Did that, booted and it worked fine.

    So in the end it was just a faintly loose connection (nothing you could see and I didn't feel like I'd made a difference pushing the cables in). I strongly recommend anyone that has problems like this to ensure the cables are all connected properly first; even if they look connected they may be a tiny bit loose which ultimately caused my problems. A simple fix that makes me feel like an idiot. But we all need to start somewhere.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:52.
Find Us