Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Frustration..................GRRRR

18 Jun 2014   #1

64 bit

Hi All

My prob is that I have a programme SAGE Accounts that when I try to open it goes error in accessing (prog name) J drive device not ready.

I have checked in programme files and the path is set as it should be "C:\Program Files (x86)\Sage\Accounts\Sage.exe"

Yet it will only go to the J drive, I have deleted and reset shortcut but still same error in trying to opening the file................. Any help would be appreciated


My System SpecsSystem Spec
18 Jun 2014   #2

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

I believe SAGE is the former Peachtree Accounting. The problem may be associated with where the program's backups are being done or have been done. Is the J: drive still connected to the computer? Should be a setting to change that to a different location, either on the same HDD or something else. Basically this can happen with USB Thumb/Flash drives and USB External HDDs when they get unplugged or the drive letter has changed.
My System SpecsSystem Spec
19 Jun 2014   #3

64 bit


Thanks for suggestion; the J drive is no longer attached neither is the main drive partitioned; what happened is the original HDD failed The Click of Death..........a replacement drive with Windows 7 was installed. What I cant get my head around is why does it not launch from the original programme ???? It's there on the main drive with the correct path etc.............
My System SpecsSystem Spec

19 Jun 2014   #4

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

When you replaced the HDD did you reinstall all your programs? Or were they just copied? Windows-based programs have to be installed from disc or downloaded executable files so as to create the proper registry entries, make entries in Control Panel, Programs and Features, create Start Menu items or the programs can't run properly.
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
WLM language frustration
I am using Thunderbird but I find that it takes forever to load. I would very much like to use WLM instead because it loads like a flash. But there is frustration there also: namely that you have to set the default language before your start writing. My correspondence is mainly in English, Spanish...
Browsers & Mail
co-processor frustration.
I've been searching up and down, left and right, inside and outside the internet for anything to help with the co-processor problem. Nothing has worked. I have a Compaq Presario f700 laptop, AMD Turion 64x2, Nvidia GeForce 7000m/ nForce 610m. My chipset is nForce 560. motherboard is a quanta....
BSOD Frustration
On a daily basis, I get the BSOD. It happens when I am on Facebook, playing games like Frontierville or Who Wants to be a Millionaire. It also happens when I am I am just surfing the internet. What's going on and how can I fix it???
BSOD Help and Support
Ebay Frustration
So I recently decided I was not going to use ebay anymore due to their lack of customer service and the amount of commission they take. They had some promotion where you could list anything for 10 cents with any starting price so I figured I'd give it one last go. The only thing that sold is a...
Chillout Room
WEI CPU Frustration
So I'm stuck at a 7.8 CPU score with an overclocked (4.00GHz) 980x. The only component that seems subpar is the encoding, e.g. <WinSPR> <CpuScore>7.8</CpuScore> <CPUSubAggScore>7.9</CPUSubAggScore> <VideoEncodeScore>7.7</VideoEncodeScore> </WinSPR>
Performance & Maintenance
I installed win7 home premium x64 the first time and it worked fine until i restarted the pc. It refused to boot. I tried all the repairs etc. After failing to reinstall 9 times I bought 2 brand new HDs. I am on my 14th attempt at installing. The new drives are totally unusable it seems. I am...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App