Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Seagate Central 4TB unable to link with Windows 7 Wireless network.

30 Jun 2014   #1

Windows 7 Pro. 64 bit.
Seagate Central 4TB unable to link with Windows 7 Wireless network.

I tried looking in FAQs but was unable to find any related information.
I have filled in my System Specs.
Recently purchased a Seagate Central 4TB Shared Storage, but it does not link or show up as a network device. I downloaded Seagate Discovery Tool software, which sometimes can 'see' the network drive.
The computer is ethernet connected to the Wireless/Router.
What I find perplexing is I have a Dell xps M1530 laptop running a Linux OS and uses wireless connection for the internet; can 'see' this Seagate-network device.
If this problem has already been dealt with, would you please direct me where I should look to view the information, thank you?

My System SpecsSystem Spec
30 Jun 2014   #2

Windows 7 Ultimate 64-bit

Hello i have a seagate as well!

Have you had a look in your network folder to make sure its not "Hidden".

Also try to add a new wireless device;

My System SpecsSystem Spec
30 Jun 2014   #3

Windows 7 Pro. 64 bit.

I have in Folder Options Show hidden files, folders or drives checked
Also tried Add a wireless device in Network, but it fails to see the Seagate unit.
On my Wireless/Router I have Powered it off and on to see it that might assist, but made no change.
Using the software Belarc Advisory Computer Profile it lists the device : Network Storage Seagate-3fb95e (in WORKGROUP). But I still can get it to connect
My System SpecsSystem Spec


 Seagate Central 4TB unable to link with Windows 7 Wireless network.

Thread Tools

Similar help and support threads
Thread Forum
Seagate Central NAS
Hi. A while back I bought the Seagate GO Flex NAS. It has horrible software. Seagate didn't help at all. The main problem was a sign on is required to access and use the drive. This of course made it impossible to automatically run backup software where there is typically no place to enter a...
Backup and Restore
Unable to remove old wireless network
Hi I've just changed providers and now have a new router. It's still appearing in "manage wireless networks". I've removed this network so that there is only one listed however when I log off & back on again, it re-appears. My account is an administrator account so I should be able to do this. ...
Network & Sharing
Unable to detect specific wireless network following Windows 7 install
I have just installed Windows 7 onto my Dell Inspiron 6400 laptop. My laptop now detects a number of wireless networks in the vicinity but not my own. It is not a problem with my router because other laptops can pick up the connection no problem. I have Googled this problem and see a lot on issues...
Network & Sharing
No Internet Access on wireless network (TP Link)
I'm using DELL D620 laptop with Win 7 Ultimate OS, and I have trouble connecting to a wireless network, in fact I can connect to a network but I dont have internet access, I'm using TP-LINK (WR 741 ND (Annex B)) router. Does anyone know how to fix this? My boardband connection is working on a...
Network & Sharing
PC unable to see wireless network
Prior to Saturday morning, my computer was able to detect the router and connect to the internet. However, as of yesterday, my computer is no longer able to see any wireless networks. My dad did change the frequency of the router yesterday, but all the other PC's in the house are able to connect...
Network & Sharing
Unable to connect to ANY wireless network
Just started having problems connection to any network or internet. Have new lappy that was working great until today. I am going out of town for a while and I was setting up my Slingbox. Somewhere along the line, I lost ANY connections, even to the router. Have tried 3 different restore...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App