Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Ongoing attempt at Windows 7 C Drive Restoration, help required

10 Aug 2014   #1

Windows 7 Ultimate x64
Ongoing attempt at Windows 7 C Drive Restoration, help required

I'll try to summarize everything that's happened so far. I am using Windows 7 Ultimate 64 bit SP1.
If you do not care for historical summary I have titled the problem I am currently stuck at near the bottom of my post. It involved using Partition Wizard.

About over a week ago I rebooted my PC and was greeted with a S.M.A.R.T error signaling that my harddrive is bad and is failing. I only have a 4 year old 1TB Seagate Barracuda harddrive split into 4 different partitions. So that means my C drive was also at risk. Using defraggler, I noticed the poor health of my drive indeed, and the lost sectors were increasing. The first thing I did was run a chkdsk on my c drive. The lost sectors stopped increasing, but the damage was already done.

My plan was to get a new drive(s) to replace my old failing one. I got one Solid State Drive (Kingston ssdnow v300 240 GB) to serve as my new C drive, and a 1TB Seagate Barracuda HDD to serve as a secondary internal drive. After backing up all my other non-system data (pictures, movies) and uninstalling any program I didn't need (like games), I created a System Backup image of my current C drive on an external 1TB harddrive in an attempt to restore my old C drive so I would not have to reinstall Windows 7. Naturally I also created a System repair disk, and checked that it booted fine from my CD drive.

I installed my new SSD into my computer and initialized it for use, then disconnected my failing HDD from my MOBO. Everything was going to plan until my attempt to restore System Image via repair disk, which didn't work. I learned that apparently, if the maximum capacity of the C drive that the system image was made from exceeds the maximum capacity of the new drive you are trying to restore the image to, it won't work even if the system backup image itself is smaller (in this case 108 or so GB). In my case, the partition size of my C drive was originally 250 GB in capacity, and my new ssd is 223 GB in capacity after installing.

So what I do is go back to my failing harddrive, and attempt shrink my C drive partition from 250 GB to at least 220 GB. So that I could create a new System Backup Image. But I can't do it with the default Windows Disk Management due to system files getting in the way of shrinking. I have read many suggestions on using Partition Wizard Free Bootable CD to shrink partitions from outside of Windows 7 via bootable CD.

Here is the problem I am at right now:

So I download and make a bootable disk for Partition Wizard and boot from it. When I attempt to shrink my C Drive volume, it runs for awhile before pausing, aborting and giving me an "Error 19 ntfs file system error" and suggests I use its System File Checker on the drive. However, this option is greyed out on the menu. Searching online reveals that Partition Wizard's system file checker can only be used on drives that are lettered. But wait, all my partition are for sure lettered! I mean we're talking about my C drive! I have not found any explanation on why Partition Wizard is not displaying my drive letters in the list. But I have read suggestions to do a chkdsk instead.

For those curious on how I do the chkdsk, I got onto windows, right click my C drive and enter properties then click the Check Now button. It won't run while windows is running of course, so I have to reset my computer for chkdsk to run on my C drive.

So I do another chkdsk on my C drive once more and attempt again to shrink my C drive via Partition Wizard, but once again it gives me an "Error 19 ntfs file system error" message and does not display my drive letters nor let me use its System File Checker.

For now, I am attempting a chkdsk on my other existing partitions of the same failing HDD, thinking that perhaps those are affecting it. But I am having trouble as my failing HDD is now periodically "disconnecting" and freezing up windows, causing a need for hard reset.

I am aware that I could, and should reinstalling a fresh windows 7 now, but I would like to know what options or help I have left. If you need anymore specific info on my problem or computer hardware, please ask and I'll do by best to provide.

My System SpecsSystem Spec
10 Aug 2014   #2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

You could mount the windows system image .vhd file ( using diskpart ), then make an image of the mounted vhd using another imaging program,.

You should then be able to restore your newly created image to the ssd.

You can use this freebie for the image and restore process:

Windows 8.1, Windows 8, Windows 7 Free Backup and Restore Software

Sounds like you will need to do that from bootable media.
My System SpecsSystem Spec
10 Aug 2014   #3

Windows 7 Ultimate x64

This sounds like a great new suggestion to try. If I'm understanding you correctly, I log onto windows and...
1. Install AOMEI Backupper Standard For Win7 if I hope my harddrive won't completely fail on me
2. Use the bootable version of AOMEI (it has one by the looks of it?)

and use Command Prompt to utilize "diskpart" and mount the backup image on my external harddrive. Then somehow I use the AOMEI program to create a new image out of the old one?
And this should circumvent the problem of default Windows System Backup Images being limited by the backups original maximum capacity? Will the new image created by AOMEI be able to be utilized like a normal system backup image and be restored using Windows 7 repair disk?

This stuff is new to me (I have no idea how to mount .vhd using diskpart) and I am unfamiliar of how AOMEI works obviously. But for now it's a different direction and I'll starting looking up online and how to do these things.

If you feel like spoonfeeding me some steps on how to do all this though, it would be nice and I'd appreciate it
My System SpecsSystem Spec

10 Aug 2014   #4

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

If you can get into windows 7:

First install aomei, and tell it to make winpe recovery media.

then you can mount the .vhd using disk management.

Ongoing attempt at Windows 7 C Drive Restoration, help required-dm-vhd.jpg

Make sure it has a drive letter, image it with aomei.

You can restore the image using the aomei winpe media.

My System SpecsSystem Spec
11 Aug 2014   #5

Windows 7 Ultimate x64

Thank you SIW2. Due to your prompt responses and great software suggestion, I was able to restore my old C drive onto my new SSD and put an end to my weeklong arduous journey within a few hours. Who knew the answer was as simple as "Don't use Windows 7 default system backup"?

Hopefully, it'll be smooth sailing from here. I'll need to tweak windows setting to work better with SSD now and clean my registry. I also hope that the harddrive failures from my old C drive won't affect my new SSD in anyway. I think it's safe to mark this solved for now.

Thanks again SIW2!
My System SpecsSystem Spec
12 Aug 2014   #6

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Glad it worked for you.
My System SpecsSystem Spec

 Ongoing attempt at Windows 7 C Drive Restoration, help required

Thread Tools

Similar help and support threads
Thread Forum
Install USB Windows 7 asks for required CD/DVD drive device is missing
I used DBAN to wipe my hard drive and i forgot to back it up. I do not have the CD for Windows 7 installation, therefore I created a bootable flash drive for Windows 7 64bit. I can't figure out what drivers is needed to continue on the installation. It says: "a required CD/DVD drive device is...
Installation & Setup
Windows 7: A required cd/dvd drive device driver is missing
I try to install Windows 7 Home Premium on an ASUS G75VW notebook - Original OEM dvd which is tested ok on other computers - not a dvd disk issue and I get the annoying error: Windows 7: A required cd/dvd drive device driver is missing The notebook doesn't have a dvd drive - it was...
Installation & Setup
Windows 7-load driver a required dvd drive device is missing
Hello, I have a Dell XPS , bought it 2 weeks ago , all good , but when I tried to re-install the nvidia graphics driver the windows crashed, and the boot system was down.Tried to fix it , couldnt , and I didnt make a backup either so I went for the format. At the moment the HDD is clean and when I...
Installation & Setup
Runtime error C drive Windows Explorer - assistance required
I have been given the incorrect information on this forum and noticed that I have a file on my hard drive that is locked. The person advised me to go to Download Microsoft Visual C++ 2010 Redistributable Package (x86) from Official Microsoft Download Center I have done this and it has...
General Discussion
Install+Run Windows Without a Hard Drive - Attempt Failed.
Hi everyone, My eMachines eM250 netbook currently has no hard drive as the old one broke a couple of months ago. In an attempt to get the computer up and running again, i ran it on Ubuntu 12.10 through a bootable USB memory stick which worked fine. Unfortunately Ubuntu isn't really good enough...
Installation & Setup
Deleted Registry Entries in an Attempt to Repair CD-Rom Drive
My situation: My CD/DVD-Rom drive is unresponsive (it opens and closes normally) and does not show up on Device Manager. I read a guide that suggested that I have corrupted registry entries. It told me to delete UpperFilters and LowerFilters. I deleted the two entries (and possibly others in...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App