Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: How to copy and paste protected & in-use system files?

02 Sep 2014   #1

Windows 7 Home Premium
How to copy and paste protected & in-use system files?

I would like to attempt to copy an untouched .NET 2.0 directory from a second PC here at home (identical install of Windows) but when I try there are files in use by the system and some say they can't be copied because they are protected system files.

Is there any way that I can accomplish this, both copying the .NET 2.0 directory from another PC, and copying it in its entirety to this PC? I assume this would have to be done outside of Windows but have no idea how to do this. Can anybody help me?

If You're Curious, This Is Why I'm Asking
A while ago I had a mishap and some system files in the Windows directory were deleted. I was able to restore everything, or so I thought, without any issues. Windows has been operating, without issue, for well over six months now, with the exception of Microsoft Framework .NET 2.0. Any app coded for .NET 2.0 crashes when I try to start it (no error code). The registry was not affected during that fiasco so I assume all .NET 2.0 registry entries are completely intact.

Note: I have extensively researched repairing, reinstalling, and replacing the .NET 2.0 installation. I have tried every official and unofficial tool that I could find. Unfortunately, all tools only affect .NET installations you installed to the system. Given that 2.0 is a part of Windows 7, I am unable to fix this using any normal means. If I wish to have a working .NET 2.0 I need to perform a clean install. This is the last possible thing I can try, as far as I know.

My System SpecsSystem Spec
02 Sep 2014   #2

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

On my Win7 Ultimate and Win7 Home Premium I have .NET Framework 3.5.1 in Control Panel, Programs and Features, Turn Windows features on or off. It appears that Only 3.5.1 came with Win7.

In Programs and Features I have .NET Framework 4.5.1.

The downside of .NET Framework is that many programs are written to use only a specific version but they usually install that version if it is not present, there seldom seems to be any backward compatibility with a newer version.

My thought? Try to determine which program/s need it and reinstall that or look on the disc for it.
My System SpecsSystem Spec
02 Sep 2014   #3

Windows 7 Home Premium

If you browse on over to X:\Windows\Microsoft.NET\Framework\ you'll see all the versions you have installed. I bet you'll find 1.0, 1.1, 2.0, 3.0, 3.5, and 4.0. All version of .NET, at least from 2.0 and on, are backwards compatible with previous versions. You can even force an application to use a later version of .NET to get it working (which is what I'm doing now on a per program basis).

Reinstalling a program wouldn't do anything if you have a corrupted .NET installation. Also, looking for an original .NET 2.0 installation doesn't matter. You cannot install .NET 2.0 into Windows given that it is already a part of the OS (not to be confused with installed). It is integrated into Windows 7.

Any chance you can help with me with my file copying issue ?
My System SpecsSystem Spec


 How to copy and paste protected & in-use system files?

Thread Tools

Similar help and support threads
Thread Forum
Copy - paste files not working
Hy, need some help! I've been trying to paste some files on my laptop, the "copy" button on right clicking a file is available, but the "paste" stays light shaded (grey) or not appearing, like if nothing was copied before it. And even Ctrl + C/ Ctrl + v is not working - no file on my windows can...
General Discussion
copy/paste multiple files get really slow
Hi guys, Recently,I noticed a significant drop in speed when copy/paste more than one files,as in the chart below.Then I tried fastcopy,and it seems my hard drives work fine. So what is wrong with explorer.exe ? Thanks!
Performance & Maintenance
Can't paste/copy or drag and drop any files
Hi! First of all my english might be bad sorry for that, I try to explain my problem as good as I can. So, as the title says I can't paste or copy, drag and drop any files. Nothing to nowhere. To copy a file and put in the same folder also don't work. Ctrl c+v also don't work, but when I...
General Discussion
BSOD & cannot copy, paste, delete or rename files and folders
(you know what? BSOD just happened right before i click the submit button. -_-* luckily Chrome's restored back this page and i don't have to type everything again..) BSOD started like a week ago. I've been trying to find ways of why it happened or what to do stuff, found one, tried it but to no...
BSOD Help and Support
Copy/Paste Files through Remote Desktop
Running Remote Desktop from Windows 7 Ultimate x64 to Windows Server 2003 Std. Can't copy a file from W7 and paste to WS03 or vice-versa. No problem with copy/paste text from an app on W7 to an app on WS03. Three other machines in the office running Windows 7 Pro x64 to the same WS03...
Network & Sharing
I cant copy/paste/cut files/folders in my harddisk!!!!!
sorry to bother and disturb all of you,but i found out the reason behind my problem.actually i installed an application "teracopy" for copying files faster between disks/partitions,and it was causing all the mess. all are advised not to install "teracopy" with windows 7.thanks for ur great support...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App