Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to empty Recycle Bin: "Need Admin Permissions"

14 Sep 2014   #1

Windows 7 Professional 64 bit, SP1
Unable to empty Recycle Bin: "Need Admin Permissions"

My laptop is part of a corporate network. I occasionally connect a vpn to access network files but mostly use it as stand-alone. I also have PGP Desktop to encrypt my hard-drive which is synchronized over the network when I am connected for backup. My user ID has administrator permissions.

Today i tried to empty the recycle bin which was quite full. I received a message that i needed admin permissions. for some of the files. After repeated attempts, I got to one stubborn file that will not go away, yielding only the need permissions error. I tried logging in as local admin but could not access my recycle bin from there. I tried logging into the VPN before deleting, I even tried to restore the file but still got the same error.

I spent a couple hours looking on the internet but didn't find anything useful

Any ideas would be appreciated. Attached is an image of the error. Interestingly the file name listed in the error is not the same as the file I am trying to purge.

Attached Images
Unable to empty Recycle Bin: "Need Admin Permissions"-eme.jpg 
My System SpecsSystem Spec
14 Sep 2014   #2

Windows 10 64 bit

The PDF file is a temporary file as it has a "$" at the beginning.

However, there is really no need to empty the recycle bin. It is limited to a certain size. When it gets full, the next file that is sent to the recycle bin "bumps" the oldest, which is deleted.
My System SpecsSystem Spec
14 Sep 2014   #3

Windows 7 Professional 64 bit, SP1

Thanks fireberd. Based on your explanation, I deleted another file, then emptied the recycle bin. I got the same error, but then the recycle bin was empty! ...not sure why.

I know that this is a virtual workspace, but knowing something was stuck bothered me. Now it is clean and I can relax
My System SpecsSystem Spec


 Unable to empty Recycle Bin: "Need Admin Permissions"

Thread Tools

Similar help and support threads
Thread Forum
Assigning "domain user" to "local admin" on select PCs
I'd like to assign a few select "domain users" to be local admin over their test machines which log into a domain. The test machines are Windows 7 64bit and the domain is Win2k8 R2. I have been searching around for the best way to do it but I've come up short on my search. Anyone know off the...
Network & Sharing
"Unable to elevate to admin rights" error, when admin user
I am trying to download Adobe Digital Editions and I keep receiving the error message Unable to elevate to administrative rights, error 786 I am the admin! I have turned off the password, I have right clicked on the program and chosen 'run as admin'-then nothing happens. Any help would be...
"Empty Recycle Bin"-button gone from toolbar
I used to have a very handy "Prullenbak Leegmaken"-button (Empty Recycle Bin). You can see it in the attachment. Does anybody know how to restore that button? Futhermore, could CCleaner be the cause of it's removal? Thanks in advance!
General Discussion
Adding "Empty the Recycle Bin" to the explorer toolbar globally?
does anyone kno of a registry hack/edit that will allow me to place an "Empty the Recycle Bin" explorer toolbar button similar to the one located inside the Recycle Bin's folder, across all my folders globally? picture below to illustrate:
Way to circumvent admin Permissions "issues" with fresh install?
I am configuring a newly built computer with Win 7 (fresh, new full install) Pro. All had been going well until I tried to install Zone Alarm and found problems with it accepting and registering the license. After a couple of chat sessions, things pointed to Permissions issues. At that point, I...
General Discussion
Bypass "Ownership" and "permissions" to files altogether!
Hello all! I don't understand what the issue is but I am logged on as administrator on my computer and only a few of my files I can access. the window will pop up stating that i don't have permission to view the file! if I am the adminitrator i should have full access to any file, right? this...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App