Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WMP Server Execution Error,Save "Class not recognised" error, others.

26 Oct 2014   #1

Windows Home Premium x64
WMP Server Execution Error,Save "Class not recognised" error, others.


My father's computer, after running ADWCleaner yesterday, started behaving finicky.
At first, Explorer.exe didn't work right. It kept saying "failed to initialize".
Following some online guides, I issued regsvr32.exe over every file in the C: drive.
This fixed that problem. But other problems started showing up, the first one being the
"Server Execution Failed" by Windows Media Player.
WinAMP also gave a DirectSound error. The "Save As.." operation gives a "Class not registered" error.

I believe the registry may be corrupt.
Thus far, I have tried many things to fix the issues, such as -
  • Running FixIT, which also gave errors
  • CHKDSK, which found no errors
  • Reinstalling drivers and DirectX
  • Trying from the Administrator account
  • Virus Scans
  • CCleaner Registy Fix (I know, I know)
Unluckily, someone had disabled system restore, so there are no backup points.

Also, this computer has important files and programs on it, so a wipe would be bothersome.

What can I do to fix it?

Thanks in advance.

My System SpecsSystem Spec
26 Oct 2014   #2

Windows Home Premium x64

SFC /SCANNOW Didn't work either.
Nothing wrong found.
My System SpecsSystem Spec
26 Oct 2014   #3

Windows Home Premium x64

I ran Regsvr32 over C:\Windows and the save as error went away.
Still can't play music, although it doesn't even give an error now.

Also, When I run FixIt, it still gives an error.

My System SpecsSystem Spec

30 Oct 2014   #4

Windows Home Premium x64

OK, anyone?
My System SpecsSystem Spec
04 Nov 2014   #5

Windows Home Premium x64

My System SpecsSystem Spec

 WMP Server Execution Error,Save "Class not recognised" error, others.

Thread Tools

Similar help and support threads
Thread Forum
Eclipse IDE: "Type name is empty" error when creating new Class
Hi guys, I have always used Notepad++ for basic Java development and have manually compiled via cmdline. I am new to Eclipse IDE. When I try to add a new class to a package, this error shows up: The "Finish" button is greyed out...
websites not loading - error on page "500 internal server error nginx"
For the last 2 days, I am not able to access all google sites and from my windows 7 PC. When I tried to access these websites, I am getting a blank page with the error message "500 internal server error -nginx". Can you please suggest me what could be the cause for this issue and how...
Browsers & Mail
all video files give error "class not registered" when trying to play
The title explains it all just restored my computer and now any kind of videos files i try to play give me the error "Class not registered" what do i do? btw, yes i did update all my video drivers.
Music, Pictures & Video
The "Fatal error during the execution of Sysprep" error witch Unattend
Hi I have Windows 7 SP1 64-bit in Audit mode and I put the Unattend.xml file <?xml version="1.0" encoding="utf-8"?> <unattend xmlns="urn:schemas-microsoft-com:unattend"> <settings pass="generalize"> <component name="Microsoft-Windows-Security-Licensing-SLC"...
Installation & Setup
"Server execution failed" with wmplayer
Trying to fix my brothers laptop. He is unable to open windows media player, the message saying "server execution failed" Also, wmplayer*32 is always running in the background, even after ending the process in task manager.
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App