Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Eventvwr reporting Webcache problems

17 Nov 2014   #1

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1
Eventvwr reporting Webcache problems

This is probably a very dumb error, but I have spent weeks on this (intermittently) and can't find the cause! I figure one of you experts can probably zero in pretty quickly...

This happens on my wife's machine, and actually most apps work great, except for WeatherEye, which either starts and then dies later, or doesn't start at all. Also services/Services (Local) just spins for ever, and so did Adwcleaner.

However, all 3 of these work fine in Safe Mode.

When Pelmorex's Weathereye is running, eventvwr Windows Log/Application shows a steady stream of errors, saying

taskhost (3816) WebCacheLocal: An attempt to open the file "C:\Users\Brenda\AppData\Local\Microsoft\Windows\WebCache\WebCacheV01.dat" for read only access failed with system error 32 (0x00000020): "The process cannot access the file because it is being used by another process. ". The open file operation will fail with error -1032 (0xfffffbf8).

If I terminate Weathereye, the messages change to

taskhost (2940) WebCacheLocal: Database recovery/restore failed with unexpected error -1032.

I did a comparison of the normal and Safe Mode Bootlogs, and noticed one driver in the differences called discache.sys - could this be involved?

The odd thing is there are quite a few references to this WebCacheV01.dat -1032 error on the Internet, but no descriptions of what to do about it!

Hoping one of you can help,

Best regards,

Paul M.

My System SpecsSystem Spec
19 Nov 2014   #2

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

184 views in 2 days and not one suggestion! That's strange! And I know the -1032 error involving WebCacheV01.dat is not all that uncommon...

Forgot to mention that neither BitDefender not MalwareBytes report any problems on the machine I am referring to.

Could someone even suggest something I could look at? TIA
My System SpecsSystem Spec
22 Nov 2014   #3

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

Looks like this problem is solved - Weathereye is now staying up, and appears to be working properly after several restarts!

The problem appears to have been a corrupted WebCacheV01.dat. This was given as one of the possible causes of the -1032 error, so I decided to try deleting it. As people have noted elsewhere this is difficult as it is locked by a taskhost - also Windows Explorer doesn't show it.

I did the following steps:

- download Windows SysInternals programs handle.exe and procexp.exe
- in command prompt running as administrator, execute handle webcachev01.dat
- this gives a PID
- run procexp.exe, right click on line showing PID, Kill Process
- now, back to command prompt, locate c:\users\{USERID}\AppData\Local\Microsoft\Windows
- dir command won't show WebCache, but you can still do del WebCache (answer Y)
- do a restart

WebCache was rebuilt (not sure whether by WeatherEye or by something else), and WeatherEye is now running properly. So I am going to close this thread - fingers crossed!
My System SpecsSystem Spec

26 Nov 2014   #4

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

Lasted 4 days, and then WebCacheV01.dat went bad again - does anyone have an idea how to find what's corrupting it...?

Thanks in advance.
My System SpecsSystem Spec
26 Nov 2014   #5
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Remove WeatherEye and then do your scans.

I'm thinking you have not go a lot of response is because you have already discovered the problem program/App.
My System SpecsSystem Spec
26 Nov 2014   #6

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

Thanks, Layback Bear! I thought I had found the problem, but Weathereye only stayed up for 4 days. I deleted WebCache, and this time Weathereye only stayed up for a few minutes!

Now Handle is reporting that a dllhost has WebCacheV01 - described as "COM surrogate". Could this be the real cause of my problem - and if so, what can I do about it?

Additional info - FWIW: my machine, where Weathereye works fine (and always has) shows WebCacheV01.dat owned by (?) a taskhost associated with
- Wininet Cache task
- MSCtfMonitor task handler
- Microsoft Play Sound Service Class

This is also true for my wife's machine most of the time, however, when I ran Handle again just now, it now reports no matching handles found!

Does this make sense?

My System SpecsSystem Spec
26 Nov 2014   #7
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I have no idea what Handle is.
Browsers cache information when you browse the internet. That is normal.
If you use your browser to go to Handle it will be stored in WebCache. When you reboot your computer your Cache should be cleared.

From your post #6

this time Weathereye only stayed up for a few minutes
If Weathereye stays for anytime at all it is still on your computer some where. You will have to hunt it down to remove it.

We need the system specs of the trouble computer. Use this tutorial to help do that.

By Brink:
System Info - See Your System Specs

Include what power supply you have and what security programs you use.
My System SpecsSystem Spec
28 Nov 2014   #8

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

Hi Layback Bear, thanks for your quick answer. However there seems to be some confusion - I just wanted to do a reset:

- Weathereye is a weather program which my wife and I both use for finding out temperature, upcoming weather, etc. It works fine for me, but dies periodically on my wife's machine

- when it dies, a couple of other things just spin forever: services (local), ADWCleaner

- all these problems seem to be associated with a corrupted WebCacheV01.dat file

- when I erase the file, things start running OK again

- I have BitDefender running all the time

- I run MalwareBytes periodically

- HitmanPro found something called Roboot.exe, which seems to be PUP - I deleted it

- Handle is part of Mark Russinovich's SysInternals tool, and lets you find out the PID associated with a particular file - when everything is running fine, it reports the WebCacheV01.dat associated with a taskhost, which has Multimedia System Sounds Server, MsCtfMonitor and WinInet - could any of these be causing problems? If so, can they be fixed?

- The COM surrogate I was asking about is labelled Wininet Cache Server, so I assume that's probably OK...?

So I guess my question is: how do I trap something that may be corrupting my WebcacheV01.dat file - assuming that is not Weathereye itself, as I have downloaded multiple copies over the last few months, and it works great on my own machine...

TIA Layback Bear - hope you can help me...
My System SpecsSystem Spec
28 Nov 2014   #9
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Reading this for Microsoft might help.

Caching (Windows)

I have never run across this kind of problem before so what I'm doing is researching just like you have been doing to see if I can find something to give you guidance.

Could you list all the cleanup, tuneup and registry programs you use on this system.
Do you use Advanced System Care; many people do.

I requested you System Specs and I don't see them.
My System SpecsSystem Spec
28 Nov 2014   #10

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
Some information

Well I can't solve your problem but here's some reading material:

Forensic analysis of the ESE database in Internet Explorer 10 | Forensic Focus - Articles - covers webcachev01.dat

Also try reading the full thread (all seven pages) here:

IE10 uses WebcacheV01.dat vs index.dat files. How to clear/delete?

Based on the information in the first link in this post I regularly delete the following on boot:

C:\Users\Chris\AppData\Local\Microsoft\Feeds Cache\
C:\Users\Chris\AppData\Local\Microsoft\Feeds Cache\container.dat
C:\Users\Chris\AppData\Local\Microsoft\Inernet Explorer\UserData\LOW\
C:\Users\Chris\AppData\Local\Microsoft\Internet Explorer\DOMStore\container.dat
C:\Users\Chris\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\container.dat
C:\Users\Chris\AppData\Local\Microsoft\Windows\Temporary Internet Files\counters.dat
Now I'm not suggesting that it's a good idea to delete the above - I just delete these entries for privacy reasons. As far as I can work out you can delete Webcachev01.dat as much as you like but it will get rebuilt because it pulls data from many sources and I can't be very specific about those but deleting the above list does seem to prevent webcachev01.dat from getting fully rebuilt.

What I think I'd do if I had the same problem as you:

Run WITS (Windows Inspection Tool Set) and use it to filter Event Log by both Application and Error code 1032 to see if there's any pattern or if it might be possible to predict when the error will occur.

Click Event Log:

Eventvwr reporting Webcache problems-windows-inspection-tool-set.jpg

Then filter by Log then by Code. Click "Unfiltered" underneath "Log" then type * *Application*

Then click "Unfiltered" underneath "Code" and type * *1032*

Eventvwr reporting Webcache problems-windows-event-log.jpg

It could take a while to apply the filters depending upon the log size.

If you can spot a pattern and predict when the problem is likely to occur you could try running a ProcMon capture and check the output to see if you can spot the problem.

How to capture a Process Monitor trace

As for your question regarding discache.sys - it's running on my machine and research shows that it's a critical system file so it shouldn't be disabled.

Eventvwr reporting Webcache problems-pserv-4.0.jpg

My System SpecsSystem Spec

 Eventvwr reporting Webcache problems

Thread Tools

Similar help and support threads
Thread Forum
chkdsk eventvwr log does not show deleted files?
Anyway to show what file names chkdsk deleted after the fact? I need to create a list of files delted to see which ones are missing and I cannot seem to find any information on which files were deleted.
Performance & Maintenance
Can't restart, error 7001 prominent in Eventvwr
Don't know why. I get to log on screen and all's well. Then just a lot of black after logging in, the bar on the bottom with the time and... that's it! I had to power off improperly and then start in safe mode w networking to downloaded a tool to collect information after reading up how to submit...
BSOD Help and Support
EventVwr - 1,188 Events Since 5/2/2013! Should I Just Start Over?
My computer freezes every hour, to the minute, so checked Event Viewer. It is a sea of errors and warnings, nearly 1200 in the last 3 months. I know enough to be dangerous, but can all these problems be caused by one or a couple of things, or am in water so deep, I should just try reinstalling...
BSOD Help and Support
ReadyBoost drive keeps reporting problems on startup
I've got a 4G USB drive that I am using as a readyboost drive. Half the time it seems to work fine but frequently when I start my computer up I get a dialog "Do you want to scan and fix LEXAR (Z: ). There might be a problem with some files on this device or disk etc. Do you think the disk is...
Hardware & Devices
Wireless NIC driver reporting no problems
Hi, This is a strange one and I'm not sure where to go with it. I installed a wireless NIC in my main desktop machine (x64 Ultimate) The little tray icon reports that it has connected correctly (and I can see the local network, so it appears it has) , when I hover over the little tray...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:10.
Twitter Facebook Google+