Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Icon issue with Advanced Uninstaller's "pinned" shortcut

25 Nov 2014   #1

Windows 7 Ultimate 64bit
Icon issue with Advanced Uninstaller's "pinned" shortcut

hello again Brink!

I'm trying to fix an annoyance with Advanced Uninstaller's "pinned" shortcut. It's a pinned control panel shortcut in the start menu

A) the icon's missing and b) the link can't be unpinned.

I've tried searching this thread and the other linked (fresh out the oven: ) alas no mention of control panel's pinned items.

One interesting thing I read on advanced uninstall FAQ

  • Why "Pin to" is missing on Revo Uninstaller's shortcut and cannot be pinned to Windows 7 taskbar?

    No Pin to option available in Windows 7 taskbar
    No Pin to option is available on the shortcut
    The reason for the problem is that Windows 7 does not allow pinning programs containing "install" keyword in their name. You can solve the problem by making a shortcut on your desktop of Revo Uninstaller and change the shortcut's name to just "Revo" or something else, but the name should not contain "install" as Revo Uninstaller Pro does!
Anyway, do you have any suggestions on where/how I can check for the cause of this "broken shortcut"?

I've glanced at JumpListsView and ShellExView and tried searching the reg....

The icon appears correctly in start menu but not in control panel...

Icon issue with Advanced Uninstaller's "pinned" shortcut-vpx4cis.png

I think it's a 32-bit app on a 64-bit OS issue... but not sure where to go from here.

Suggestions, as always, most welcome

My System SpecsSystem Spec
25 Nov 2014   #2

64-bit Windows 10 Pro

Hello Jonny,

Have you already tried to uninstall and reinstall "Advanced Uninstaller" to see if it may repair it?
My System SpecsSystem Spec
25 Nov 2014   #3

Windows 7 Ultimate 64bit

Just tried, reboot and I now have this issue (except the blank icon is named

Perhaps ironically, I've now installed ccleaner on this build, to clean up after another cleaner.

1st swoop with the following options (all advanced, further down and invisible, are set to default - unchecked)

Will re-attempt after check and reboot, 2nd iteration trashing my jumplists (there was a time when I was precious about such things!)

My System SpecsSystem Spec

25 Nov 2014   #4

Windows 7 Ultimate 64bit

quick reg scan reveals the registry is littered with nearly 600 mentions of advanced uninstaller after uninstalling it. erroneous icon remains.

Java is installed as 32-bit. should I be looking at it's namespace entry, in comparison with Revo's, to try and spot the break?

(this is all a side-note, as I intend to reinstall)

There's also the possibility that, as the ghost-pinned entry is still stuck, despite application uninstall, that it's pertaining to a previous install of the software (I used to have an older version, this is all massive speculation)

Off to wipe jumplists and re-read your article on namespaces
My System SpecsSystem Spec
25 Nov 2014   #5

Windows 7 Ultimate 64bit

after reading more of your guides and playing closer attention I think I have found the culprit.

Remembering the blank icon issue (where the exact resolution was not known), I think CCleaner's clean jumplists (or equallty the reset items via batch/cmd prompt method) is "the fix".

for me, I found that unchecking (start menu properties) privacy "store and display recently opened programs/items" removed the list... and re-enabling allowed me to rebuild new jumplists. OK, start menu pinned data is gone...

After a frantic search, I think that, to pin the control panel like I like it, you need to pin "control panel"

Looking at the jumplistsview I see a) a correlation and b) a candidate!!

The application IDs match, and the first entry doesn't conform (re syntax)

On closer inspection .. there's lots of paths that don't work.

the first - {B4B0CDBC-A610-4CE1-BC70-2BA43091FDEA} - I thought was advanced uninstaller...

the second, full path - ::{26EE0668-A00A-44D7-9371-BEB064C98683}\0\::{6DFD7C5C-2451-11D3-A299-00C04F8EF6AF} - is folder options!

3, ::{26EE0668-A00A-44D7-9371-BEB064C98683}\5\::{BB06C0E4-D293-4F75-8A90-CB05B6477EEE}, is System
4, ::{26EE0668-A00A-44D7-9371-BEB064C98683}\2\::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}, power options...

the next set, including "the master" {ED7BA470-8E54-465E-825C-99712043E01C}, don't work...

Should I just delete 7e4dca80246863e3.automaticDestinations-ms and start again?
My System SpecsSystem Spec
25 Nov 2014   #6

64-bit Windows 10 Pro

If you find it listed under Namespace in the registry, then deleting it should remove it from the Control Panel.
My System SpecsSystem Spec
25 Nov 2014   #7

Windows 7 Ultimate 64bit

Call me tempestuous, but I deleted the "control panel" audodestination-ms file 7e4dca80246863e3, and started rebuilding... and got rid of the deadlink.

Time to reinstall the suspect software (I obviously wouldn't if only it wasn't so damn useful!), think I'll make a mental note to not pin it to the start menu!

Mark solved
My System SpecsSystem Spec
25 Nov 2014   #8

Windows 7 Ultimate 64bit

I tried a few text searches of the registry, and found either no entries (I had the .cpl filename, the company revo, the program name of course....) or too much noise (if anything, it's absence from namespace was what struck me).

thank you Brink!!
My System SpecsSystem Spec
25 Nov 2014   #9

64-bit Windows 10 Pro

Great news. You're most welcome.
My System SpecsSystem Spec

 Icon issue with Advanced Uninstaller's "pinned" shortcut

Thread Tools

Similar help and support threads
Thread Forum
"Desktop As Shortcut" Command Is Missing from the "Send To" Menu
Can anyone help me with this ? i got a picture ... i cant sendto desktop as shortcut the icon is missing .. help !!:cry:
Can't change advanced settings from "802.11d" to "wireless mode"
It seems to keep rolling back to 802.11d after I click okay. If you need more information from me I would be happy to fill you in a bit more there. Some basic specs: - 32-bit Service Pack 2 - Acer - AM5620-E1204A - Intel Core 2 Any additional help to further assist would be...
Network & Sharing
the task bar "folder" pinned "program"
I usually use it by pinning my frequently use folder, so when I right click, the list of "pinned program (folder)" will be listed out, easy for me to access them in a click. and one day, all the pinned programs gone. so I attempted to "repin" all vanish folders, but even if I click to pin...
General Discussion
how to change wmp "pinned" taskbar icon ?
ok . ive done a search but couldnt find a specific soloution. im trying to change the wmp icon that i have pinned to my taskbar. i guesse i have to change the icon in wmp prog file but i cant figure out which it is i have to delete or change to icon i want ,i know it can be done (somehow) as i...
How to display the "Network" icon (not shortcut)?
Somehow I managed to display the "Network" icon (not shortcut) on the desktop, but now I couldn't remember how to do it again on another 7127 installation:confused:.
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App