Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: /RebuildBCD - Total identified Windows installations: 0

03 Dec 2014   #1
Vinicius MT

Windows 7 ultimate x64
/RebuildBCD - Total identified Windows installations: 0

I've got an error status 0xc0000098 within the Boot/BCD files and when I do the /RebuildBCD command, it can't identify any Windows installations.

The reserved system files are in the C partition, wich is active, and the Windows files are in the D partition.

I have Ubuntu installed in my second HDD. Running Gparted, the D part is marked with an exclamation icon and when I try to mount it, I got this message:

Error mounting: mount exited with exit code 14: Hibernated non-system partition, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is hibernated. Please resume and shutdown Windows
properly, or mount the volume read-only with the 'ro' mount option, or
mount the volume read-write with the 'remove_hiberfile' mount option.
For example type on the command line:

mount -t ntfs-3g -o remove_hiberfile /dev/sda2 /media/94C48149C4812E94

So, I guess the problem is it. The /RebuildBCD command can't access the Windows files to fix the BCD in the C part. because it's hibernated. If I mount the volume 'ro' or mount it read-write with the 'remove_hiberfile' as the description says, will it fix it?

My System SpecsSystem Spec
03 Dec 2014   #2
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit

The following is from askubuntu about using the remove_hiberfile option:

If you need to mount the partition in read-write mode and are not able to or willing to boot into Windows and shut it down completely there is a third option. However, it is not included here because it completely deletes hiberfil.sys and will cause you to lose all unsaved information in the hibernated Windows programs. The following is a quotation from man ntfs-3g about the option that would be used to do this.
remove_hiberfile Unlike in case of read-only mount, the read-write mount is denied if the NTFS volume is hibernated. One needs either to resume Windows and shutdown it properly, or use this option which will remove the Windows hibernation file. Please note, this means that the saved Windows session will be completely lost. Use this option under your own responsibility.
While this could then give you access to the partition and be able to read/write it, it's possible that Win7 will no longer boot after that.

In general, it's a bad idea to use Linux utilities to mess around with Windows filesystems.
My System SpecsSystem Spec
03 Dec 2014   #3
Microsoft MVP


The repairs you want are to Mark C Partition Active then run Startup Repair - Run 3 Separate Times to reassert the Win7 Boot loader.

Then if you need to add Linux to a Window Boot menu follow this post to Dual boot Ubuntu-Win7.

In some cases where Startup Repair cannot find an OS to repair even after repeatedly running it, you'd want to actually back up and Rebuild the BCD as shown in How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows.

Keep in mind that if heavily infected the system may not repair until disinfected. All of this is covered in sequence in Troubleshooting Windows 7 Failure to Start
My System SpecsSystem Spec


 /RebuildBCD - Total identified Windows installations: 0

Thread Tools

Similar help and support threads
Thread Forum
Messed up /RebuildBcd command, now can't boot either Win7 or Ubuntu
Hello, (Please see original issue posted over at the Ubuntu forums: I spent about 10 hours last night trying all possible solutions I could find on this and other forums, so if this has already been solved elsewhere and I have not found it,...
Backup and Restore
Total identified Windows installations: 0 What do I do next?
My Gateway NV79 running 64 bit Windows 7 won't boot and I've tried startup repair and the following steps below and it tells me that the total identified windows installations: 0. I have no clue what to try next. Any suggestions would be appreciated. Thanks. bootrec.exe /FixMbr If...
Installation & Setup
Messed up BCD, Error 0xc000000f. Unable to '/rebuildBCD'
I have an asus n56vz laptop that is a couple years old. I replaced the HDD with a SSD when I bought it and put a clean win7 install on it. Today, I decided to swap the blu-ray drive with a HDD caddy and put the original HDD back in. I think my mistake started because I never wiped the original...
Installation & Setup
Bootmgr missing, 0 OS, no Rebuildbcd
(first post so please pardon any violations) (if you feel this should be moved to the Win8 section feel free to move it, I just don't believe it to be relevant) (Please don't tell me to Google stuff as I've already done my research and exhausted Google) (I'm currently using my iPhone as I do not...
General Discussion
Windows 7 2 installations
I have installed a retail version of windows 7 and for some reason when i boot now I have an option to select windows utimate and windows ultimate recovered .Any one help with the best way to remove this please,Its my old beta version
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:51.
Twitter Facebook Google+