Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error message regarding DNS

16 Dec 2014   #11

windows 7 home premium 64bit

Ok thanks for that Nigel. Im waiting for some feedback from the Admins at Serverpress. But so for one of them pointed out my anti virus. Could this be a worry the fact Im not running a Microsoft anti virus and I have avast?
My System SpecsSystem Spec
16 Dec 2014   #12

windows 7 home premium 64bit

Also Id like to add Im digging into the softwares folders and I found one called "other" I located a host file in there too. And in that host file its got the www."sites name".dev I registered when I tried to connect to the internet. Is this something fishy? should there be a host folder in a software?
My System SpecsSystem Spec
16 Dec 2014   #13

Windows 10 Pro x64 2004 - 19041 - 329 XP/Vista/Win7/Win8.1 in VM for testing

If they are saying that there is a specific issue with avast then I would follow their lead on this, although I have found that a lot of developers will tend to "blame" an AV that they are not familiar with without any proof -

When installing any program that works at a low, (system), level, it is often a good idea to disable all AV on the system as the AV could see the system level changes as a malware issue.

Edit, Just seen your last post whilst typing

Copy the contents of the "extra" Host file and paste it into the "correct " hosts file, it looks like the program may be getting confused with the locations - locations in Windows 7 are a lot different from those in, for example, XP qnd although if the developer uses accepted MS Protocols for this all is good, some use direct writes which can cause this sort of issue
My System SpecsSystem Spec

16 Dec 2014   #14

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Just jumping in for a moment - Nigel / Barman is providing you with excellent help.

I read your post on the ServerPress forum and have one answer and one suggestion.

The / static DNS server addresses are fine - they are Google's public DNS. I recommend those servers when troubleshooting some network issues (because they are easy to remember)

It would be good to know what's in the Windows\System32\drivers\etc\hosts (no extension on hosts) file. The default file used to include one entry for loopback testing. The MS fixit that resets the hosts file essentially creates an empty file (everything is commented out). This puts the onus on the router to define the loopback.

Please attach the above hosts file to a post (you can edit the if it's defined in that file, but do not change anything else).

Also, please launch an elevated Command Prompt (right click ... run as administrator) and enter the following
cd C:\Windows\System32\drivers\etc

icacls hosts

** copy the text in the Command Prompt window and
** paste it into a text file
** attach the text file to a post
** then you can exit or close the command prompt

If the hosts file is not quite right, I'll suggest resetting the hosts file ... but not without seeing the data.

A standard Hosts file is only a KB (maybe 2 KB). If it's much larger, don't bother attaching the contents and definitely DO NOT reset the hosts file.
My System SpecsSystem Spec
17 Dec 2014   #15

windows 7 home premium 64bit

Hello Slartybart

Thank you for reply, as if my DNS server problem was not enough, as I tried one more time to connect, I got a message while launching the serverpress software that I have used up my free version of the software and I get prompt to become a premium member, lol.. I haven't even used the software cant connect to server but I'm getting message like this, how ironic! I've sent a message to support, hope I get a response.

btw just thinking if its worth uninstalling the software and reinstalling again, in case I can make some more attempts for faster solution, because I'd like to give your advice a go too, sound promising hopefully. Or do software companies detect I.P and cannot reuse the software again ?

Thank you.
My System SpecsSystem Spec
17 Dec 2014   #16

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

I'm not familiar with ServerPress, so I can't address that pgm specifically. Trial/demo versions of software have various mechanisms to detect 'reuse' - too many methods to go into any great detail. Some create a file, some create an entry in the registry, some do both ...

ServerPress should resolve this for your (the out of free version use) - press hard if they press hard. If it's a good company, they will help (they want you to buy their premium membership and unhappy trial version users won't).

Uninstalling/Reinstalling ServerPress might work, I don't know. Give it a shot and post your results.

The only real advice I gave was on the Google DNS servers (affirming that the address is safe). The other stuff is gathering data on the issue.

You can easily change the DNS server as a quick test, but without having ServerPress configurable, there's not much to gain at this point. I'd give ServerPress a day or two to respond. Of course, if the reinstall lets you do what you're trying to do, you should try the DNS change (I think ServerPress recommenced the DNS change as a workaround)

You could still post the hosts file if it's small (I don't need to see tens or hundreds of entries). And since you said that ServerPress complained about accessing the hosts file, I'd like to see the access control list (icacls output).

I'll keep an eye on your thread, but I might not be very responsive - got busy in September and will be busy until late Jan or Feb ... but I do stop in and check, just not every day.

If I find some time, I might read up on ServerPress to see If I can find some low hanging fruit (easy things that might sort things out).

My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Upon booting my computer I have gotten an Error Message, MBR Error 1.
Upon booting my computer I have gotten an error message named MBR error 1: Press any key to boot from floppy. Naturally I began my research immediately as to what this error means and how to fix it! Some of the first suggestions I came across were solutions such as rebooting your computer,...
Hardware & Devices
Never seen before message error message.
"The procedure entry point RtlTryAcquirePebLock could not be located in the dynamic link library NTDLL.DLL." System worked fine the day before no updates or anything was apply, just turn it off for the day and now this error, any idea what up? So far did a sfc/scannow and waiting for the results...
General Discussion
Windows not genuine message plus Error message 0x8000247
Hi folks, I hope someone can help me with this problem: I'm getting the 'Windows not genuine' message box show regularly. When I follow the link to investigate I get the Windows Activation Technologies box come up saying that the Update Installation Failed with Error Code 0x8000247. A while...
Windows Updates & Activation
Microsoft Visual C++ Runtime Library error, error message 00289x01849
Hi, I'm worried about this Microsoft Visual c++ runtime library error... It happens, whenever i'm trying to do anything with my malwarebytes anti-malware. And even if I open the folder where i put malwarebytes exe, there also it shows this error.. Can anyone help me.. Thnks...
General Discussion
Error:720 Error Message When You Try to Establish a Dial-Up Connection
Team, Before my computer was working fine when i am connecting to the internet using a portable usb internet huawei. Then one morning when i tried to connect i got this "Error: 720". been searching the internet for a solution but none of them worked. if anyone knows how to fix this please shed...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:23.
Twitter Facebook