Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: security permissions needed to access files

26 Jan 2015   #1

windows 8.1 32bit
security permissions needed to access files

Good morning all, please i have this problem wid my laptop, i deleted one of my account that i used microsoft to sign in and i have not seen where it kept the user files of that account and i also set security permissions on most of my files through that account so now that the account is no more, it is requesting me to obtain permission from that account, each time i want to copy, move or delete a file. Please what do i do ?

Attached Images
security permissions needed to access files-capture.png 
My System SpecsSystem Spec
26 Jan 2015   #2

Windows 7 Pro 32bit

Hi netpotechani, Welcome to SevenForums

First, i would like to know if you can right click cmd, then run as administrator on your current account.
My System SpecsSystem Spec
26 Jan 2015   #3

windows 8.1 32bit

Yes i can do it,
My System SpecsSystem Spec

26 Jan 2015   #4

Windows 7 Pro 32bit

okay, i would like you to this:

type this command on the cmd, run as administrator.

net user administrator /active:yes

restart your computer after
My System SpecsSystem Spec
26 Jan 2015   #5

Windows 7 Pro 32bit

If that works, you can see an administrator account after you reboot,
Log-in to administrator account then give permission or make your current account administrator.
My System SpecsSystem Spec
26 Jan 2015   #6

windows 8.1 32bit

it is not working, i have done that before and it didn't work
Sir, let me explain this thing well for you, i set security permissions on my harddisk so that someone might not be able to access my informations, on that fateful day i had a flat battery and a friend came looking for a file from my computer so i removed my internal hard disk and then put it in another it booted fine but i was unable to access my files cos of the permissions set on the hdd, when i put it back on my computer it booted fine also but this time around the start screen did not show, it was black and empty while the built-in administrator showed the start screen well but most of my files didn't show at all, i had to delete d microsoft account i was using before and now use the build-in administrator account to create another microsoft account.
So now if i want to access any file or copy, move or delete any file affected with the permissions it will request permission from that account that i deleted, n i cant format my computer cos i will lose alot of informations that i cant get anymore.
Please help me out, i have tried all wat i knw wid thing machine and it is not working
My System SpecsSystem Spec
26 Jan 2015   #7

w7 ultimate 64-bit sp1

Hi, have you tried Windows 8 Forums , can you recreated the "Ani Emah" Microsoft account on this computer?
My System SpecsSystem Spec
26 Jan 2015   #8

Windows 10, Windows 8.1 Pro, Windows 7 Professional, OS X El Capitan

Hey Netpotechani,

Attached is a batch script that will set those pesky permissions straight... and help re-claim what was once yours !

@echo off
net session >NUL 2>&1|| powershell Start-Process '%0' -Verb RunAs&& exit /b|| exit /b
pushd "%~dp0"
for /f "delims=" %%I in ('
powershell "((new-object -com 'Shell.Application').BrowseForFolder(0,'Select a folder to gain access to',1,17)).Self.Path"
') do set selected_dir="%%I"
if "%SELECTED_DIR:"=%"=="" exit /b 1
if "%SELECTED_DIR:"=%"=="::{20D04FE0-3AEA-1069-A2D8-08002B30309D}" goto :select
echo.& echo Are you sure you want to reset and recover access to
echo  %SELECTED_DIR:"=%
echo by taking ownership and assigning full control of this directory and all its 
echo sub-directories and files to the current user?
if errorlevel 2 exit /b 0& cls
takeown /f %SELECTED_DIR% /r
icacls %SELECTED_DIR% /reset /t /c
icacls %SELECTED_DIR% /grant:r "%USERNAME%":f
echo.& echo Success.
popd& timeout 2 >NUL

Attached Files
File Type: bat th-359451.bat (865 Bytes, 7 views)
My System SpecsSystem Spec

 security permissions needed to access files

Thread Tools

Similar help and support threads
Thread Forum
Can't Access External HD To Change Security Permissions
I can't remember doing anything this stupid to my computers in a long time, but seriously need help now. I was working with a 2TB external hard drive when I selected to change the security permission access and then realized that wasn't what I wanted to do, so stopped the process midway. A...
Network & Sharing
Security - User Permissions - Why don't I have access to everything?
UPDATE: I went to the .exe and checked my permissions, I had no "special" permissions just read/write iirc. Set my access to full control and ran the .exe directly (no shortcut) still doesn't work properly. Neither does running as administrator. I should also mention that I'm able to copy...
General Discussion
Security & Permissions Too good? - Error 5 Access is denied.
My not quite 3 months old Win 7 system has taken a notable dislike to me trying to install programs now that I have an actual need to burn some disks of the data and DVD kind. For certain programs I am getting that lovely little message box which states; "Unable to execute file in the temporary...
How to remove (reset) all security files/folder permissions?
I have a problem with my security permissions. I need to reset all security permissions of my files/folder to reconfigure this. What I have to do?
General Discussion
Problem with security access to files on 2nd HD after installing windo
I recently installed windows 7, and pervious to that I had my windows XP. I have 2 HD and the second one is where I put most of my files. So i tried to open one my my pictures, and found a message saying: "Windows photo viewer can't open this picture because you don't have the correct...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:11.
Twitter Facebook Google+