Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Acer Aspire 5733Z stuck in a boot loop

27 Jan 2015   #1

Windows 7 Home Premium 64bit
Acer Aspire 5733Z stuck in a boot loop

If this is in the wrong forum I apologize, I was not sure where to put it.

Yesterday I turned my acer laptop on and I got to the "press F2 for setup" screen and then my laptop shut off. And then it proceeded to turn back on, get to the same screen, then turn off.

Pressing F2 or F8 gets me a very scary and loud beeping sound. Then it shuts off.

I already removed the battery and pressed the power button for 30 to 45 seconds and this did not help.

I have tried reseating the harddisk, and removing my expanded RAM to see if that would help, like other forums had suggested. Didn't work.

Right now it is in Startup Repair mode.
I really hope this works.

Before this happened I had trouble with the new iTunes update, and my computet was really slow so I tried running my anti spyware/malware programs, and Microsoft Security Essentials. It found some things but they were removed promptly.

What could possibly be wrong with my computer?

My System SpecsSystem Spec
27 Jan 2015   #2

Windows 7 Home Premium 64bit

The startup repair was unable to fix the problem, and I am trying to upload the picture I took from my phone of the details but my phone is incapable due to low memory.
My System SpecsSystem Spec

 Acer Aspire 5733Z stuck in a boot loop

Thread Tools

Similar help and support threads
Thread Forum
Acer Aspire Stuck on setup is starting services
So one evening my laptop randomly restarted itself and upon logging back in I found that I could not run almost any of my programs (.exe files). I tried checking for anything unusual in the registry but found nothing. In task manager when I clicked a program or attempted to run it in various...
Hardware & Devices
Acer Aspire stuck on software installation
My laptop (acer aspire 7750-6423) recently crashed and would no longer load up windows. I couldn't repair or recover anything from the hardrive and had to buy a new one. I went through erecovery and came to software instillations. It was working fine till it got to "installing LITE-ON Camera 1.3M...
Backup and Restore
ACER Aspire System Restore stuck!
My Wife's laptop Acer Aspire One D255 with OS Win 7 Starter, needed to be restored and a clean install, the problem is that when it was first bought no backups were made mainly because it doesn't have a disc drive. I used the Advanced Recovery Method that was pre-installed to ''Return your...
Backup and Restore
I would like to know more about my Acer Aspire notebook 5733z model
Hi there. I am just wondering about my notebook laptop which is an Acer Aspire 5733z model. And this is a really new model as well that just came out I believe this March. Now I am just wondering if my notebook as Wake-On-Lan on it. Because I cannot seem to find it in my Bios settings. And I do not...
Hardware & Devices
Acer Aspire 4553 won't boot up
I need your help people! I have a practically brand new ACER ASPIRE 4553 (1 month old, max) and I was experiencing some reboot failures and also having problems turning the computer on, how's that? Well, for example when rebooting the computer it did not turn back on (kept a black screen, no...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:52.
Twitter Facebook Google+