Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System Properties Not Showing Usable Ram

04 Feb 2015   #1

all versions
System Properties Not Showing Usable Ram

Windows 7 Professional, SP1, 3GB Physical RAM, 64-bit. System Properties has a label such as this on *OTHER* systems:

Installed Memory (RAM): 4.00 GB (3.85GB usable)

And you will see this "usable RAM" item in many Windows systems. However, there are some systems where it simply does not show the item in parentheses AT ALL such as mine:

Installed Memory (RAM): 3.00 GB

I have a company that requires seeing this "usable" RAM and I can't Google anything anywhere how to make this show up or what prevents it from showing up or how to make a WMI call to make it show up.

It is a Dell E5500 with the latest BIOS (A19) and chipset and video driver.

+Resource Manager and msinfo32 show there really is only a scant 45MB being used for video RAM (hardware) thus if the value ever showed up it would say 2.93 or some such.and company would be happy my PC passes their certification.

+tried setting msconfig Boot|Advanced Max Mem to 3072 KB and did not impact anything (nor does unchecking and saying 0)

+looked at msinfo32 -- nothing useful

+Googled "usable ram" etc. and all everyone talks about is situations when the usable *IS* *IS* displayed and is less than expected. That does not apply here.

+Ran memory diagnostics; reseated RAM -- forced apps to go well past 2GB and no problem.

I know 2.93 GB is usable because I know how to interpret the usable RAM from other values (resource Monitor Memory) but the company doing the certification insists on seeing this "usable" and if not there, they incorrectly use the currently available RAM which of course is varying/dynamic and nothing at all to do with "usable" shown in system properties. "Usable" is a static value gleaned from physical RAM minus RAM dedicated to video hardware -- but why on earth it does or does not display in System Properties is the mystery here. Obviously, few complain about this because "out of sight, out of mind" -- people seem to endlessly post when the usable RAM *IS* shown and is significantly less than physical.

Are there WMI issues here? Is it a BIOS/CPU-mfgr that stops something from being calculated under the hood here? Why doesn't anyone (Dell, Microsoft) have an explanation?

What's in your wallet? (i.e., does yours show nothing there and if so, any ideas why)?


My System SpecsSystem Spec
04 Feb 2015   #2
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Way to much to read.

Lets start with basics.

Show us these pictures from the problem computer.

Use this tutorial by Brink.

Screenshots and Files - Upload and Post in Seven Forums

System Properties Not Showing Usable Ram-capture.jpg

System Properties Not Showing Usable Ram-msconfig-ram.jpg

My System SpecsSystem Spec
04 Feb 2015   #3

all versions

You'll have to take me at my word when I said MSCONFIG started out with the max memory unchecked (there are 1000s of posts about this "basic" and of course that was looked at and confirmed as unchecked). Then there are 100s of post suggesting setting that box be checked and the value set to 3072. That has been done.

I am sorry for sounding ornery but I am a skilled professional and have tried all those and am seeking answers from people who have experienced this or can look in their own system and see there not being a usable amount shown in System properties and have also, like me done the basics. If you must have the basics, the msconfig looks exactly like yours and I stated as such in my post. Later, I changed it to checked and 3072.

The Resorurce monitor confirms things are okay. It shows the hardware is using 45MB and then it shows the *CURRENTL:Y* used RAM and the amount allocated for Cache and we all know how subtly complicated explaining that is which is precisel;y why I said I was focused on the WMI value for "usable" or whatever it is that the static value in System properties is showing.
My System SpecsSystem Spec

04 Feb 2015   #4

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

The system i'm on now has 6 GB RAM and 3 MB Hardware Reserved.
Is has a GPU Video card, and the IGP is disabled in BIOS.
It doesn't display Usable on the System Properties window.

I'm just guessing here, Windows may not display Usable if it is "close" to the full Installed RAM.
If you can allocate more RAM in BIOS to your IGP (or anything), then maybe it will display Usable on the System Properties.
Can you allocate more RAM in BIOS to test it?

System Properties Not Showing Usable Ram-memory_01.png

My System SpecsSystem Spec
04 Feb 2015   #5
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

hstein we have no idea what your skill level is. You have only 2 post. Your boot Advance option should stay the way my picture indicates. It's your system and your problem so pick what you want to do.
If and when you see fit to post the pictures I requested please do so.

It might help.
My System SpecsSystem Spec
04 Feb 2015   #6

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by hstein View Post
What's in your wallet? (i.e., does yours show nothing there and if so, any ideas why)?
Well, I have two machines and one shows "usable" and the other one doesn't.

Both are Win7 Pro 64-bit SP1 with all Windows Updates applied, both are retail Win7 (i.e. not OEM). One is an ASUS motherboard home-build, and the other is a Lenovo W530 laptop (which I reinstalled Win7 from scratch on when upgrading to SSD).

No explanation for the difference in presentation.
My System SpecsSystem Spec
04 Feb 2015   #7

Windows 7 Pro 64 bit

My guess is that usable memory is only shown when the difference from installed is significant. In a 64 bit OS it very often is not. I doubt there is any way to control this. If this information is needed it will have to be obtained by other means. Resource Monitor shows this information.
My System SpecsSystem Spec
04 Feb 2015   #8

Windows 10 Pro x64

I have never seen the display show usable different from total unless usable memory differed by more than 3% of total (so if it was 3.88GB, it doesn't show, but 3.87GB or less and it does). I don't know if that's the cutoff, but I've seen 3.85GB usable many times - but never higher.
My System SpecsSystem Spec
06 Feb 2015   #9

all versions

Layback Bear: -- so sorry about how i came across. The others who replied are seeing the same issue which is a relief and posting images. They are making some great empirical guesses and observations about the N% threshold/cutoff *and* that it's hard to tell what is going on, that you can infer it indirectly from Resource Monitor, etc.

Shame on Microsoft for being inconsistent and not documenting this anywhere that I can see. I like the idea of tweaking the video RAM in the BIOS but unfortunately my BIOS (latest/last one released for this machine) does not permit that. The resource monitor says 45MB reserved for hardware which means 97.6 usable. Others have seen 3.88/4.00 or 97%. confirms "usable" is physical minus "hardware reserved" memory.

Anyway, can anyone else with this issue can tweak their video RAM up past the 3% threshold to see if it shows up. WARNING: be careful. Thank you all and this remains unsolved for the time being.
My System SpecsSystem Spec
06 Feb 2015   #10

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

Try setting msconfig Boot|Advanced Max Mem to 3000 (so it is less than your installed memory of 3072).
You should see an increase in the Resource Monitor Hardware Reserved memory.
If that is enough of a change, you should see Usable on System Properties.
My System SpecsSystem Spec

 System Properties Not Showing Usable Ram

Thread Tools

Similar help and support threads
Thread Forum
Some Mp3 files not showing all properties.
Some of my Mp3 files aren't showing up all properties in my Win 7 Ultimate 64 bit. But some of them are. Here's a screenshot of what I actually mean: The explorer should show the missing fields cause these are 100% Ok, playable & non-corrupted Mp3 files, you can see on the screenshot when I...
Music, Pictures & Video
4gb ddr2 ram install windows 7 only showing 1.87 usable
i just installed windows 7 a couple days ago and i don't have a lot of stuff installed just yet...couple games and the likes but nothing major. i happened to go in to update my system rating and realized that my ram was showing only 1.87 usable. just like it did when i had vista installed before...
General Discussion
4gb installed only showing 2.75 usable? is this right? what can i do?
Hi everyone. this is my first ever post here, so bear with me plz. I have a dell inspiron 530, with 4 gb ram installed, but the computer says i only have 2.75 usable. Is this right? i am running 64x windows home premium, with nvidia geforce gt 240 video card. the card has over 1gb of its own...
Hardware & Devices
Can a property from a .properties file be made into a usable variable?
I have code to read out lines from .properties, but it just prints it out, because im an idiot and didn't notice till now. So, the question is, can it be made into a variable instead? current code; Properties prop = new Properties(); InputStream input = null; try { input = new...
Showing 3.25GB USable Memory out of 4 Win7Prof64Bit
Hello. I have self assebled desktop with following configuration- AMD Phenom II X4 955 CPU Gigabyte GA-MA785GMT-UD2H Motherboard 500GB SATA HDD 4GB DDR3 1333MHz Gskill RAM PowerColor ATI Readon HD4850 1GB DDR3 600W PSU I have installed Windows 7 Professional 64 Bit OS. After installation...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:02.
Twitter Facebook Google+