Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't access my external HD after changing Permissions

05 Feb 2015   #1

Windows 8 x64
Can't access my external HD after changing Permissions

I changed the Permissions for my External Hard Drive (I am the Admin in this computer), I actually wanted to passport-protect it, and now Windows doesn’t let me change it back (my HD will not work in other computers either). Please help!

First I tried system restore, that was useless, but then again I have never been able to fully complete successfully a system restore on this netbook, it always restores somewhat but gives me an error message.

Then tried this Take Ownership Shortcut Option 3 “Add "Take Ownership" with Pause to Context Menu” The “take ownership” option appeared successfully, when I took ownership of the folders a long list of messages saying that is was successful appeared, but when I did this on the Drive, the black dialog box opens and closes so quick that I can’t see any message on it, if there is any, so I can’t see if it was successful.

Creator Owner appeared on list after doing this, but the only Alowed box ticked was “Special Permissions” everything else was unticked with neither Allowed nor Denied.

User Everyone has List folder contents as Allowed and Write as Denied, everything else unticked.

User SYSTEM has everything ticked as Allowed except for Special Permissions.

And there is a 4th user with a very long number as a name and a question mark on the person of the icon, which has the same Special Permissions as the Creator Owner (this was there before Taking Ownership.

Before taking ownership I was able to delete files, but not copy or modify them (documents appear as read-only files). Now I’m able to both delete and copy files to another location (clicking on providing admin permission when prompted) but I cannot write any new information or copy files to the HD (no pop-up asking to give admin permission here). So at least I can access my files now, but still my Disk is useless as a back-up.

Again, the Edit button on Security doesn’t allow me to change anything, I can’t tick or untick any boxes, and the Advanced button is just the same: when I click on Change Permission another dialog just the same appears where I can only click View, Ok or Cancel. The Add, Remove and Apply buttons appear greyed-out. The funny thing is that Creator Owner appears as having full control of Subfolders and Files only, so in theory I should be able to write over files.

This is the current print screen:

Thirdly, I have tried finding the “Access Control Settings for Local Disk dialog box” but I’m using Windows 8 and I’m afraid this just isn’t an option there.

What else can I try?

Attached Thumbnails
Can't access my external HD after changing Permissions-print-screen.jpg  
My System SpecsSystem Spec
05 Feb 2015   #2

64-bit Windows 10 Pro

Hello Conloria, and welcome to Seven Forums.

Since this is a Windows 8.1 issue, please register and post this at our sister site instead. :)
My System SpecsSystem Spec
Closed Thread

 Can't access my external HD after changing Permissions

Thread Tools

Similar help and support threads
Thread Forum
Can't Access External HD To Change Security Permissions
I can't remember doing anything this stupid to my computers in a long time, but seriously need help now. I was working with a 2TB external hard drive when I selected to change the security permission access and then realized that wasn't what I wanted to do, so stopped the process midway. A...
Network & Sharing
Changing permissions..
hey..! can anyone please tell me that how to change permissions in windows drive.. i have to delete my old windows..! it says to ask permission from admin..??
General Discussion
Restore Access Permissions on C: Drive after changing in cmd
So, I'm an idiot. I need someone to help me reset ownership and permissions for the c: drive on a hdd. I'm not well versed in cmd so I can't seem to figure it out. My bf's laptop overheated (so I thought, he was streaming a baseball game, not much else I think, when it shut down unexpectedly...
Installation & Setup
Changing Folder Permissions ...
Hey guys, I have a question for you all ... I just remade my PC and reinstalled Windows 7 and now working on the Software. I must of fixed this in the past, but for the life of me can't remember what I did ... when getting into certain folders, or even trying to save certain files, I get the...
General Discussion
Changing game permissions
I've decided my 9 year old son is getting a tad too excitable playing my first person shooters (Crysis, Crysis Warhead, Call of Duty 1,2,3 and 4, Medal of Honour: Airborne Assault) so I want to make them off-limits for the guest account on my desktop, as that is the account my kids use. I know how...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:01.
Twitter Facebook Google+