Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: missing msls31.dll

11 Feb 2015   #1

Windows 7 Home Premium 64 bit
missing msls31.dll

I keep getting a missing msls31.dll message. Ran sfc/scannow and got a 332 MB CBS.log file, too big for my editor to load entirely and too big to wade through. I built this machine and a carbon copy. Tried to copy the dll file from the other machine but got message that trustedinstaller had to do it but can't find how to use trustedinstaller. There is a msls31.dll file in windows\system32 but apparently it's not the right one or it is corrupted, don't know how. Could not run regstr. Any suggestions for how to copy my good file into windows\system32 so I can run regstr?

My System SpecsSystem Spec
18 Feb 2015   #2

Windows 8.1 x64

Hi phragdick,

Try placing the dll-file in the same folder as the program requesting it.

If you need a fresh file, or a different version, I found you can download them directly from msls31.dll free download - . Look for "Manual Fix" at the site if you are not interested in downloading a program...

btw.. Are you on a 32bit or 64bit version of Windows?
on a 64bit Windows, 32bit dll-files goes in C:\Windows\SysWOW64\ and 64bit dll-files in C:\Windows\System32\ .

Jarlee, out.
My System SpecsSystem Spec
25 Feb 2015   #3

Windows 7 Home Premium 64 bit

It took me a couple of days to get back to this problem but when I try to copy the dll file to \windows\syswow64 (64 bit windows) it says I need to provide administrator permission. I'm logged in as administrator. Got an answer to that?
My System SpecsSystem Spec

26 Feb 2015   #4

Windows 8.1 x64

To get the rights to paste a file in SysWOW64, take ownership of the folder;

If you are an administrator, an authorized user, or a backup operator, you can take ownership of a file or folder by completing the following steps:
1. In Windows Explorer, open the file or folder’s Properties dialog box by right-clicking the file or folder and then clicking Properties.
2. On the Security tab, click Advanced to display the Advanced Security Settings dialog box.
3. On the Owner tab, click Edit.This opens the Advanced Security Settings dialog box for editing.
4. In the Change Owner To list, select the new owner.If you’re taking ownership of a folder, you can take ownership of all subfolders and files within the folder by selecting the Replace Owner On Subcontainers And Objects option.
5. Click OK twice when you have finished.

You can see the steps at [Guide] How to Take Ownership (Permission) of a File or Folder Manually in Windows? - AskVG

Hope it helps
My System SpecsSystem Spec

 missing msls31.dll

Thread Tools

Similar help and support threads
Thread Forum
The specified module could not be found msls31.dll When press Sart
My sound stopped working. My computer says that everything is working fine but its not working at all. There is this error message I get when I press the start button (the specified module could not be found msls31.dll) It all started with that error, now Iv'e tried to do the sfc/scannnow but I...
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Pictures missing suddenly and backgroung picture missing
i got on the pc this morning and noticed that where i have the picture saved on the desktop it was just black so i went into where my pictures are saved and there missing ?? but when i double click on one it will show any ideas please im lost on this ??
General Discussion
Win Explorer arrows missing, cursor spinning, libraries missing
New laptop (Lenovo W510), but I swapped boot disk for an SSD and reinstalled Win 7 64bit from recovery disks. I moved My Documents to D: and when I open Windows Explorer all looks fine. When I click on an arrow beside My Documents (or Music or anything), the arrow selected disappears, folder...
General Discussion
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:17.
Twitter Facebook Google+