Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Permission/ownership problem

25 Feb 2015   #1

Windows 7 32 bit
Permission/ownership problem

I have a desktop system that had WinXP on it. I bought a copy of Win7, put the install CD in the drive, and booted. After waiting a long time(*), it finally booted and offered me a choice:
Complete install

I'd swear I chose fresh install, but when it finished installing all my user files, etc. were still there.

I went ahead and set up fourusers:
barry (normal user)

But when I started using the system, I discovered that all the old files were owned by "unknown" users. The result is that I can't write my own files. In some cases, not even the admin can write the files.

This is a mess, and not very useful. For the time being, I'm storing new files on the external hard drive (where I had backed up all my user files before the install), but I don't want to do that permanently.

I've tried using the admin user to change the permissions and/or the ownership, but that didn't fix the problem. Maybe I didn't do that right? The choices offered didn't seem all that obvious.

So, how do I get out of this mess. My brain throws out two ideas:

1. Start over: re-install, then install my apps again, etc. But *make sure* that I get a fresh install. Maybe do something (fdisk?) to make sure that my hard drive doesn't look like a Windows drive?

2. One at a time, rename the existing user file directories, then create new ones and copy the contents of the old directories to them, then delete the old directories.

Which do the experts here recommend? Or is there a better solution I haven't spotted?

(*) I could write an entire DVD in the time it took the install disk to boot!
(+) I'd had a previous problem on a laptop where the registry got corrupted and the admin password was lost. I had to let the shop re-install from scratch. Every since, I've had two admin users, just in case.

My System SpecsSystem Spec
25 Feb 2015   #2

Windows 10 Pro (x64)

When you take ownership you need to set the permissions up properly. Do not use the Administrators group use your user account name.

As for why your files remained is because you did not format the disk. However this is perfectly fine, it is still a fresh and clean installation. You just need to setup the permissions correctly as they reflect the old installation.
My System SpecsSystem Spec
25 Feb 2015   #3

Windows 10 Pro X64

I'd recommend doing the install again only follow these directions: Clean Reinstall - Factory OEM Windows 7
My System SpecsSystem Spec


 Permission/ownership problem

Thread Tools

Similar help and support threads
Thread Forum
0 byte jpg "You need permission to delete" Take Ownership/unlocker fai
Photoshop CC 2015.5 wrote a 0 byte jpg file to the My Pictures file that I cannot delete. I always get a "You need permission from the computer's administrator to perform this action." Hitting "retry" multiple times does nothing. the "Take Ownership" Registry hack and Unlocker both fail. Take...
General Discussion
Permission not granted to access files even after taking ownership
I have a 250gb hard drive from an old PC that has ALOT of pictures ,videos, and music stored on. The PC was running Window XP. It died and I removed the hard drive and bought an enclosure to install it in. I have it hooked to a newer PC running Windows 7. At 1st when I pulled up the folders with...
General Discussion
Moved a HD to new machine, now have permission and ownership problems
I recently bought a new computer. I took a data hard drive out of my old one and installed it in the new. No problems with that. All files are intact. I am having problems with ownership and permissions on the new system. I can change permissions/ownership one one folder at a time, but that will...
Installation & Setup
ACCESS DENIED ( ownership and permission )
hey guys babylon trans. kindly advise me about the image below what to do i tried every thing nothing work out !! Uploaded with
Stuck on 'read only' after ownership, permission change
I'm set as an administrator, I've taken ownership of Program Files folder via my account, and I've set myself to full permissions - yet I STILL can't get it to release from Read Only, which makes it impossible to install certain softwares. WTH?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App