Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: browsers won't open and slow loading programs

28 Feb 2015   #1

windows 7 x64
browsers won't open and slow loading programs

Hi can someone please help me my browsers won't open and I have programs that open but take a really long time to load to the point I get frustrated and close it. I tried everything from doing a system restore, clean my disk, downloaded anti-malware, and more. I looked up here too if anybody had the same problem and I tried the solutions people suggested but it wouldn't work for me. Please help thanks

My System SpecsSystem Spec
01 Mar 2015   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Hello and welcome Sophia now some sytem specs would be really helpful as you have said you have 273GB RAM in the machine and it is quite wrong so follow this please System Info - See Your System Specs

Now you can run these if you haven't already and in safe mode if necessary < if necessary include the /f and /r in the command line as per Option2

I am also interested in what you have in the Start up tab in msconfig see this
Startup Programs - Change < use method 3
My System SpecsSystem Spec

 browsers won't open and slow loading programs

Thread Tools

Similar help and support threads
Thread Forum
All browsers loading facebook slow? Ideas?
Ive reset chrome completely and its till does it. Yet another PC connected to the same exthernet cable (Laptop also windows 7) works nice and speedy. Ive pinged a few sites, yahoo, google, facebook. All have good pings on the laptop yet facebook had a bad one on the desktop. google and yahoo both...
Browsers & Mail
Strange all browsers loading problems
I had upgraded to 8mbps plan with my broadband provider couple of months back, earlier I was on 4mbps. Ever since, I have upgraded my plan, I have been having strange loading issues with lots of sites. When I first try to load up the site, I get Problem Loading Page (error msg changes...
Browsers & Mail
Videos not loading in web browsers!!
I'm trying to loading videos with a updated version of FLASH, JAVA, SILVERLIGHT but nothing changes . ALso i cleared cookies and temp also.. please help me out!!!!!!1
Browsers & Mail
Almost all browsers are dead, not loading any web pages.
As I type this I am using Safari as this is the only browser that loads any web pages. When I try to load a web page in ANY other browser it's just a white screen, it tries to connect, and gives me the "This webpage is not available" page. The only one that works aside from Safari is the Steam...
Browsers & Mail
some programs open very slow
Hi I am testdriving a new Win7 X64 installalling and testing software I discovered that some software is suddenly very slow at startup. I am used to a 32 bit text editor ( text pad) that normally opens fast but now I can count about 10-15 seconds everytime I try to start the program. Also when...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App