Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Corrupt MBR Record Windows 7 Ultimate

02 Mar 2015   #1

Windows 7 Ultimate 64bit
Corrupt MBR Record Windows 7 Ultimate


Win 7 Ultimate 64bit
Intel on Intel. custom build, 2 WD, 1tx2, raid 0 array. 1 Seagate 160gb

My troubles are of my own making. I corrupted the MBR of the Windows system when I tried installing Linux Mint on the Seagate 160gb HDD.

I tried doing the installation of Linux so that I would have 2 completely separate OSes.The problem is that I forgot to change my BIOS before I proceeded with the Linux install. I did not want GRUB to be dual boot. I want to choose which system I use regardless of the state of the other system.

When I reformatted the SG HDD during the Linux install that caused the problem with the MBR record.

To make matters worse, I can no longer get into BIOS. Whatever happened during the next boot caused BIOS to think it's password protected and I never password protect BIOS.

I have Acronis and Norton Ghost backups but, they're not going to help me because I never backed up the SG disk.

I'm hoping someone would know of a way to fix the mbr, otherwise I'm going to have to re-install windows and start from scratch.

Any assistance would be greatly appreciated.

My System SpecsSystem Spec
02 Mar 2015   #2

Win-7-Pro64bit 7-H-Prem-64bit

Hi and welcome to SevenForums,
The default install when installing Linux is along side of an existing os did you change that ?
And exactly which version of mint 17.1 ?
My System SpecsSystem Spec
03 Mar 2015   #3

Windows 7 Ultimate 64bit

Hello ThrashZone,

Thanks for the reply and sorry it took awhile to get back to you.

I resolved my problem with the boot loader and got Linux Mint, Rebecca 17.1 installed. I needed a Linux distro on my Win7 machine to SSH into my server from time to time. It got to be a pain switching machines all the time and running multiple machines makes my office too hot.

The fix turned out to be easy. I went ahead and installed linux because that was the easiest way to fix the MBR of Windows. Then, I
added a 4th drive (another 160g Seagate) and allocated that drive to Rebecca as well. Finally, I had to reset my bios to get rid of the password. Everything is working great, again.
My System SpecsSystem Spec


 Corrupt MBR Record Windows 7 Ultimate

Thread Tools

Similar help and support threads
Thread Forum
Deleting corrupt file record segment xxxxxxxx
Hi I hjave no idea which forum this belongs to but I guess everything comes under "General". On my W7 PC I just changed the name of an attached hard drive, attached through an external SATA port to the MB, I'm not sure this is relevant. I then restarted the PC and it did not boot to...
General Discussion
Fresh 7 Ultimate x64 install. Windows updates failed/corrupt
================================= Checking System Update Readiness. Binary Version 6.1.7601.22471 Package Version 26.0 2014-12-27 12:36 Checking Windows Servicing Packages Checking Package Manifests and Catalogs (f) CBS MUM...
Windows Updates & Activation
cannot record audio in windows 7 ultimate
i have installed windows 7 ultimate.once i intalled xp and it records audio.but now in 7 not recording audio:huh:.i have correctly installed realtek for windows displays recording divices are - microphone,cd audio,line in,stereo mix(default divice).help me please! thanks in...
Sound & Audio
Record Icon not showing when pressing record in Live TV
Hi Guys When I am watching Live TV and press the record button on my remote or through the interface using the mouse I am no longer getting the red icon indicating that recording has started but the program is actually recording. I use to get it but for some reason it now no longer pops up. Has...
Media Center
Windows 7 x64 Ultimate Corrupt Update?
Hi guys. Can anyone help me figure this out without reinstalling the OS? My problem is that I've recently downloaded a Windows update (through Win 7 Update system) and then I've restarted the PC. Before the shutdown, the update was installed (i guess?!... I wasn't in the room when that happened)...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:17.
Twitter Facebook Google+