Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "comctl32.dll is missing from your computer", even though it's not

11 Mar 2015   #1

Windows 7 Professional x64
"comctl32.dll is missing from your computer", even though it's not

Hi, when I try to install any program I get the message:

"The program can't start because COMCTL32.dll is missing from your computer. Try reinstalling the the program to fix this problem."

The confusing thing is, when I go in to "C:/Windows/System32", the file COMCTL32.dll is right there still!

The reason this has happened is almost certainly because I recently cloned my hard drive over to a new SSD and kept my old drive just for storage. I've been booting off the new drive for a few days already, but today I deleted Windows off the old HDD (now named D:/), so I'm guessing that's why I'm getting this problem.

If I try to run any of the programs installed on D:/ I get the same message, but programs on C:/ work fine.

I've tried going into elevated Command Prompt and typing "regsvr32 comctl32.dll", but this just returns the message "The module "comctl32.dll" was loaded but the entry-point DllRegisterServer was not found."

I've also tried running a system file check and this says errors were found but that it was unable to fix them.

Any other ideas on how to solve this?


My System SpecsSystem Spec
11 Mar 2015   #2

Windows 7

I have this exact same problem on windows 7 32. Windows went through a number of updates yesterday and the day before. No viruses detected when removing the drive and placing in another computer. The file exists in System32 folder. Problem occurred this morning, when attempting to turn on the computer... Using system restore succeeds in restoring to an earlier restore point, but does not resolve the problem.
My System SpecsSystem Spec
11 Mar 2015   #3

Windows 7 Professional x64

I've been trying all day to solve this but to no avail. I think I'm just gonna format the drive and reinstall Windows.
My System SpecsSystem Spec

12 Mar 2015   #4

Windows 7 Professional 64-bit
Possible Panda AV link for comctl32.dll problem

There seem to be a lot of people having the same problem right now (including me) who are all using Panda Antivirus - if you're using it too, it's worth looking at this thread:
Panda Security Forum - View topic - Can't run Panda Recovery Tool, missing Comctl32.dll

It seems the antivirus program quarantined something it shouldn't have done, and the Windows update that happened at the same time may have complicated things. There are a couple of possible solutions mentioned there, and Panda are working on it.
My System SpecsSystem Spec
14 Mar 2015   #5

Windows 7 Professional x64

Haha yeah I had Panda, that was probably the cause. I've already reinstalled Windows now though and am back up and running with everything setup like it was before so it's no biggie. Thanks for your response!
My System SpecsSystem Spec
14 Mar 2015   #6

Windows 7

'twas using Panda Antivirus too... Oh, man. I'm upset. I realized this a few days ago when I saw this on Engadget. Was sure it was a virus then 80% certain it was Panda, now I'm 100% sure.

Too late. So obscure when it happened that I already rebuilt the os on the computer. Zheesh. Panda should compensate me for this. I even posted on their Facebook account, and no one even apologized.

Good Riddance Panda.
My System SpecsSystem Spec

 "comctl32.dll is missing from your computer", even though it's not

Thread Tools

Similar help and support threads
Thread Forum
D Drive is missing in my " My computer menu"
Dear All, Here is the Problem that i could't find my D Drive in my Computer menu. The problem evoked from Disk management settings, I wanted to extend Drive unfortunately i Made click on "Make Portion as active". After clicking when i restart computer it shown boot manager missing ( Press...
General Discussion
"COMCTL32.DLL Missing" (Not April Fools!)
As title suggests I'm getting the comctl32.dll error. Cause: Google Chrome was slow so I ran Herd Protect. While removing a few things it detected something went wrong. Info: -I see this file in System 32 however I'm still seeing this problem. It states file was modified today. -Several...
General Discussion
"Local Area Connection" missing in "Change adapter Settings".. Plz hlp
I have to set up a Broadband connection. But Local Area connection icon is missing. Someone told "drivers" could be missing... I installed few. But the problem is as it was.. please guide me in this regards.. Thank you Screen shots Attached
Network & Sharing
Windows 7 x64 "COMCTL32.ocx Failed To Register"
Hi, i have a laptop running Windows 7 Home Premium x64, and i am trying to run a program called "Advanced-Mart" Its for hacking Pokemon games. when i try to open it, it says that "COMCTL32.OCX or one of it dependencies is missing." i tried registering it, but IT WILL NOT WORK :mad:! Its very...
"Repair your computer" option using F8 key is missing
my machine is bootable and WIN7 starts without any problems. My Problem is I'd like create "System Reserved" to boot from this partition using F8 key and "Repair your computer" instead of booting from the CD boot disk. I've already tried to boot with a Windows Repair CD, I've done "Startup...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App