Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I can't run any .bat files!

04 Apr 2015   #1

Windows 7 64bit
I can't run any .bat files!

Hey forum people, I'm not sure this is the right place for this topic but here it goes. I'm trying to run a Minecraft server with more ram so i made a .bat and copy and pasted a .bat from online to use. I know it works I've used it before but now there is no program on my computer that can run it.

Attached Thumbnails
I can't run any .bat files!-untitled.png   I can't run any .bat files!-untitled1.png  
My System SpecsSystem Spec
04 Apr 2015   #2

64-bit Windows 10 Pro

Hello ItsMyCheese, and welcome to Seven Forums.

If you like, you can download and merge the .reg file for the listed BAT option in the tutorial below to restore it's default association.

Default File Type Associations - Restore
My System SpecsSystem Spec
04 Apr 2015   #3

Windows 7 64bit
not helping

sorry but that did not help
My System SpecsSystem Spec

04 Apr 2015   #4

64-bit Windows 10 Pro

Did the .reg file fully merge? Did you restart the computer afterwards?

If so, then you might see if doing a system restore using a restore point dated when you were able to run .bat files may help.

I also noticed the file name text are blue in your screenshot. A blue file name usually means that it has been compressed. Did you use NTFS compression on them?
My System SpecsSystem Spec
05 Apr 2015   #5

Windows 7 64bit
Still didnt help

For some reason, all of the files in any folder are all blue. i didn't compress them. and i also tried the merge thing but that did not work. i restarted my pc like it said
My System SpecsSystem Spec
05 Apr 2015   #6

Windows 7 Ultimate 64bit

Files are usually blue when they are NTFS compressed, like Admin Brink stated above.
Maybe you mistook NTFS compression with normal .zip compression?
How to remove NTFS compression - Microsoft Website

I'll post them here just to save time.
If you want to uncompress the files, you may follow these steps:
a. Click on Start, and then click My Computer.
b. Double-click the NTFS Volume that contains the folder or folders you want to compress.
c. Right-click the file or folder you want to compress, and then click Properties.
d. On the General tab, click Advanced.
e. Click to unselect the Compress contents to save disk space check box, and then click OK.
f. In the Properties dialog box, click OK.
g. In Confirm Attribute Changes, click the option you want.
My System SpecsSystem Spec
05 Apr 2015   #7

64-bit Windows 10 Pro

My System SpecsSystem Spec

 I can't run any .bat files!

Thread Tools

Similar help and support threads
Thread Forum
Are files lost when I choose delete temporary files before burning cd
I am new to burning pictures from my computer to a cd. After successfully burning 2 cd's, on the 3rd attempt, the message exceeds set limit came up. I think I should click delete temporary files, but if I do will the pictures in this file be lost or will they go back to their original location so I...
General Discussion
Windows 7 won't boot, SFC found corrupt files, hdd/files still intact
I get a windows boot error 0xc000000e if I try to boot into safe mode or launch startup repair through through windows boot manager. I tried using a windows 7 recovery usb but startup repair says it cannot repair the problem automatically. Through the command line I ran chkdsk /f and /r multiple...
Performance & Maintenance
Files in Memry card converted to unreadable files with size in GBz
i have a camera named "Canon PC 1264",,the pictures in the memory card are converted to some unknown file type with size GBz....some of the picture's folders are in the original conditions but 3 to 4 folder are change due to some known reason,, Please suggest me someone a solution,,the pics are...
Hardware & Devices
.wma files appears as .dat files in Temporary Internet Files folder
Hi, I am running IE8 on Windows 7 (Home Premium 64bit). My Temporary Internet Files folder is C:\Users\<username>\AppData\Local\Microsoft\Windows\Temporary Internet Files\Low\Content.IE5. I have enabled Show Hidden Files and Folders and removed the tick for Hide Protected Operating System...
Browsers & Mail
error-failed to load locale files from "Program Files\Western Digital\
failed to load locale files from "Program Files\Western Digital\WD Smartware\Locale" The menu box it's under is entitled " WDContextMenuHandler " I get this error when I just right click on any part of "my computer" everytime. the pc then goes blank on desktop while it says " windows...
BSOD Help and Support
.reg files open Notepad - do not change registry to read older files
Running Win7Pro 64-bit. Am unable to open older Office 97 files with Office2003 which is installed and running fine. I found a couple of files here and elsewhere with .reg extensions that were supposed to make the necessary registry changes. eg. "UnlockWord.reg" and a more elaborate-looking...
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App