Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lenovo Z580 Blank Screen on Startup Problem!

14 Apr 2015   #1
kitkat4life

Windows x64
 
 
Lenovo Z580 Blank Screen on Startup Problem!

Hello, I am having a very big struggle with turning on my laptop to show a display. People have said that I should get a VGA or a HDMI cable and connect it to a monitor so I have done that. Some have said press take out the battery and charger and press the power button for 40 seconds then put the charger and battery back in, that I have tried. Lastly, they have said to press the NOVO button on my laptop (A button that is only on Lenovo laptops) but unfortunately, all of these suggestions have not seemed to help.

The laptop does turn on but the display does not come on so its just a black screen, sometimes though you can get a display and after that when I hibernate or shut the laptop down it will begin to not show the display again unless I am lucky and it turns on. Does anyone here have any other suggestions that could help?

Thanks!


My System SpecsSystem Spec
.
14 Apr 2015   #2
americancritic2

Windows 7 Home Premium 64-Bit SP1
 
 

Hello Kitkat4life and welcome to the sevens forum:

1. Can you get into safe mode, try and see if it does it in safe mode.
2. When the laptop does come on have you tried to run your anti-virus to see if you have a virus.
My System SpecsSystem Spec
14 Apr 2015   #3
gregrocker
Microsoft MVP

 

You said you tried an external monitor. Does it get any signal at all and if so describe it fully?

Do you see the BIOS spash screen when you first start it up. What exactly do you see, if anything, on the screen.

If there is no signal at all, or it is intermittent, then you may have a failing display adapter or you could have a failing screen or loose connection in the wire harness that connects the screen. This can be checked if it is indicated by reading your Manual on the Lenovo site, or Googling for a video for your mode that shows how to disassemble the laptop to reach the wire harness.
My System SpecsSystem Spec
.

Reply

 Lenovo Z580 Blank Screen on Startup Problem!




Thread Tools




Similar help and support threads
Thread Forum
Lenovo G580/i5/4GB blank screen on bootup
Hi All, I am facing problem please help me out. Actually I forgot my Administrator password and I was using my system using Guest Account. But unfortunately today when I turn on my laptop to try recover the password, display turned into Blank and I hardly can see folders, Icon etc. I...
General Discussion
Windows 7: Blank screen on boot up, before login screen; slow startup
After the Starting Windows screen a blank black screen with a cursor that I can move pops up that lasts a minute (shouldn't happen with SSD, used to be ~10 second boot). Afterwards the login screen will appear as normal and everything works as normal. This doesn't happen when I boot into safe mode....
General Discussion
64-bit - Blank screen on boot up, before login screen; slow startup
Bonjour mes amis. I recently have started getting the infamous black screen of death at my computer's startup, very similar to this fellow user's problem. Basically, Blank screen on boot up, before login screen; slow startup. The black screen lasts at least two minutes on average, before the...
Performance & Maintenance
Lenovo Ideapad Y560 shows blank screen after booting
I am not able to update my VGA driver with any other than ATI Mobility Radeon HD 5730. However when I boot having this driver keeps my screen blank till I have to reboot it in Safe Mode and choose Standard VGA driver. I have attached my MiniDump folder with this thread. What shall I do? ...
Drivers
Blank screen on boot up, before login screen; slow startup
Hey, first time posting here, so sorry if this is the wrong section or anything. Lately my laptop has been experiencing a problem when I boot it up. After the Starting Windows screen with the glowing Windows logo, a blank black screen pops up that lasts for ages (I'd say at least 5 minutes)....
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:08.
Twitter Facebook Google+