Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: explorer.exe - Entry Point Not Found

16 Apr 2015   #1

Window 7 Pro, 64 bit
explorer.exe - Entry Point Not Found

My computer is self-assembled. CPU: Intel i5. OS is Windows 7 Pro, SP1, 64-bit. Hard drive has a capacity of 1 TB and RAM is 8 GB.

When I right click a folder icon on the desktop or in Windows Explorer, the menu comes up correctly. When I right click a file icon, I receive the following error message:

explorer.exe - Entry Point Not Found

The procedure entry point
PEAD@Z could not be located in the dynamic link library MSVCP110.dll.


Once I click “OK” the menu comes up normally.

I have done the following actions in an attempt to correct the problem:

• Checked for explorer.exe in C:\windows – it was there.
• Check the Registry, “WinLogon” for explorer.exe – it was there.
• Ran the Windows 7 DVD “Repair My Computer" – no change
• Restored the computer to a date in January 2015-no change
• Ran “Memory Diagnostics” – no discrepancies
• Ran “scf /scannow – no change

Can you tell me what is causing this problem and how to correct it?

My System SpecsSystem Spec
16 Apr 2015   #2

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM

Reinstall Visual C++


If that doesn't work try this one.

My System SpecsSystem Spec
17 Apr 2015   #3

Window 7 Pro, 64 bit

Thanks for the reply.

I downloaded vcredist x64.exe and ran it. I received this error message; “A newer version of Microsoft visual C++ 2010 Redistributable has been detected on the machine.” I uninstalled MS VC++ 2010 x64 Redistributable 10.0.40219. This time vcredist x64 installed, but I still had the “explorer.exe – Entry Point Not Found” error after the installation. I ran vcredist x64 again and it asked to Repair VC++ x64. I said OK but afterwards I continued to get the “Entry Point Not Found” error message.

Have I missed something or do you have any additional directions?
My System SpecsSystem Spec

17 Apr 2015   #4
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Give this tutorial by Brink a try. Can't hurt but might help.

SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
18 Apr 2015   #5

Window 7 Pro, 64 bit

I ran sfc /scannow three times. Each time I got "Windows Resource Protection did not find any integrity violations."

One thing I noted was the error message did not show up as Administrator, but once I switched back to my personal long on, the error showed up again
My System SpecsSystem Spec

 explorer.exe - Entry Point Not Found

Thread Tools

Similar help and support threads
Thread Forum
The procedure entry point ucrtbase.terminate could not be located
Hello guys, i got a problem message entry point not found after updating windows 7 the message is "The procedure entry point ucrtbase.terminate could not be located in the dynamics link library api-ms-win-crt-runtime-l1-1-0.dll" I also attach the message picture here. Some ways to fix this...
General Discussion
Window7 errors LogonUI.exe- entry point not found
LogonUI.exe- entry point not found the procedure entry point Btsdk_BLEG.GetProximityLockState could not be located in the dinamic link library BsSDK.dll Please help me :huh:
Performance & Maintenance
Entry Point Not Found for Kernel32.dll on multiple applications
I keep geting Entry Point Not Found errors on mutiple programs. I have no clue what causes it, and the programs aren't even similar. I've been just dealing with it, but now I think it's causing me to not be able to upgrade to IE10. Can anybody shed some light on fixing this? I don't really...
jogl.dll is loaded but the entry point to dllregistryserver not found
Hello Everyone, I am trying to use a software which requires jogl.dll and jaglib.dll files. But when i try to load these using regsvr it giving me the following error "jogl.dll is loaded but the entry point to dllregistryserver not found". please help me. I am using windows 7 home basic.
"Entry Point Not Found" Error While Attempting To Play A Game
Hello, I receive this error when I try to play the game, "Bit.Trip Runner": I've googled for hours and I've tried every suggestion, nothing is working for me. I've re-downloaded, uninstalled and re-installed Visual Point C++ 2010 SEVERAL times. Cleaned my...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App