Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Corrupt or Missing BIOS - no POST, can't boot from USB or CD

23 May 2015   #1

Windows 7 Home Premium 64bit
Corrupt or Missing BIOS - no POST, can't boot from USB or CD

Dell Optiplex 790 (SFF). Will not boot - Diagnostics are Amber Power light (steady) and diagnostic lights 2,3 & 4 flashing amber - this indicates a corrupt or missing BIOS. Turning on, the PC powers up but immediately starts the flashing diagnostic lights. This is my daughters computer and appears to have just randomly happened.

Had the issue confirmed by Dell, but as I bought it second hand and have no idea which company originally owned it, I cant get a repair via any warranty.

Have downloaded the BIOS from Dell and created an MS-Dos start-up disk (via Rufus) on both a USB drive and a CD. The PC will not attempt to boot from either source and continues to flash the diagnostic lights. As I have no access, I cant change the boot sequence.

Is there any method to force a boot from either USB or CD? - or an alternate option?

Most forums tend to recommend a new motherboard when this happens in Dells, but be great to avoid this if possible.

My System SpecsSystem Spec
23 May 2015   #2

Windows 7 Ultimate x64 SP1

Hey, sorry to hear

Did you try clearing the CMOS? you may need to search how to clear it for your PC

Also do you get any action on the screen when you power up? You can try Boot Menu option (usually lists the key to press when BIOS first screen) which is a one time "boot from" menu.
My System SpecsSystem Spec
24 May 2015   #3

Windows 7 Home Premium 64bit

After posting I followed a thread on clearing the CMOS. Bit tight inside the case, so the best option was to remove and re-seat the battery, which I did. Made no difference.

The screen remains blank throughout. Tried the function keys on start-up to try and access the bios, but no joy.

If I have to replace the motherboard, is the dell board a standard sized micro board? (might be a cheaper and easier option to replace with something other than Dell).
My System SpecsSystem Spec

12 Apr 2016   #4

Windows 7 x86

Danter, did you solve this issue? If so, what did you do?

I have an Optiplex 990 SFF giving the same diagnostic code.

My System SpecsSystem Spec
12 Apr 2016   #5

Windows 7 Home Premium 64bit

In the end I replaced the motherboard and all is now working as it should.
Expensive to purchase in Australia (where I am) but found a cheap second hand board from the US for about $30 from memory. Easy install and rebooted without a hiccup.

Besides the wait for the board, it was an easier option than the hours wasted attempting to find a solution that I suspect was never going to work.
My System SpecsSystem Spec
13 Apr 2016   #6

Windows 7 Ultimate x64 SP1 OEM

Hi may I interject.
If the motherboard has a removable BIOS chip it is possible off ebay and from the guy I used he was in the USA.
You can order a new pre-programmed chip with what ever BIOS version you like.
I had to de-solder my chip but I have that ability so if it is in a socket you just pry it out and slip in the new one and boot.
I would also replace the back up battery at the same time as this was probably the reason why it went belly up in the first place.
The IC chip number written on top will be required of course and I would remove any battery and power before replacement of the chip.
Sorry Danter a bit late for you :-(
My System SpecsSystem Spec
13 Apr 2016   #7

Windows 7 x86


Thanks for the response. I called Dell's out of warranty hardware repair number and the service rep (from India) indicated the MOBO was this issue and they could send someone to fix it for US$319. Based on that, I ordered a "New" MOBO from eBay for US$37 including shipping. It's good knowing a MOBO swap fixed your issue - my next candidate, the CPU, is a lot more $$$.

If the BIOS flash is in a socket (which seems unlikely) I'll try swapping it.

The MOBO will be here in a week. I'll report back as to the level of my success then.

Thanks guys.

My System SpecsSystem Spec
14 Apr 2016   #8

Windows 10 Education 64 bit

Some OEM PC's have a BIOS recovery feature. You'd have to search for it by manufacturer. You put your bios file on a thumb drive or floppy and press a certain key, or key sequence on boot up and it flashes in the blind.
My System SpecsSystem Spec
17 Apr 2016   #9

Windows 7 x86

I swapped out my Optiplex 990 SFF motherboard which solved my issue. The computer runs again!

The only socket part on the 990 SFF motherboard is the CPU so swapping the chip containing the BIOS isn't practical - especially given a new motherboard costs US$37!

Thanks everyone for the help!!!

My System SpecsSystem Spec

 Corrupt or Missing BIOS - no POST, can't boot from USB or CD

Thread Tools

Similar help and support threads
Thread Forum
BSOD then no boot cause fwpkclnt.sys is missing or corrupt
I got a BSOD on my SSD and booting up it told me that "fwpkclnt.sys is missing or corrupt". I ran Startup Repair, tried System Restore, did a few things in command prompt, and nothing has worked. So I switched to my HDD for a day (it was working fine) but then overnight it BSODed or something and...
BSOD Help and Support
Can't Boot or repair - NETIO.SYS missing/corrupt
I returned home today to find my computer off and not able to boot. My wife said all she had done was web browsing and then sleeping the computer. At this time the computer tried to Auto-repair the startup but would cyclically fail (indicating an issue with NETIO.SYS). I performed the following...
BSOD Help and Support
No Post, No Bios, No Boot From CD
I have no idea what is going on... I posted to this forum about our other HP desktop: and now other other HP desktop (with the identical motherboard) is now failing as well. This one is a pc6000,...
General Discussion
Win 7 boot files missing or corrupt
I have an Advent Roma 2001 configured, in PC World style, with a "recovery partition" alongside the system partition and, after resolving a hard disk problem, I found that the machine would not start/boot Windows 7. clearly some necessary files are missing or corrupted, but the normal system...
Performance & Maintenance
windows 7 boot loader missing/corrupt
I recently Uninstalled my Ubuntu 9.10 partition from my 500gb IDE hard drive, and thought nothing of formatting the partition and setting it up as a new windows drive. But, out of my own forgetfulness, i forgot that in rder to dual boot windows 7 with ubuntu, you Have to install the GRUB boot...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:50.
Twitter Facebook Google+