Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Keep on getting violation error especially towards EXE and 'system'

28 May 2015   #1

windows 7 64bit
Keep on getting violation error especially towards EXE and 'system'

First, hi to everyone that are willing to help me out of this real trouble...
i jst having a new laptop of i7-4510u , nvidia 840m , and using 7 64bit as OS but then...

error keeps on popping out to me, especially MOST of my exe file is being corrupted or so,
access violation in lots of apps, file is being used, and many more... im not someone who doesnt understand computer at all, but this is just beyond my capability that i cant figure out anymore how to deal with...

so please if you guys dont mind helping me, then i will start a complete brief story...
pls i know it will be a wall of text but.... this is all i know...

(this is current situation, even after i reinstall windows)
Current Error List & Weird Behavior :
-30% of all of my *.exe cant be EXECUTE ever again once i opened it,
this is just crazy, once i execute it, exit and enter again, error pop out...
SUCH as error 0x000007c and 0x0000142 ( or so if my memory serves me right )
But some... can WORKS perfectly just fine without getting corrupted after i open it
ALSO, WHEN i try to replace those *.exe that got corrupted with the original one, "it works again!"
when it corrupts again, i can simply replace it by extracting the real *.exe that i backup
OKAY, this is not the solution at all... i mean this doesnt solve the error

one last thing, every detail is mostly "appcrash" issue.
-trying sfc /scannow give me a result where it found a corrupted system file but CANT be fixed.
-trying to fix exe registry said it cant be rewrite since some of them are being used
here is some of the code... :

Windows Registry Editor Version 5.00

"Content Type"="application/x-msdownload"






@="\"%1\" %*"


@="\"%1\" %*"






[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]

While previously before i try that full exe reg, i try the simplest one by this :

@="\"%1\" %*"

@="\"%1\" %*"
i found that my HKEY_CLASSES_ROOT\exefile\shell\open\command has the value of "%1\" %* instead of \"%1\" %*

so i change both back but still wont work since some of my *.exe app SUDDENLY not working
so yeah that full *.exe reg cant be used to rewrite everything...

I think that's ALL my current error list, WHILE PREVIOUSLY.... T^T
i have tons of error... that makes me have to reinstall windows 7 and format my C system...
I keep the D file thou

previous error before i reinstall windows :
-my *.exe start to get error and cant be execute
-then MY EXPLORER.EXE cant be launch even on safe mode
this is where the disaster getting real, i operate everything via task manager,
of course i cant re run explorer.exe since its getting the same error,
i run through browser search for everything i could do, sfc scan, malware scan,
everything and replace my *.exe and dll stuff, it wont work , cant even system restore
THEN before this error solve, here goes the worst....
-the next one, still cant run explorer.exe , now I CANT open notepad, i cant write/type in CMD,
cant access regedit, this is just... ... awesome..... i mean it, i CANT HANDLE it anymore.

thus i have to clean format by reinstall my win7 64bit, keeping my Drive D file....
when i got back my desktop, sure things goes back normally, then i start to reinstall my framework 4.5.2,
directx, vredist, updating graph card and stuff, things goes well for 1 day, then the error i list above appear and that's my current situation right now....

allrite, currently im still FINE, i can run most of my *.exe , let say they are all my game,
yep i can run my DMC5 exe, RE6 exe , but i sometimes cant launch my ffxiiilauncher.exe ,
that i have to replace the *.exe , yeah the size is different... ( the corrupted one that cause error )
have no trouble accessing cmd and explorer still running... AND sfc now scanned something corrupted that it cant fix...

please... help me before my next assumption is its getting my explorer.exe wont be able to run then its getting worst till i have to.... reformat or stuff...

FINALLY... here is my assumption of the error AND what IVE BEEN doing since i bought this new laptop :
-install all working software, such as all adobe, microsoft stuff and some programming stuff.
(no problem)
-copy back all of my document and file from my other laptop
(no problem)
-install tons of game
(no problem)
-getting lots of game from my friend
(no problem)
-installing some japanese game that require japanese apploc
(Strange but this is where everything began to corrupt)
error keep popping out that i cant finished install stuff or whatsover...

then i dont know, i never think i mess it up so badly till this crazy error...
till i reformat, doing the same thing, but the same program and game,
somehow works fine for 4 days, then the error shows up again...

SO i think there is a virus? maybe? on my D, but i cant HARDLY figure it out HOW could it be possible...
most of the game apps is 99% safe for me, all i do was jst trying to install everything and check if they are working or not, they are working, till one point where it ruins my exe stuff then this disaster is up.
and im using 64bit? and it got corrupt by 32 system? but HOW? i just... dont get it

please dont suggest me using :
check disk, sfc scannow, malwarebytes, antivirus scan, and most google method.
ive already tried them all, currently using Avast and Smadav.

ask me anything that will reveal more of what cause this error, i will try to provide the log or stuff.

Before things get worsen, i really wish i could get back to my usual daily life with my desktop.

Thanks to everyone thats reading and those who willing to help, you have GREATEST gratitude.

My System SpecsSystem Spec
30 May 2015   #2

windows 7 64bit

please, now its start to getting worst again...

when boot, i start to get error that windows register service error ( about 2 times ) , vlc cant be run, my right click winrar cant be used ( Rarextloader.exe encounter error and appcrash ) and many more,...

please, before explorer start to go crazy and i have to reformat things
My System SpecsSystem Spec
30 May 2015   #3

Windows 7 Ultimate x64 SP1

You can try Repair Install I guess if everything fails.

Unless someone provides an easier approach.
My System SpecsSystem Spec

31 May 2015   #4

windows 7 64bit

i want to avoid that if possible, since im going to lost a portion of my data as well,

but i tried once again to scan using another anti virus, i found like total of 400 thread, ALL of them was *.exe file and im sure its the corrupted one, only 3 file is from C which probably got corrupted as well but not an exe, if i remember correctly its user.init msc stuff and i forgot the last one, is there any other way?

since that doesnt really helps even i delete those *.exe i perhaps just have to reinstall stuff,
but did i got the error source gone? so it wont affects my other *.exe again?

btw thanks for trying to help
My System SpecsSystem Spec
31 May 2015   #5

Windows 7 Ultimate x64 SP1

You should backup data to another drive right away anyway.

And run scans with:
- Malwarebytes Anti-Malware free -
- ESET Online
- AdwCleaner - Windows Downloads
My System SpecsSystem Spec
01 Jun 2015   #6

windows 7 64bit

i already tried anti malware...

but okay
i will try ESET Online and AdwCleaner, hope i can catch things that cause error on my system...
My System SpecsSystem Spec

 Keep on getting violation error especially towards EXE and 'system'

Thread Tools

Similar help and support threads
Thread Forum
BSOD, error 0x010d framework violation
I started getting my first BSOD a week ago, now I get one everyday. I though it was related to my xBox controller (since it was always plugged in when the bsod happened) and tried to correct it, but get another BSOD. That's why I'm asking for your help. I get a Framework Violation, 0x010d, 0x0,...
BSOD Help and Support
Access violation error happening everyday, ole32.dll
Hello SevenForums community, After hours of researching through Google, I could not find a solution for my constant problem that has been happening for the past month and so. Every night, this error would pop up while I'm watching a video, editing a video, on Skype, etc. I have updated all of my...
General Discussion
Runtime error (access violation)
Hello, I have a problem during the installion of a software (the software is Battery 4 by Native Instrument) When the installation starts, this error occurs: Runtime error in setup script: Line 438: access violation at address 74A715DA in module 'version.dll'. Read of address 00000004 ...
Installation & Setup
Error:access violation at 0x0170CA9B (tried to read from 0x00000000), getting this error when i start playing games downloaded from
BSOD Help and Support
Access violation Error, Migrating from xp to win-07.
I am exhausted by using windows-7 operating system. we have tools developed in windows-xp environment. Now we have the plan to migrate all the tools to windows-07 OS. After installing the tools in win-07 machine i am be not able to run the tool because of "Access violation error (with some...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:20.
Twitter Facebook Google+