Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 does not read UDF formatted DVD's

04 Jun 2015   #1

Windows 7 Ultimate 64bit & 32bit, Windows 8.1, Windows XP Pro, Windows 10 TP 64bit, OpenSUSE 13.2
Windows 7 does not read UDF formatted DVD's

I have Windows 7 x64 Ultimate and suddenly one day when I tried to read the Windows installation disk Windows explorer did not read it. The only think I saw was a readme.txt file with the following content:

This disc contains a "UDF" file system and requires an operating system that supports the ISO-13346 "UDF" file system specification.

I thought that was a hardware problem and I rebooted into Windows XP (I have a multiboot system: Windows 7 64bit, Windows 7 32bit, Windows XP Pro, Windows 10 Preview and OpenSUSE). In XP the disk is being read normally, also in Win 7 32bit, Win 10 & OpenSUSE. The conclusion is that there is no disc or hardware defection, it's a problem of mounting the UDFS in Windows 7 x64.

The same problem appears anytime with any UDF wtitten DVD. In the device properties the file system appears as CDFS.

There is no 3rd party burning software installed and the Windows DVD is original. I have not any other issue, no errors logged in event system, all installed software is original and the Windows installation is relatively fresh (March 2015).

Does anyone know how to solve this problem without having to reinstall Windows?

My System SpecsSystem Spec
04 Jun 2015   #2

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

Here's a solution that work for one person:
Solved: XP cannot read UDF Filesystem - Tech Support Guy
A Search finds lots of pages about the problem including one on this forum back on 2009:
My System SpecsSystem Spec
04 Jun 2015   #3

Windows 7 Ultimate 64bit & 32bit, Windows 8.1, Windows XP Pro, Windows 10 TP 64bit, OpenSUSE 13.2

None of these solved the issue. Any other idea?
My System SpecsSystem Spec


 Windows 7 does not read UDF formatted DVD's

Thread Tools

Similar help and support threads
Thread Forum
How to read FAT32 formatted external drive on Windows 7?
I had a DVD recorder with internal HDD (Nortek, ndvx hd 160 p). It was repaired once, but the second time it stopped working, the repairer said the vendor didn't longer provide spare parts. I asked him to give me the HDD back as I had downloaded tons of home made movie of my kids from a...
General Discussion
Formatted External HD as exFat - Windows does not read drive...
Hey folks, I just reformatted a 350gig external hard drive as exFat so as to be able to use it with both Windows at home as well as Mac's - but now it seems my laptop does not read the drive ie I can't see it in MyComputer - although I can still safely remove for some reason. :confused: I...
Hardware & Devices
Windows 7 unable to read external drive formatted FAT32
I have an external drive that was formatted FAT32 which I have been using with my XP laptop for the past year. I have data on it that I want to transfer to my Windows 7 laptop. However, as soon as I connect it to my Windows 7 laptop, it comes up with a message saying "You need to format the disk...
Hardware & Devices
Can't read Mac-formatted FAT32 flash drive
I formatted a 64gb flash memory stick on a Mac with MSDOS/FAT32 format and copied some files to it just fine. When I plug the stick into my Windows 7 64 bit machine, it wants to format it! From what I have read, the Mac formatted it using a GUID partition. I can see it in Disk Manager and there are...
Hardware & Devices
External HDD WIN7 Formatted XP can't read it...
Hi Please accept my appologies if this is a known and solved issue that I haven't found yet. I formatted my Western Digital 500GB My Book with Windows 7 RC and copied all my data across my network from my mac's external HDD. I'm sure I formatted it in NTFS and not the new Windows7 FAT32...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:03.
Twitter Facebook Google+