Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: at my wits end with apphelp.dll errors!

06 Jun 2015   #1
aweber1nj

Win7 Ultimate x64
 
 
at my wits end with apphelp.dll errors!

OK, how I got here may or may not be important, but basically a VMware VM was misbehaving. I tried to "power off", but it was hung. I couldn't even kill the vmware process. So I was going to reboot. I started installing some Windows Updates, but they looked like they were hanging too. Just rebooted.

On reboot a lot of my startup programs (and those I try and run manually) throw an error about apphelp.dll being corrupt or missing. I never knew this dll existed, but google says it's pretty important.

I let checksur run, it completed. Rebooted - no better.

I ran sfc /checknow - results were that it found corrupted files, but could not fix them. I have that log, its over 40k lines. A lot of "Failed to verify if catalog file is valid" and "Failed to parse package manifest" entries.

Tried replacing apphelp.dll in safe mode (from my same-OS desktop). Did not help, so I'm not sure that's the actual issue.

Also ran CCleaner to see if it was a registry issue. No help.

Was going to bite the bullet and try an upgrade/repair install. It won't run for some reason (could be using the corrupt dll for all I know). It gets to me selecting Win 7 Ultimate x64 and then says I can't upgrade 32bit to 64bit or vice versa. But I'm choosing x64 and double-checked that my laptop is running x64, so that can't be the problem.

Was going to try and comb through the CBS.log file and see what files it's complaining about and try and replace all of them with a batch script in safe mode. But that file is really strange, and I'm not sure what, if any, of these files really need to be replaced or is it that the XML Parser can't read any of the files because apphelp.dll is crashing it?

So I need help. Apparently I have some corruption in my OS files, but I can't fully determine where and therefore how to fix it. I obviously am desperate to NOT have to re-install from scratch.

Does anyone have any ideas or utilities I haven't tried? Appreciate any help/links/tips!

-AJ


My System SpecsSystem Spec
.
06 Jun 2015   #2
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

I know that you don't want to reinstall Windows from scratch, but at this point it may be your only option.

That being said, rebooting the machine during Windows Updates may have been the start of your troubles. Have you tried doing a system restore from before you did the updates and rebooted? I don't know if it will work, but you should try everything you can to avoid a from-scratch reinstall.
My System SpecsSystem Spec
06 Jun 2015   #3
aweber1nj

Win7 Ultimate x64
 
 

Yes, I'm trying everything possible to avoid a from-scratch reinstall. Too many programs and settings I'd have to deal with on that kind of reset!

I'll be honest, and it's obviously biting me now, I turn off System Restore after installs. So I don't have one.

I have a recent backup, but I don't know that it'll do me much good, because these system files are so hard to just replace.

I agree, the reboot during updates is probably where it started. It is what it is now. (Note, I didn't force the reboot or power-off the PC, I just happened to choose restart during the updates...one would think there would have been a transaction rolled back or something.)
My System SpecsSystem Spec
.

06 Jun 2015   #4
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

If the backup contains the core Windows system files, or includes a recent system image, it may be the place to start.

In any case, I would recommend capturing any data from that disk and backing it up, in case you do have to do a fresh install.
My System SpecsSystem Spec
Reply

 at my wits end with apphelp.dll errors!




Thread Tools




Similar help and support threads
Thread Forum
at wits end here..
friend has Windows seven laptop and for years happily received her e-mail from BT via Live Mail. About three weeks ago, something bad happened, corruption or hacking, don't know, and she was advised to change her password, which she did, and she can still get to her web mail, using this password,...
Browsers & Mail
At Wits End!! Please Help :)
Oh geez......ok, I have Windows 7, 64 bit and I have been using Windows Live Mail successfully until today. I can't send nor receive email. I have contacted Comcast in regards to this error: Unable to send or receive messages for the Comcast (myname) account. The connection to the server has...
Browsers & Mail
At (new printer) wits end!
HP 990 died after years of consistent dependability. Do not want nor need a multi, just a plain ole single purpose inkjet PRINTER. Sounds simple right? Couldn't be further from reality. After beaucoup research, regardless of what 'reviewers' say about any current single function inkjets,...
Hardware & Devices
I'm at wits end =(
I recently rebuilt one on my computers into a new case (and added new harddrives and video card). Afterwards I attempted to install Windows 7 PRO 64bit. It hangs at the first "Starting Windows." I have been browsing these forums and just about every other one on the net trying EVERY solution I...
Installation & Setup
Crashing: Gotten me at my wits end.
As the title states, no ,matter what I do, I am constantly crashing. At first I thought it was a compatibility issue with my RAM, as my old DIMMs were not on the QVL for my motherboard. So today I bought new DIMMs that were on the QVL, and much to my surprise, after a while on Team Fortress 2, ...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:35.
Twitter Facebook Google+