Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: svchost.exe + NTDLL.DLL Causing high CPU Usage

11 Nov 2009   #31
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

It would be really nice Satanical Eve, if you could give those of us who have jumped in to help you, some more 'input' about how your computer is working now.


My System SpecsSystem Spec
.
12 Nov 2009   #32
Satanical Eve

Windows 7 Professional 64 BIT
 
 

Quote   Quote: Originally Posted by Jacee View Post
It would be really nice Satanical Eve, if you could give those of us who have jumped in to help you, some more 'input' about how your computer is working now.
Eh I was just about to come in here to talk about it. I only once had to suspend the svchost process with NTDLL.DLL inside of it yesterday. That was before I did the malware bytes scan. Once I did that. I also removed my IRC Bot that I run from the computer. That bot is being moved over to a remote computer with me having SSH access and all that for it. Ended up from 5 PM last night until I did this post it did not spike once at all. I know it usually does it within 4-7 hours Its been around 18 and half hours without it happening once. Now I'm holding my breath hoping the issue is resolved which I do believe it is because. I set up last night when I was asleep for the my PC to inform me if that ntdll.dll process spiked up and not once did it.

I'm going to keep this unresolved for now. Going to give it another two more days and see what happens. I'd like to thank everyone though for your help. I was trying this on my own fixing wise and got to a point where I was like eh I need another expert opinion. Thanks a bunch
My System SpecsSystem Spec
12 Nov 2009   #33
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

My System SpecsSystem Spec
.

12 Nov 2009   #34
Satanical Eve

Windows 7 Professional 64 BIT
 
 

Just wanted to say thanks to all the folks in here who helped me. The problem has seemed to go away. I do not know exactly which fix got rid of it. But thanks again. I will revisit this thread if it ever crops up again
My System SpecsSystem Spec
12 Nov 2009   #35
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Quote   Quote: Originally Posted by Satanical Eve View Post
Just wanted to say thanks to all the folks in here who helped me. The problem has seemed to go away. I do not know exactly which fix got rid of it. But thanks again. I will revisit this thread if it ever crops up again
Thank you for letting us know that you're in shape!

It just matters that you have control over and with your computer.
My System SpecsSystem Spec
13 Nov 2009   #36
Satanical Eve

Windows 7 Professional 64 BIT
 
 

The issue is not resolved. Just recently it reared its ugly head.

This is what I am getting from the infected NTDLL.DLL!tppworkerthread

ntoskrnl.exe!KiSwapContext+0x7a
ntdll.dll!NtSetSecurityObject+0xa
kernel32.dll!LocalBaseRegSetKeySecurity+0x72
kernel32.dll!RegSetKeySecurity+0x1e8
umpnpmgr.dll!SecuritySubkeyCallback+0x116
umpnpmgr.dll!EnumRegKeyWithCallback+0xa5
umpnpmgr.dll!SecuritySubkeyCallback+0xb8
umpnpmgr.dll!EnumRegKeyWithCallback+0xa5
umpnpmgr.dll!SecuritySubkeyCallback+0xb8
umpnpmgr.dll!EnumRegKeyWithCallback+0xa5
umpnpmgr.dll!InstanceSubkeyCallback+0x115
umpnpmgr.dll!EnumRegKeyWithCallback+0xa5
umpnpmgr.dll!EnumSubkeyCallback+0x156
umpnpmgr.dll!EnumRegKeyWithCallback+0xa5
umpnpmgr.dll!EnumSubkeyCallback+0x156
umpnpmgr.dll!EnumRegKeyWithCallback+0xa5
umpnpmgr.dll!EnumSubkeyCallback+0x156
umpnpmgr.dll!EnumRegKeyWithCallback+0xa5
umpnpmgr.dll!PnpSelfHealEnumTimerCallback+0x12f
ntdll.dll!RtlpTpTimerCallback+0xcb
ntdll.dll!TppTimerpExecuteCallback+0x105
ntdll.dll!TppWorkerThread+0x6c9
kernel32.dll!BaseThreadInitThunk+0xd
ntdll.dll!RtlUserThreadStart+0x1d

and heres svchost.exe!WmainCRTStartup

ntoskrnl.exe!KiSwapContext+0x7a
ntoskrnl.exe!KiCommitThreadWait+0x1d2
ntoskrnl.exe!KeWaitForSingleObject+0x19f
ntoskrnl.exe!KiSuspendThread+0x54
ntoskrnl.exe!KiDeliverApc+0x211
ntoskrnl.exe!KiCommitThreadWait+0x3dd
ntoskrnl.exe!KeWaitForSingleObject+0x19f
ntoskrnl.exe!NtWaitForSingleObject+0xb2
ntoskrnl.exe!KiSystemServiceCopyEnd+0x13
ntdll.dll!NtWaitForSingleObject+0xa
KERNELBASE.dll!WaitForSingleObjectEx+0x79
sechost.dll!ScSendResponseReceiveControls+0x13b
sechost.dll!ScDispatcherLoop+0x121
sechost.dll!StartServiceCtrlDispatcherW+0x14e
svchost.exe!wmain+0x110
svchost.exe!ScCreateWellKnownSids+0x2fd
kernel32.dll!BaseThreadInitThunk+0xd
ntdll.dll!RtlUserThreadStart+0x1d
My System SpecsSystem Spec
13 Nov 2009   #37
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Did you ever run sfc /scannow?
My System SpecsSystem Spec
13 Nov 2009   #38
Satanical Eve

Windows 7 Professional 64 BIT
 
 

Quote   Quote: Originally Posted by Jacee View Post
Did you ever run sfc /scannow?
I didn't think to do it.

I'll do it right now. See whats up with it. I had to uh suspend the process again. though ntdll.dll. Which then in turn caused the CPU to go back down to the normal levels. I'll post the results though. Worked for a good 2 days just about until it went back to the old habit of Spiking.

So it did the SFC scan. Hopefully repairing any damaged files. I downloaded and have Process Monitor running so hopefully if this creeps up again I might get a better picture of whats going on at the exact time the CPU spikes up.
My System SpecsSystem Spec
13 Nov 2009   #39
Satanical Eve

Windows 7 Professional 64 BIT
 
 

So I ended up doing a full system report using Get System Info by Kaspersky. Heres a link to it. Its a very long txt file but it has a ton of info on it. Maybe something inside of it will point to what is going on. I'm looking at it right now to gather more information and hopefully the direct problem

http://tinyurl.com/systemurlinfo
My System SpecsSystem Spec
14 Nov 2009   #40
Satanical Eve

Windows 7 Professional 64 BIT
 
 

I uninstalled Kaspersky and will not be using it. I have a feeling it might be causing issues with the high cpu usage. Process monitor would show that Kaspersky was working more then it should when the CPU would spike. So I uninstalled it. Hopefully the issue is related to that. I did install Bit Defender for now as a protective measure until I can truly be sure its Kaspersky
My System SpecsSystem Spec
Reply

 svchost.exe + NTDLL.DLL Causing high CPU Usage




Thread Tools




Similar help and support threads
Thread Forum
Svchost.exe High memory usage at startup
Hello So I had this problem for a while now and it's really annoying. Just after the "Welcome" message the PC keep loading for few mins and I can hardly open any software due to this high memory/CPU usage. I already disabled some startup programmes/services but that didn't help Is there a...
Performance & Maintenance
one of the svchost.exe causing my system to have high cpu usage
i saw this process in task manager svchost.exe causing my system to have 50% cpu load at idle, after i end task it the windows gui desktop turns to classic and returns back to normal. how to fix this btw i have windows xp but i know you encounter or read some of this problems please help me fix...
Hardware & Devices
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance
svchost.exe high memory usage
hello everyone, recently my pc has been having some minor 'lag' problems, i think best describes it. Its relatively new with good specs so it should be able to handle the programs that i use on a regular basis easily. I looked in the task manager and sorted processes by highest memory usage,...
Performance & Maintenance
High SVCHOST.exe memory usage
Hi, my name is Chris. I'm having quite a bug problem with a high memory usage in one of the svchost.exe processes(more than 120,00+ memory usage) and if i try to use another program like firefox, the computer crashes. I'm using an VAIO VGN-NW310F 2.2GHz Intel Pentium Dual-Core T4400...
BSOD Help and Support
svchost.exe / Schedule, high CPU and RAM usage
I've been having a problem where svchost.exe is using 25% of my CPU (X4 630) and 1GB+ of RAM. I tracked this down to the Schedule service but still don't know why it's happening. The Tasks that run (in case someone happens to know that one of these is known to cause this problem) are: ...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App