Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I used TestDisc - now laptop won't boot

03 Aug 2015   #1

Windows 7 Home Premium 64 bit
I used TestDisc - now laptop won't boot


Today I was using TestDisc to try to recover an external hard drive that was hooked to my laptop. I used this set of instructions:

Regain a lost drive using Test Disk - An Illustrated Guide

After a couple of hours, when the steps were complete, I rebooted my machine. It first showed the normal Dell screen where it says "F2 for setup, F12 for Boot options." After that, instead of loading Windows, it flashes a black screen with some writing on it (I can try to capture what it says if needed), and then it goes to a Dell diagnostic screen with three options (Test Memory, Test System, and Exit). If I exit, it just runs through the same process I just described, only to land me on the same diagnostic screen.

I haven't done much of anything else to attempt to correct the problem, mainly because I wouldn't be sure where to start. And the whole reason this happened is a bit puzzling because I was quite certain I was using TestDisc on the external drive. Anyway, if anyone can help I would be GREATLY appreciative.


My System SpecsSystem Spec
03 Aug 2015   #2

Windows 7 Enterprise x64

can you please capture what the writing says, also, you may have clicked the wrong drive by mistake
My System SpecsSystem Spec
03 Aug 2015   #3
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I know little of nothing about a Dell but you could check your boot priority in the bios.
My System SpecsSystem Spec

25 Sep 2015   #4

Windows 7 Home Premium 64 bit


Sorry about the very long time since I posted about this. Lot going on and I just let things go. The laptop is in the same condition as before, and I haven't done anything to try to fix it.

The screen that comes up black with white text says the following:

Loading DRMK V8.00...

DRMK Version 8.00
COMMAND.COM Build 37 - July 28, 2008
DRMK KERNEL Build 15 - Aug 8 2008
Copyright (c) 2006-2008 Dell Inc. All Rights Reserved.

It is possible (and likely) that I selected the wrong drive when I ran the program. I am assuming that is what happened, so now I just want to know if anyone knows how to recover my system from this point. I would like to have access to my drive and the files, rather than reload the OS from scratch, if at all possible. Thanks for taking the time to read.
My System SpecsSystem Spec
25 Sep 2015   #5

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

You could try booting something with a graphical partition manager and have a look.

PW does a free one:

Bootable Partition Manger | MiniTool Partition Wizard Bootable Edition
My System SpecsSystem Spec
25 Sep 2015   #6
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

By chance would you have a thumb drive or DVD plugged into your computer with DRMK Version 8.00?
If so, unplug it or remove the DVD.
Unplug all usb things except your mouse and keyboard and then try booting.
My System SpecsSystem Spec
26 Sep 2015   #7

Windows 7 Home Premium 32 bit

Clap,clap! Excellent suggestion by Layback Bear.( Have to spread my reps a lot.)

It may simply be booting to the disc or the bootable usb/RAM drive that you created. Remove the disc or usb and it should boot into windows.

Did you run TestDisk from a bootable USB pendrive? Bootable CD?

Did you change the boot priority on your machine?

As Layback Bear suggested, remove all USB devices plugged into your machine (except mouse/Keyboard). Also remove any CD/DVD in the optical drive. I will go one step further. Shut down your laptop. Remove the power adaptor from the laptop. Remove the battery. Leave your laptop powerless for a few minutes. As an added measure vent your anger by pressing the power on button on your laptop for a few seconds. All this should remove any residual charge on the laptop or struck bits. Now put the battery back, restore AC power to the laptop and boot.

Is everything OK?
My System SpecsSystem Spec
26 Sep 2015   #8
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Thanks for the clap/clap jumanji!
My System SpecsSystem Spec
26 Sep 2015   #9

Windows 7 Home Premium 64 bit


I have no discs in the machine, and nothing is plugged in, USB or otherwise (not even mouse/keyboard). I tried the suggestion of disconnecting AC and battery power and pressing the power button for a few seconds, and the problem persists.

Thanks for chiming in. Hopefully you have more suggestions.

I am getting to a point where I was planning to remove the hard drive and put it into my wife's laptop in the 2nd HDD bay (we both have the same model and year laptop, and they each have an empty bay for a 2nd hard drive). I was thinking this would perhaps allow me to access the drive to save my files, and then I could proceed with a more forceful way of recovering my system, even if it means rewriting the hard drive or something like that. What do you guys think of that?

Edit: I ran Testdisc from my hard drive - not a removable drive of any sort. And I did not knowingly change the boot priority.
My System SpecsSystem Spec
26 Sep 2015   #10

Windows 7 Ultimate x64

Some commands that can be run from an install DVD at the command prompt are

Bcdboot C:\windows NOTE: Replace C with the drive letter where the system is installed.


so boot an install DVD, select repair the PC, get to a command prompt

I would try this one first BOOTREC /FIXBOOT
My System SpecsSystem Spec

 I used TestDisc - now laptop won't boot

Thread Tools

Similar help and support threads
Thread Forum
Laptop won't boot (Logo screen),can't boot from USB/DVD or access BIOS
Hey guys, I've been searching the web for solutions for hours now and won't find anything that works for me. You are kinda like my last hope. :) Situation I have a Asus A54C Laptop here (it's my brother's), that won't boot. If I turn it on, it quickly shows the Logo screen and nothing else...
Installation & Setup
Laptop will not boot up
Hi My daughter has an Acer laptop, not sure of model. It has been slow booting up lately and now it will not boot up at all. When the power button is pushed, the power light comes on an the light for the hard drive flashes, the Acer screen pops up and the light for the hard drive flashes again. ...
General Discussion
BSOD on boot up. Laptop will not Boot
I have a Toshiba Laptop which for a number of weeks will not start up first time. I get a BSOD which shuts the computer down before I can read it. If I try to reboot "safe mode" takes ages to analyze (about 40 minutes) before telling me the issue cannot be solved. If I then boot again but select...
BSOD Help and Support
Cannot boot my laptop, windows can't find any hardrive to boot OS..
Today when I was surfing on my laptop (G74S Series) I wanted to restart the laptop because the internet crashed and it usually helps to restart. But I restarted it holding down the power button thing. So, I restarted it and while I was waiting, staring in to the screen, the blinking "_" thing when...
Hardware & Devices
Laptop cannot boot into Windows, possible 0xc000000f boot failure
First, some system specs: This is about a stock ASUS K50ID laptop, so the specs are as listed in this Newegg description. The very basic description of the problem is that whenever I turn on the laptop, it seems to boot into Windows 7, in that the "Starting Windows" text appears and the little...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:22.
Twitter Facebook Google+