Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Right Click Menu Doesn't function properly, very strange issue

14 Aug 2015   #1

Windows 7 Ultimate X64
Right Click Menu Doesn't function properly, very strange issue

Hi every one, first post here. I've been using Win 7 Ultimate 64 since the end of 2013 and never experienced any issues until now. Here is the problem:

The right click menu on most of the desktop icons doesn't open the programs. The menu opens, however clicking the "open" option or some of the other options doesn't work. Left clicking the same icons opens the programs without any issues. All the programs that do not open using the right click method are programs installed to windows. Programs like "Computer" "Recycle Bin" "Control Panel" etc. which are generic windows programs work as expected.

My computer is custom built by myself and has been rock solid. What I did was uninstalling some of these programs and reinstalling them with no resolution. Just finished a session with a MS attendant that finished in error when he was restarting my PC, but it didn't look like he had any idea what the problem was, he just run some tests that didn't show any errors.

I installed Kasperski Total Security about a month ago, but uninstalling the program didn't change anything.

Here is an example: right clicking the Google Chrome icon in the tray opens the menu, left clicking "Chrome" opens the browser however clicking on all the other options listed doesn't work, most of the other icons in the tray work properly, there are other icons on the desktop that behave in a similar manner, actually there is one Google Chrome that opens using the right click menu and another that doesn't.

It's some kind of file association issue I guess, but other than that I have no idea what's up.

My System SpecsSystem Spec
14 Aug 2015   #2

Linux Lite 3.2 x64; Windows 7, 8.1

Try going to MSCONFIG and performing a clean (diagnostic) boot. If that works, something in startup is breaking the context menu. Next, go to Programs and Features and sort by install date, and see if uninstalling something works. Then do the same for Windows updates. You also could create a new user account and see if it works there.
My System SpecsSystem Spec
15 Aug 2015   #3

Windows 7 Ultimate X64

Thanks paul, I tried the Diagnostic start up without success, tomorrow I will try the rest of your suggestions or I might just reinstall Windows, it could be faster than sorting out individual problems and wasting time. I was hoping someone would have experience same issue and suggest a solution.
My System SpecsSystem Spec

15 Aug 2015   #4

Win 7 Ult 64-bit

go to command prompt and write this command:
c:\> attrib -r -h -s autorun.inf
c:\> del autorun.inf
d:\> attrib -r -h -s autorun.inf
d:\> del autorun.inf
restart the pc

c and d are the names of logical drives - execute the command according the drives You have.

This solves issues with "open with" problems.
My System SpecsSystem Spec
15 Aug 2015   #5

Windows 7 Ultimate X64

Thanks BisVal, autorun.inf and del autorun.inf couldn't be executed, autorun.inf was not found on C. I tried typing it with space without space with the same result.

The search continues
My System SpecsSystem Spec
15 Aug 2015   #6

Windows 7 Ultimate X64

Hey Guys I am happy to report that the problem was solved. Changing the account didn't help, I finally decided to look my recently installed programs and remembered that "AirDroid" a program designed to communicate with your android device recently updated. I uninstall it and voila all is back to normal now. I am so glad I don't have to re-install Windows, no time for that.

Cheers and thanks to everyone for looking and helping me.
My System SpecsSystem Spec

 Right Click Menu Doesn't function properly, very strange issue

Thread Tools

Similar help and support threads
Thread Forum
Alt-Space Menu doesn't work properly sometimes.
For many years I've used the alt-space (system) menu especially for closing lots of windows when tidying-up. After switching to W7 I progressively gained the impression that on Windows Explorer this doesn't always work properly. Sometimes the window is not closed. It's taken some while to find...
General Discussion
Laptop Keyboard Doesn't Work Very Strange Issue
Have an old asus laptop that i use very little. I noticed that when i type something ... nothing shows up. I open up google. I type keyboard letters into google... nothing shows up. However when i click the letter F... it would seem to click on the top right corner where the 3 horizontal...
Hardware & Devices
Firefox 4 doesn't function properly in the taskbar
This is quite a weird problem and it started when I replaced Firefox 3.6 with Firefox 4 (as in uninstall Firefox and install Firefox 4). Everytime I am browing now Firefox 4 doesn't function properly in the taskbar. I made a screenshot of it which shows the problem much better. As you can see...
Browsers & Mail
My Computer right mouse click menu - explore function
hey guys first of all I want to wish any of you a merry christmas and a happy new year, may luck be brought to you for the year 2011 (and all the years that might follow). Anyway, what I was wondering is if there is any possibility to add the "Explore"-function when browsing the menu that...
General Discussion
winrar right click menu issue
i notice that through every version since 7000, i have to select the option twice, from the right click menu. the first time does nothing. then i right click again, select extract, and it works. very strange, 3 different machines i've tested, winrar 3.80

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:55.
Twitter Facebook Google+