Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I'm the Administrator but get message that I need permission

15 Sep 2015   #1

Windows 7 Pro
I'm the Administrator but get message that I need permission

I have a small tablet with a very small hard drive, I had 7 gigs or so of hard drive space in July when I got it. The only thing I use my tablet for is to watch movies and Chromecast Netfilx to my TV. So I haven't used up much of the hard drive at all.

I haven't used the tablet in about a month. When I turned it on the other day, it did a Windows update and soon after I started getting a message about not having much hard drive space available. I looked and I had just over 300 MB of space left!!! Something ate up over 6 gigs of my hard drive!

It dawned on me that it could be the Windows 10 upgrade offer. There was the Windows 10 icon in the tray, but I hadn't reserved the upgrade. Something came through my news feed about the update downloading regardless of whether you reserved it or not. After Googling I managed to find how to check if this was the case, and sure enough it was.

I spent hours and hours Googling all sorts of things and I have worked out how to delete the update file KB3035583, but I cannot delete the GWX folder found in Windows System32 folder which is what I need to do in order to regain the hard drive space. I have managed to do this without any problems on my desktop computer.

However, on my tablet, when I try to delete it from the System32 folder, I get a message that I need permission from "trusted installer". Interestingly enough, I was able to move the whole GWX folder over to the desktop.

When I try deleting it from the desktop, I get a message saying that I need permission from “LINDA\L” which should be me, because I am the purchaser, owner and only user of this tablet.

I have right clicked on the folder and picked "Properties" and "Security", but am not able to make any changes that way for some reason. Unless I'm doing something wrong.

I have done a bunch of Google searches and found out how to add an Admin and/or change permissions for users on C Drive. The problem I’m having is that “LINDA\L” is not an option in the list that I can pick from.

When I checked in User Accounts, there is only the one (my hotmail account) that I use to login to Windows with (shows as Administrator); and "Guest" which was OFF, but I turned ON.

I have found "LINDA\L" in the following path:

Control Panel
User Accounts and Family Safety
User Accounts
Configure advanced user profile properties

How exactly do I gain access to or get permission from that "LINDA\L" profile, so that I can take 100% ownership/control of my tablet’s hard drive/windows system so that I can delete this folder and get my hard drive space back? I'm pretty comfortable with maneuvering around the computer, so long as I have direction on how to do it, even in regedit, but I'm not looking to root around in folders that could damage my system. I just want to delete that folder and its contents.

I thought it might have something to do with maybe needing to create a User Account for "LINDA\L", so I did a Google search on how to do that. But when I tried I was told I don't have enough hard drive space available. Plus I don't even know if that is what I need to do.

Anyway, I desperately need to regain some hard drive space. But I don't know how to get permission from that profile so I can delete the GWX folder.

My System SpecsSystem Spec
17 Sep 2015   #2
Wandering one

Win7 sp1 Pro 64bit / XP sp2 Pro (games only)

Look in the TUTORIALS section for 'Files and Folders'. There is a tutorial by Brink to use a command prompt to delete. If you are not sure of this method, read it through a couple of times first. Best way is to make a printout to follow. No guarantees but it should work.
My System SpecsSystem Spec
17 Sep 2015   #3

W7 Pro SP1 64bit

Quote   Quote: Originally Posted by LindaLB View Post
...I have worked out how to delete the update file KB3035583, but I cannot delete the GWX folder found in Windows System32 folder...
I hope that "delete" means uninstall. You did not mention if you hide that KB.

Put the GWX folder back where it came from and run the native Windows Disk Cleanup tool via this steps: Windows 7 SP1 Disk Cleanup Tool

Step 3 lets you clean the 6GB downloaded for W10. You can save time by starting the cleanup tool via "run as admin". Change step 1 in the tut to use the Start menu. Type in
Disk Cleanup and right-click and "run as admin" on the shortcut that the search should find.

Restart after running that cleanup tool. It will look something like WU screens during shutdown and startup.

The screenshots in the tut are old - but you'll figure it out.
My System SpecsSystem Spec


 I'm the Administrator but get message that I need permission

Thread Tools

Similar help and support threads
Thread Forum
You need Administrator Permission to copy...
I am trying to copy files off a hard drive from a deceased laptop to my new laptop. No big deal I would have thought. I have copied many files from this drive using a USB gizmo that the bare drive slots into, not sure what the thing is called, but it works. The three partitions on the old drive...
System Security
getting Administrator permission
I'm trying to download Maxtor backup software and it refuses to let me install in Program Files folder. It says I need permission from the Administrator...that's me (this is a single computer at home), but I don't know how to give/get that permission. Can anyone give me the steps to get there? ...
No administrator permission
Trying to download a program and I receive a message that I do not have adminisrator permission. I am logged on as administrator. Right clicking does not give option to run as administrator. How do I get "permission"?
General Discussion
Site administrator permission
I am running 2 computers on a home network both of which are using Windows 7 While using a tutorial programme I am informed to leave a copy of the application into a specific folder. When I try to do this a message comes up: "You dont have permission to save to this location Contact the site...
General Discussion
Administrator Permission Help
I have been trying to save an installer but am unable to because Windows says that I don't have administrator permission. I've been reading on the forums that you can turn off the UAC but that did not help any. I also saw someone say that the "Owner" profile, the default, is a protected...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:19.
Twitter Facebook Google+