Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Random "access is denied" problem

30 Sep 2015   #1

64-bit Windows 7
Random "access is denied" problem

For the last couple of months, I have been getting random "access is denied" on all types of files. This usually happens when I'm trying to modify, rename, or delete a file, like a .txt file or something else.

When I get the "access is denied" error message, I usually have to wait a couple of seconds or more before it goes away. Everything then works again and I can modify my file as normal.

At first, I ignored it. But, now, it's really getting on my nerves, as this has never happened before so frequently.

Since it started only a couple of months ago, I suspect it has something to with my operating system.
Perhaps it's related to a Microsoft security update. I don't know.
And my hard drive is certainly not defective or dying. That is not the issue.

I have disabled "Windows Defender", just in case it's working in the background.
I have no other "real-time" anti-virus software installed.

My best guess is that it's Windows explorer.exe that is accessing my files while I'm looking at them. But, I don't know how to tell it to leave my files alone.

Any suggestions?

OS: Windows 7 Pro SP1, 64-bit

My System SpecsSystem Spec
03 Oct 2015   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Mate some system specs would be good please System Info - See Your System Specs

Now for starters please run these< if necessary include the /f and /r in the command line as per Option2

ADW download from bleeping computer delete any rubbish found with themalware scans

(NBIf one is running Kaspersky security it may rant about ADW - just ignore it ordisable Kaspersky while the ADW is being used)
My System SpecsSystem Spec
03 Oct 2015   #3

64-bit Windows 7

My computer is clean of viruses. Just wondering if someone else has experienced the same problem on Windows 7, 64-bit.

This is what I do on a daily basis:

1. Open up Windows Explorer. Browse to a directory.
2. Open up MS Notepad.
3. Write something and save it to a .txt file.
4. Save the .txt file.
5. Write some more text.
6. Save the .txt file again.
7. Sometimes get random "access is denied" when trying to write to file. .Txt file will not save.

I am logged in as administrator. It doesn't matter if I run Notepad "as administrator" either.
The file I'm working on frequently gets locked down (by another process?), and I can't save it.

Sometimes I have to write to a completely new file, because the lock won't go away.
Very annoying and very unusual.

Hard drive is Western Digital WD1002FAEX1TB, 1TB internal SATA hard drive.
My System SpecsSystem Spec

03 Oct 2015   #4

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Now I did say at the beginning that running those scans was for starters because I do things by elimination and usually from the obvious to the - well - less obvious. I wasn't suggesting for one moment you are infected.

I am left wondering if you also ran the SFC and CHKDSK?? because again it could just be some simple file corruption or bad sectors.

If those come up clean then it might be an idea to test the drive 14 Free Hard Drive Testing Tools (Updated October 2015) < see number 7 and I think I ma right in saying that Seatools can be used too (number 1 in that listing) - because I have used it in the past on WD's.

One more test is a surface test with this MiniTool Partition Wizard | Best partition magic alternative for Windows PC and Server see my pic for how it is run.

Once again I ma not suggesting that these are the problems and that testing the drive is just eliminating a possible cause.

Attached Thumbnails
Random &quot;access is denied&quot; problem-mini-tool-surface-2.png  
My System SpecsSystem Spec
03 Oct 2015   #5

W7 Pro SP1 64bit

Quote   Quote: Originally Posted by samurle View Post
...The file I'm working on frequently gets locked down (by another process?), and I can't save it....
Unlocker might be able to tell you what app or apps are locking the txt file.... if you can use Unlocker quick enough - before the problem goes away on its own.

Just watch out for the junk that Unlocker offers to install:
Impossible to delete leftover folders

Once Unlocker is installed...
...wait for the issue to happen
...quickly right click on the file from within Windows Explorer Unlocker from the context menu with the UAC

If Unlocker tells you "No Locking handles found", then maybe you missed the event.

If need be, Process Monitor can be used to find out what is happening. Process Monitor can be filtered to only show entries pertaining to the one text file involved in the test.

It would help us to help you if you would complete your system specs - including any security related software (antivirus, anti-exploit apps and the like).
My System SpecsSystem Spec
17 Oct 2015   #6

64-bit Windows 7

Thanks, I do use Unlocker, and it is indeed Window's explorer.exe that's locking down all my files.

Frankly, I think this problem is somewhow related to Windows 7's no-refresh folder fiasco.
That is one of my major annoyances as well. Yet another problem with no solutions, thanks to Microsoft.
My System SpecsSystem Spec
17 Oct 2015   #7

W7 Pro SP1 64bit

The odd thing is: this file locking by explorer does not happen to everyone. Lucky you

I realize that your on-demand virus scanners indicate no infections, but it sure sounds like something is making explorer behave abnormally. You might want to try some offline scanners:
My System SpecsSystem Spec

 Random "access is denied" problem

Thread Tools

Similar help and support threads
Thread Forum
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
Problem with "Access is denied"
I have a Dell xps laptop with Windows 7 OS. I noticed a minor problem recently. When I click a hyperlink, it prompts "access is denied". But email- and web-hyperlinks found inside of any webpages work just fine. But those in text (or Pdf, docs) files, they prompt "access is denied". How can...
General Discussion
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing
"Access denied:" How to overcome denied access to a folder
I'd like to put a .cmd file in my c:\Documents and Settings\All Users\Start Menu\Programs\Startup directory, but \Documents and Settings has a lock on it and tells me "Access denied" when I click on it. Is this a job for "Take Ownership" or is there another way? The instructions for "Take...
General Discussion
"Access Denied" for "Documents and Settings"
I have tried logging on as the hidden Admin and I have checked my permissions but I still can't access this folder. I think there are some Firefox files in this folder and I need to see them. Any help? Thanks, Frank
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:08.
Twitter Facebook Google+