Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 will not connect or host LAN Games, Age of Empires 1

29 Oct 2015   #1

Windows 7 Home Premium 64 Bit
Windows 7 will not connect or host LAN Games, Age of Empires 1

I have a Dell Inspiron Laptop running windows 7 Home 64 Bit, I did a clean install of it last year so there is no bloatware or other junk on it.
I had a LAN game set up for Age of Empires 1, with 3 laptops hard wired to a Netgear router. Two of the laptops were running XP, and mine is Win 7 64.
My laptop refuses to connect to any LAN games, and will not be seen by other computers when I host the session. I know it is not the router, both of the XP machines could host and join each others games, and I have used this router in many different LAN games before with no issues. I know It's my computer that is the problem.
I have added the correct exceptions to windows firewall, and even tried turning it off.
My network drivers all work fine.
I have played LAN games for Age of Empires on other Windows 7 machines before with no problems, even connected to XP machines.
We tried switching ethernet cables in case one of them was bad, they all work fine.
It shows "Unidentified Network, No Internet Access" Which is normal.
I tried the Windows Troubleshooter, (That usually does not work) And it recognized Age of Empires and tried to change settings to allow it to work, it still would not work.
I have all computers on the network manually assigned an IP address, Mine, one laptop and another This has always worked before in past LAN games.
I have tried all kinds of fixes online, none of them have worked so far.
I also tried to connect to a windows Vista laptop one time playing AOE 2, same problem there.

I would really appreciate any ides anyone has, this has been bugging me for a long time.

My System SpecsSystem Spec
29 Oct 2015   #2

Windows 7 Home Premium 64 Bit

This is my first post on this site by the way.
My System SpecsSystem Spec

 Windows 7 will not connect or host LAN Games, Age of Empires 1

Thread Tools

Similar help and support threads
Thread Forum
Drives will not connect to USB3 host controller
I just got a new Dell Precision T7810 at work. When I plug in USB3.0 external hard drives to the SS USB 3.0 ports, they connect as USB2, and get the balloon popup "This device can perform faster". I have tried everything - uninstalling and re-installing the latest USB3.0 controller drivers and...
Hardware & Devices
Connect host os to domain that I created on that pc in virtalbox?
I recently created a windows domain using windows server 2008 in virtualbox my host os is windows 7 is it possible to connect windows 7 to the domain * windows 7 and server 2008 are 32bit *windows server vm is located in local administrator account
windows xp mode (as clients) connect to host windosws 7 as server.
Hi All, I have install windows xp mode on my windows 7 64bit laptop. I also install MS SQL Server 2008R2 on windows 7 as server. How do i connect from win xp mode (client) to windows 7(server) as my laptop is running standalone not in networking environment, I also need to map network to share...
Everytime i cant connect i get redirected to a web host
Hi Guys, Im having a problem where when I try and connect to a website that isnt available instead of getting the standard windows error saying a timout error occurred or whatever im not being redirected a hosting provider (who i installed their java applet a few weeks ago). Its happening...
Browsers & Mail
cmd could not connect to the host on port 23
Microsoft Telnet> o < to > not open connection to the host, on port 23: connect failed :( this has also not worked when i have tried to connect to a IP address and i would be happy if any one could help thanks, Dan:)
Network & Sharing
VM with guest XP and Host Win7 not connect to internet
Hi All Need help. Issue is - On my Win7 I have installed Sun Virtual Box and created virtual machines of XP and Ubunto but non of it gets connected to internet rest of the things works fine on it. Please suggest the solution

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App