'Folder in use!' message, I can't delete/move this folder, help!


  1. Posts : 23
    Windows 7 Ultimate x64
       #1

    'Folder in use!' message, I can't delete/move this folder, help!


    'Folder in use! The action can't be completed because the folder or a file in it is open in another program. Close the folder and try again.'


    This is the message I get, I want to delete the folder since I no longer need it. The folder contains ScpControl.dll and.ScpService.exe. I haven't found it in the Task manager processes list. Here is some background info on the folder in case it's useful:



    I followed the following steps to use my PS3 dualshock 3 controller with PC games, It basically makes Windows recognise the DS3 as an xbox 360 controller.

    While connected it flashes one red light slowly to indicate charging. But once I D/C it won't stop flashing all 4 red lights (presumably until the battery dies). I haven't used it wirelessly yet, only via the USB cable that came with the DS3. Holding the PS button for 10 secs worked as a temporary solution to stop the controller flashing.


    Steam Community :: Group :: Steam Universe...


    1: Download the official drivers for the Xbox 360 controller from Microsoft's site. I use the 64 bit version, but you should choose the appropriate Windows version here: DOWNLOAD[www.microsoft.com]

    2: Install the Xbox 360 controller drivers.

    3: Plug in your PS3 controller with USB. Also plug in your bluetooth dongle if you want to use that (and install the drivers if you haven't already).

    4: Download the XInput Wrapper drivers from here: DOWNLOAD[forums.pcsx2.net]

    5: Unpack the file and run the ScpDriver.exe file from the ScpServer\bin folder.
    IMPORT

    Windows XP or Vista users - check the Force Install option.
    Windows 7 or 8 users - leave it unchecked.

    8: Click the install button.

    7: YOU ARE DONE! Your PS3 controller will now work, using the official 360 controller drivers (it just tricks the computer into thinking it's a 360 controller).

    8: Run whatever game that supports the 360 controller. The PS3 controller will automatically pair with your bluetooth hardware if it's connected to USB while the program is running.

    Thanks to user Scarlet.Crush over at the PCSX2 forums for this wonderful fix!



    Hope somebody can help out, thanks!
      My Computer


  2. Posts : 53,395
    Windows 10 Home x64
       #2

    Welcome to Seven Forums supashaka. You might download Lock Hunter and it will show you what is locking the file. Right click and choose What is locking this file? It will also let you try to unlock, and delete the files. You may have to restart if it cannot delete the file while windows is running. A Guy
      My Computer


  3. Posts : 6,285
    Windows 10 Pro X64
       #3

    You could also try booting to Safe Mode and deleting it from there. That often works.
      My Computer


  4. Posts : 23
    Windows 7 Ultimate x64
    Thread Starter
       #4

    I used lockhunter and it deleted the folder after restart which is something, but not the ScpControl.dll (says it can't be deleted) so I'm wondering what that file is doing? Possibly something malicious?

    I'll try the safe mode delete next, thanks guys :)

    1 problem though, I can't locate the file anymore! File locker message which informed me it couldn't be deleted still pointed to my download folder, but I definitely don't see it there anymore. When I search for it in the start menu it can't locate it.

    Is it deleted or something? I checked through the whole recycle bin and did a search there too, couldn't find it. Any ideas?
      My Computer


  5. Posts : 53,395
    Windows 10 Home x64
       #5

    Download Everything (portable if don't want to install), search for ScpControl.dll. If it is still on your system, Everything should find it

    A Guy
      My Computer


  6. Posts : 23
    Windows 7 Ultimate x64
    Thread Starter
       #6

    New problem, When I tried to connect my DS3 it no longer recognises it as an xbox 360 controller, but as PS3 controller!!

    I didn't think those files were needed afterwards, but clearly they were! Even if deleting them stopped it from working I thought I could just re-do the whole process, but unfortunately even after running through all the above steps it won't work anymore. Any ideas?
      My Computer


  7. Posts : 3,724
    Windows 10x64 Build 1709
       #7

    Do you have a system restore point from before you started mucking about? Or a disc image maybe?
      My Computer


  8. Posts : 23
    Windows 7 Ultimate x64
    Thread Starter
       #8

    I don't know about a restore point but I guess I can do a clean install, for now I have used the method on the SCP site. It's kind of annoying since today my DS3 was just charging instead of behaving like a 360 pad like it was before, and I had to reinstall the drivers, at least it works but is it supposed to reset each time I shut down?

    Thanks guys :)
      My Computer


  9. Posts : 53,395
    Windows 10 Home x64
       #9

    Wow, didn't know what it was all about, so didn't think you may need the files still. Sorry I can't help with that part. A Guy
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:21.
Find Us