Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I/O operation initiated by the Registry failed unrecoverably

09 Mar 2016   #1

Win 7 Professional 32-bit
I/O operation initiated by the Registry failed unrecoverably

This morning my laptop has started to suddenly power off after running for just a few minutes. After restarting, the problem persists. The event log indicates the following critical error:
An I/O operation initiated by the Registry failed unrecoverably.The Registry could not flush hive (file): ''.
I have tried the following trouble-shooting steps thus far:
- chkdsk which found no errors.
- CCleaner to check for registry errors
- Malware check via Malwarebytes in Safe-mode
- Virus scan via Microsoft Security Essentials

Is anyone familiar with this error and could let me know what my next troubleshooting steps should be? Thanks.

System: Windows 7 x64
Hardware: HP g6-1d60US
2.5GHz/1.9GHz VISION A4 Technology from AMD with AMD Dual-Core A4-3305M Accelerated Processor
AMD Radeon HD 6480G Discrete-Class Graphics

My System SpecsSystem Spec
10 Mar 2016   #2

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

Have you tried a system restore to a restore point before the problem occurred?
My System SpecsSystem Spec
11 Mar 2016   #3

Win 7 Professional 32-bit

Thanks for your reply. I opted to do a reformat and clean install. After the reformat the problem persisted so I ran a memory check. The check was interrupted by an unscheduled power down. Upon reboot I got an overheating issue. I installed CoreTemp and the CPU temp was in excess of 90 degrees C. So, I think the problem is likely a broken fan. I've ordered another one, will replace thermal paste during install and will post back if those steps don't eliminate the problem.
My System SpecsSystem Spec


 I/O operation initiated by the Registry failed unrecoverably

Thread Tools

Similar help and support threads
Thread Forum
After ComboFix: Illegal Operation, Registry Key Marked for Deletion
Ok, so I'm working on a computer who's owner ran a program called ComboFix. Now, whenever you try to launch a program (say, Chrome, word, etc.) we're getting a popup that says something like "Illegal Operation Attempted on registry key marked for deletion." I was thinking I'd have him restart...
General Discussion
Newbie.....operation failed with 0x8007047f.... i cant install wmp!!!
Hi guys....newbie here. I recently had to format my pc and install a new copy of windows 7 as i had constant crashing of my pc. I brought a new copy of windows 7 and apparantly its a "n" version. I'm trying to install wmp 12 and ive downloaded the media pack update thing from the windows...
Installation & Setup
reagentc /enable : operation failed : 3
reagentc /enable : operation failed : 3 There is not "recovery" menu at F8 menus. So I found the reason. When I am installing windows 7, I have stopped oobe. According to some documents, I open cmd and entered commend. C:\Users\Administrator>reagentc.exe /enable REAGENTC.EXE: operation...
General Discussion
Registry Initiated Startup Programs
It is important that you are aware of which programs that run on startup, and which are initiated by the Run keys in the registry. These may be found in the following locations (note that I have removed the identification from the 2nd image): ...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:52.
Twitter Facebook Google+