Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installer Registry Key Missing

29 Mar 2016   #1

Windows 7 Pro SP1 x64
Installer Registry Key Missing


I had at one time installed Bluestacks Android Emulator on my Windows 7 Pro SP1 machine and it worked fine. I uninstalled it and went about other business. Now, I want to reinstall it so that I can play Clash of Kings with multiple accts. on my pc.

The problem is that it will not install now, as there's something amiss within the Registry. All is well with the computer and the file system is intact. I simply need to use multiple Google accts. to play the game effectively, and to use multiple accts. on Facebook is a violation of Terms.

Please advise on this issue, and note the attached failure window for more info.

Thanks for any and all help on this matter.



Attached Images
Installer Registry Key Missing-bs.jpg 
My System SpecsSystem Spec

 Installer Registry Key Missing

Thread Tools

Similar help and support threads
Thread Forum
My Windows Installer Service is missing. How do I get it back?
My Windows Installer Service is missing. How do I get it back? I'm unable to install any programs or open my Outlook due to the missing install service. Can anyone help me on fixing this issue?:confused:
General Discussion
An entry in registry missing
I want gain an access to com ports and require changed in registry entry of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PNP0501 but it seems the folder is not there. I have tried regcleaner and reg fix did not help. thanks
Missing privileges for registry key
I'm trying to use the program "Dragon Tag", where the program will start MS-Excel, and here put an add-in into the menu. However, I get the below error, where I seemingly do not have the needed privileges. Tried to remedy this without succes, but then I tried to run the program being logged in as...
missing C:\Windows\Installer folder
I first noticed it when icons for my MS office 2007 documents became the generic ones. I tried to change the icon using the software Types, where it shows that the icon files are directed to the Windows\Installer folder, WHICH IS MISSING from my computer. I can't even reinstall MS Office as the...
Gadget Installer is Missing
When I download a gadget.. Windows doesn't install it for me. It tells me that it can't open the file. I can choose a program to open it with. But what program do I choose? I already went to Start > Run > optionalfeatures.exe, and made sure "Windows Gadget Platform" is checked and installed. ...
Missing a registry place
Hallo! I was trying to hide a local disc (Q:), a virtual disc that Office 2010 has created. I found the answer, but it told me to go to: HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer I went to policies, but there where no "explorer" I tried to google, but I only found more...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App