Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: After 3 years, a sudden "Reboot and Select proper Boot device"

17 Apr 2016   #1

Windows 7 Pro 64 bit
After 3 years, a sudden "Reboot and Select proper Boot device"

Edit: solution found (KB3133977 update clobbers ASUS motherboards using Secure Boot)

Hi folks, tearing my hair out over this one. Win7 Pro PC was operating fine earlier in the day, no hardware changes in almost a year. Power it up later in the day and I get Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key.
  • There is a single DVD drive and only the Samsung SSD drive, neither has changed
  • Both DVD and SSD show up in my BIOS. No matter how I arrange the SSD, I get the Reboot and Select proper Boot Device
  • I can boot from my Win 7 Pro (64) install DVD. Since I know the DVD cables work, I swapped both the DVD's power and SATA cable to the SSD, no joy, so cables and SATA port seem fine.
  • Doing Repair from my Install disk fails; I get "This version of System Recovery Options is not compatible with the version of Windows you are trying to repair. Try using a recovery disc that is compatible with this version of Windows." I moved a year ago, and my repair disk is missing.
  • From cmd window via Install disk:
    • I can access C: and see my files just fine
    • Using bootrec:
      • /scanos does detect c:\windows
      • /fixmbr /fixboot /rebuildbcd will detect Windows and succeed across the board but still not correct the problem (see below)
    • Using diskpart:
      • I can see that my disk is GPT. GPT is new to me, I'm more familiar with MBR recovery. Does bootrec handle GPT too or is it just a relic now?
      • 'detail disk' shows the Samsung, but with Boot Disk : No. That seems wrong?
      • volume 1 c: shows up ok, 465GB, 202GB free
      • I can't 'active' the partition, I get 'selected disk is not a fixed MBR disk". Makes sense if it is GPT, but I don't know what to do with GPT to mark a partition bootable
    • Using chkdsk c:, no errors found
PC has been working fine leading up to this. I custom built it three years ago. Only thing of maybe interest is that a month or so ago I had tried to upgrade to Win 10, and had to abort due to an error (I can't recall specifics but it was some sort of a driver issue I didn't have time to sort out). The Windows install returned me to Win 7 without apparent problem. I'm not sure if this explains the 'Repair' error.

I've searched for help but I seem to be stuck:
  • Fix the GPT - A technique I'm not familiar with, this is the first time I've dealt with a GPT and most of what I find on the net is MBR recovery advice
  • "Repair 3 times" technique - But I can't repair, due to the Install disk's error above. How can I get around it?
I'd like to recover the data on the drive if possible. Thanks!

Edit: solution found (KB3133977 update clobbers ASUS motherboards using Secure Boot)

My System SpecsSystem Spec
18 Apr 2016   #2

Windows 7 Pro

It's possible that your computer's BIOS is configured in legacy mode. You might need to enter into the BIOS Setup and enable UEFI boot support:
How to Set Windows 8 PC to Boot with Legacy BIOS Mode Instead of UEFI Mode | Password Recovery

UEFI mode requires the boot drive partitioned with GPT, while legacy or CSM mode can boot from MBR-partitioned hard drive only.
My System SpecsSystem Spec
19 Apr 2016   #3

Windows 7 Ultimate x64 SP1 OEM

Maat, welcome to SF.

Go here and look at post 2

Repair Windows 7 boot menu on UEFI
My System SpecsSystem Spec

19 Apr 2016   #4

Windows 7 Pro 64 bit

Thanks for the replies guys, much appreciated.

markoso: I will check when I get home, but I believe UEFI is enabled. Mobo is an Asus Sabertooth Z77 with the UEFI BIOS. In the BIOS there is a quick option for re-arranging the boot order, and there are four options. My DVD and my SSD are listed twice, once with a UEFI label and once without. All SSD arrangements result in the Reboot and Select proper device error (can boot from DVD just fine). I'll check under the Boot Menu though and see if the Boot flags are correct there at least, but IIRC they were set to 'Both'.

MeOnMine: thanks for the link. Re: 2nd post: I do not recall Windows Boot Manager being listed in my BIOS (see above). However, when booting to the Windows Install DVD its possible I had the non-UEFI legacy version selected or earlier in the priority sequence - perhaps that results in the This version of System Recovery Options is not compatible error when I try to Repair. I'll try again with UEFI-DVD selected.
My System SpecsSystem Spec
19 Apr 2016   #5

Windows 7 Ultimate x64 SP1 OEM

Yes, you said your HDD was formatted GPT this is because your OS is loaded in UEFI so that means you will not have MBR.
You must select UEFI version in all cases.
GPT has two system partitions per drive, one in the beginning and one at the end.
This is what tells BIOS where the OS is.
I am a systems builder however I still build in Legacy and not EFI so that means there are better experts here than me who can put you on a better path.
My System SpecsSystem Spec
19 Apr 2016   #6

Windows 7 Professional x64

I'm having the same exact problem with my Windows 7 Pro and Samsung SSD. It's crazy. It happened overnight. If i find a fix i'll let you know.
My System SpecsSystem Spec
19 Apr 2016   #7

Windows 7 Pro 64 bit

Thanks Nick, likewise I'll share anything I find.

'UEFI and Legacy Mode' is selected in my BIOS. My memory served me incorrectly: the Samsung is listed as Windows Boot Manager in my BIOS. However I've already tried several times moving it to #1 in the boot order with no luck; I have also tried booting directly to it via selection in BIOS, no luck.

No luck: Downloading the Windows 7 Pro 64 bit ISO, burning a disk, and attempting to Repair. Same Repair error.

Luck: Forcing the boot mode to UEFI-only in BIOS and booting from my Win7 Install disk however got me into Repair recovery tool menu without the error. However, selecting Startup Repair detects no problems at all! It shows Windows 7 on (C: ) Samsung SSD, Startup Repair log shows 'Boot status indicates the OS booted successfully'.

So I've learned:
  • The 'This version of System Recovery Options is not compatible...' error is based on needing to boot the Win 7 Install Disk in UEFI mode, to match my hard drive
  • my ASUS BIOS appears to be flaky at booting into UEFI. Using the Basic menu to order the drive icons to place the UEFI drives first did not work. I had to go into Advanced options, select UEFI Only under Boot->CMS, and then finally boot from the install DVD to get past the version error in Recovery Options
Sadly, I still am not sure what to do to fix the actual boot issue. Even with UEFI-Only set in BIOS, the disk does not boot - oddly, instead of the Reboot and Select proper device, it now boots directly into BIOS menu.

I have a Hirens boot CD burnt and it has a lovely variety of sharp looking knives on it; so I'm going to be doing some research on which of these might be able to help with a UEFI boot issue.

Any UEFI boot debug advice welcome!
My System SpecsSystem Spec
21 Apr 2016   #8

Windows 7 Professional x64

I got tired of googling and I couldn't find any fix myself so I broke down and bought Easy Recovery Essentials and successfully ran the autorepair. When my computer restarted I was still getting an error and was pretty bummed that I had wasted 39 bucks. But, once I popped my windows disk back in and booted to that, Chkdsk ran and my drive worked again! I was able to boot. Now I'm trying to make a backup and system image! I can't guarantee that this will work for you but it seems like we had a very similar issue (like I said, I also have an ASUS Mobo and Samsung SSD with Win7).

Anyway, best of luck, hope you find a fix soon!
My System SpecsSystem Spec
21 Apr 2016   #9

Windows 7 Pro 64 bit

Cheers Nick. When I ran chkdsk I confess I ran it without /f and simply scanned the output for errors. I will try again with /f just to be sure when I get home tonight. When you said "When my computer restarted I was still getting an error", do you mean the Reboot and Select proper Device... error? How did you get chkdsk to run from the Win Install disk, via shift-F10 to get a command window, then manually?

Googling for a solution has been rather depressing; virtually all the guides out there for UEFI are for installing or reformatting, and not really a word on recovery. The drive appears to be just fine outside of the failure to boot so I'm really reluctant to just reformat and reinstall. The Hirens Boot CD appeared to be no help for UEFI.
My System SpecsSystem Spec
21 Apr 2016   #10

Windows 7 Professional x64

I was getting another new error, instead of the "reboot and insert" error it was a "system32\winload.efi 0xC0000428" error. This was after I booted the Easy Recovery Essentials and ran the repair. I didn't know where to go from there, I was bummed, then I booted to the Windows 7 disc I had made just to try to use it's repair function again and rather than booting to the disc, my screen started running chkdsk on my C drive and then suddenly there I was at my usual login screen. Somehow, the computer had restored to the last point before the error occured. I'm still not quite sure how this happened and I'm not 100 percent sure I'm out of the woods. That's why I'm making a backup and restore point now.

I've gotta restart after my backup finishes and i'm so nervous it's going to stop working again!
My System SpecsSystem Spec

 After 3 years, a sudden "Reboot and Select proper Boot device"

Thread Tools

Similar help and support threads
Thread Forum
"Reboot and Select proper Boot device" with only 1 data drive
Hello, So a while ago my computer crashed and I wasn't sure what it was so I tried many things because I wasn't getting any BIOS beeps so I thought it was the motherboard but long story short it's the graphics card, so I've replaced that with my old one for now. But since I took out so many...
Installation & Setup
SSD - "Reboot and Select Proper Boot Device" message
Hello All, I booted my machine to find it present me with two things I never encounter. 1) It booted into ASUS Express Gate (EG), which I believe I disabled when I first built the machine several years ago. 2) Upon exiting EG, it displays the main splash screen for my mobo. It then displays...
Hardware & Devices
Getting "reboot and select proper boot device" error on startup
Hello, Ive recently been getting this message and I cant seem to solve it. I read a few topics and solutions, but I can't seem to grasp it. I am rather greatly unfamiliar with pc tech know how. I tried putting the OS disk and restart, but I get the same error, and I dont know how to reinstall...
Installation & Setup
When left alone..."Reboot and select proper boot device or Insert..."
When left alone..."Reboot and select proper boot device or Insert boot media in selected boot device and press a key" I have a new(ish) cpu that I bought last Christmas, it works great and it has not crashed on me whenever I am using it. However, when I leave it on overnight (usually when it is...
BSOD Help and Support
Booting Issue: "Reboot and Select proper Boot device"
I haven't been on my computer for a week, I was away from home and once I turned it on i get some message saying, Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key. This happens every time I turn on the PC. I don't get to the Windows login screen...
BSOD Help and Support
Booting from DVD issue, "Reboot and select proper boot device".
Hi! I just burned a copy of the Windows 8 Developer Preview onto a DVD. I have created a partition for the new OS (because I don't want to install over Windows 7). When Windows 7 is running and I pop in the DVD, the computer directly recognizes it as a runnable program. I'm also able to install...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App