Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Logged in as Administrator but still need to run as administrator

13 May 2016   #1

Windows 7 Professional 64-bit
Logged in as Administrator but still need to run as administrator

Despite being logged in as the administrator I still sometimes need to right-click and select 'run as administrator' to get programs & games to run otherwise they just literally do nothing, no error message, just nothing.

I think the reason I can't get a steam game running is this problem. But since I am already logged in as administrator I can't think of anything to do about this problem.
My System SpecsSystem Spec
13 May 2016   #2

Windows 7 Professional 64-bit

I think somewhere in any particular program EXE's properties is a place you can check the box for Run this program as an administrator. Now, whether this works, I'm still not sure, some of my EXEs do ok, some - not so much.

(OPTION SIX) Run as Administrator
My System SpecsSystem Spec
13 May 2016   #3

Windows 10 Pro x64, Windows 8.1 Pro x64, Windows 7 Ultimate x64 SP1,

Hi and welcome.

What you are experiencing is normal.
Windows 7 prevents malicious programs from running inside an administrator account by requiring the user to specify running some programs at an elevated level.
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
APPCRASH when logged in as Administrator
I have an employee time clock application installed on my Windows 7 machine. It is a simple program with a MS ACCESS database. It was working fine for a couple of months, and then, for no apparent reason, it started APPCRASHing. The program will not open. When It APPCRASHes it'll crash different...
General Discussion
Permission denied While logged on as administrator.
I am logged on as admin, and i want to defrag my HDD. but it says i don't have sufficient privileges! I'm admin God-damnit! Please help :)
General Discussion
Access denied Even though logged into Administrator account
Hello Guys, Done a factory resetting,want to delete unwanted files,but couldn't. Most of the thread here having the same problem are quite old and asked to start a new one. I have tried sliding the bar lower on UAC,Tried to take the ownership of the particular folder but couldn't. ...
General Discussion
BSOD when logged on as Administrator, STOP: 0x0000001E
Really need your help. My HP laptop keep crashing and we get the blue screen whenever we log on in Administrator accounts. When I log on as Guest it doesn't crash. The BSOD starting happening after one of my friends used my browser. I've attached the SevenForums zip file Thank You!
BSOD Help and Support
Unable to defrag from CMD despite being logged in as Administrator
Hello I have a Thinkpad T60 running windows 7 untimate (trial version) when logged in as an Administrator and when I try to defrag the hard disk from the command prompt using the command: c:\>defrag c: /a I get the following error: "The disk defragmenter cannot start because you...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:12.
Twitter Facebook