Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Certain files refuse to open in one folder. Permission problem?

25 May 2016   #1

Windows 7 Professional 64
Certain files refuse to open in one folder. Permission problem?

In one folder that contains photos, many of them refuse to open. The message "Photo gallery cannot open this photo because you do not have permission to access the file location" is displayed.

Its not a file type issue because many of the png. and jpg. will open while others won't.

I've tried to concentrate on just one photo which happens to be a copy of another photo which does open. I've gone through the Properties>Security>Advanced>Owner technique to find CURRENT OWNER is "unable to display current owner". When I click EDIT, I see a random group of numbers. When I try this procedure on a photo which will open, I get the same random group.

One more thing when comparing a working photo and a non working photo. When I open a working photo's PROPERTIES then go to SECURITY, there is a group of user names or numbers. When I open a non-operating photo's PROPERTIES, then go to SECURITY, I am given the message "To continue, you must be an administrative user with permission to view this object's security properties".

What could be causing this problem. I hate to lose these files.

My System SpecsSystem Spec
25 May 2016   #2

Windows 7 Ultimate x64

Seems pretty much like you don't have permission to some of those files, and also you aren't the owner of none of them. Those "random numbers" is just the SID of an unknown user, likely from another computer.

Just select them all, go to the current owner and make your own user the new owner. Close all dialogs and open them again, and in the permission tab add your own user and give yourself full control. That should restore access to everything.

This sort of things is common when you take disks from one computer and put in another, or when sharing a disk after a clean install, for example.
My System SpecsSystem Spec
25 May 2016   #3

Windows 7 Ultimate, SP1, x86

Since the first day I installed and ran Windows XP, many years ago now, I've been cursing that "you don't have permission" BS.

Finally after all those years of cursing and hair pulling, some kind soul wrote "Grant Admin Full Control", so you can click on any file or folder in your computer, and 'Take Ownership' of it. That makes life with Windows a whole lot easier and less stressful.

Grant Admin Full Control and "Take Ownership" have been around long enough now, I'm really surprised that everyone doesn't know about it. Google it, download it, install it, and then you can Right Click on any file to become its Owner.
Simple! Problem solved!

Cheers Mate!
My System SpecsSystem Spec

26 May 2016   #4

Windows 7 Professional 64

Thanks for the advice guys but I found a solution to the problem.

I copied all the picture files that refused to open into a new folder on my desktop. Then I tried to open one. IT OPENED. I tried most of them. THOSE OPENED TOO! Next, I deleted all the non-operating picture files and replaced them with the desktop folder copies. Everything is working great. A permission window popped up while I doing some of this but I clicked the right button and was able to carry on.

My System SpecsSystem Spec

 Certain files refuse to open in one folder. Permission problem?

Thread Tools

Similar help and support threads
Thread Forum
No permission to open a folder
Hi, my PC monitor died so I removed the PC's 2nd internal drive and installed it as an external USB drive to access its files from my laptop. I can access certain folders, but some folders I'm unable to open them, a message pops displaying lack of permission. How can I fix this? Thanks.
General Discussion
Cannot open Network Files, permission error
Hi everybody, Currently, I am trying to open a picture in a network drive using windows photo viewer, I get Windows Photo Viewer can't open this picture because you don't have the correct permissions to access the file location. I tried opening, word, xls any file from the network directory, and...
Network & Sharing
Cant open downloaded files (windows message no permission)
Ive been trying for about an hour now to disable the stopid message saying are you sure you want to open this file? i got to a site wich got me to internet settings of windows. made custom profile for zone and disabled the warning if i want to open those files. Applied settings, tried to open a...
General Discussion
Sea gate 2tb will not let me open any files permission problems
This is my tb that I plugged into a friends work computer I shared some files with him after he left the job I received his computer I plug in my tb and it says I'm locked out that his login is the only person who has permission to access it but his login is gone so I can't login with his account...
Folder Permission problem
I know there were many question like this before And, i almost have tried everything but still it's not solved it I have tried the way from SECURITY tab folder It helped in most folders but not everything and sometimes it got messier where i can do anything cept read Even though i'm the...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:44.
Twitter Facebook Google+