Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Startup Repair Loop (Boot manager failed to find OS Loader)

14 Oct 2016   #1

Windows 7 Professional SP1 x64
Windows 7 Startup Repair Loop (Boot manager failed to find OS Loader)

Hey guys.. I am very anxious and frustrated about this issue. I have searched frantically all on multiple forums but the solutions are all over and I just can't..
I have seen some really knowledgeable users here while looking at threads to solve my problem so this is my best bet.. I really do not want to lose all my data :/

I am willing to follow any instructions provided as I am very desperate.

Background Information

My laptop automatically boots into Startup Repair, and once it finishes "repairing", the laptop restarts and boots into Startup Repair once again, looping the whole process. The diagnostic and repair details from Startup Repair showed that the "root cause found" was that the "Boot manager failed to find OS Loader", and the repair action for "File repair" and "Boot configuration data store repair failed".

This is the second time this issue has happened, where I tried to boot up my laptop after hibernating it. Prior to encountering this issue again, reboot, sleep, and shutting down my computer worked fine. Also, I think before the two times the issue happened, I was installing some Windows Updates. I am trying to avoid restoring the disk back to factory state.

What I have tried
  • Letting Startup Repair finish. Just simply loops back.
  • Running chkdsk /f on my C: drive. No errors and fixes.
  • Pressing F8 to access Advanced Boot Options does not work. Goes to Startup Repair.
  • System restore to the point before the Windows Update occurred. Did not work.
  • Windows Memory Diagnostic tool, Memtest86, Memtest86+ showed no errors.
  • Run this in CMD. This is where it gets weird.
    bcdedit /export C:\BCD_Backup
    cd boot
    attrib bcd -s -h -r
    ren c:\boot\bcd bcd.old
    bootrec /RebuildBcd
    bootrec /fixmbr
    bootrec /fixboot
    I'm not sure what happened, but after rebooting, I encountered an error by Windows Boot Manager in which Windows cannot verify the digital signature for this file for \Windows\System32\winload.exe. Pressing Enter brings me onto this screen, where either pressing Enter once again or pressing F8 brings me back to the screen before with the error message. Restarting the computer or anything now always brings me to the screen with the error message by Windows Boot Manager.

    To resolve this, I tried following a bunch of instructions from this thread, and making C: (where Windows is) drive the active partition instead of D: (labelled System) solved this and returned me to the Startup Repair Loop issue.
    Additionally though, now if I try to boot from a USB, it says Bootmgr is missing, which is bad. I could boot to Kali Linux via USB before I attempted a bunch of solutions, where I could mount the Windows partition in read-only mode in Kali Linux.

Current situation

So far, I have deleted the bcd and bootmgr files and ran Startup Repair 3 times with reboots in between to restore them for a number of times. I'm not sure which of my actions contributed to what problems (such as the Bootmgr is missing problem appearing later) and I am confused and frustrated. Thus, I await your professional help. I'll return in about 12 hours because of sleep.

My System SpecsSystem Spec
14 Oct 2016   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

What you didnt say is
I loaded the dvd prior to running the commands, did you??

My System SpecsSystem Spec
14 Oct 2016   #3

Windows 7 Professional SP1 x64

Yea, though before the winload.exe error I could quickly cancel Startup Repair and get an option to run CMD (Hence the commands I ran before encountering the winload.exe error were not through the DVD).
While trying to get rid of the winload.exe error I probably ran a lot of other commands which resulted in not being able to boot from USB now (Bootmgr is missing).

Main issue is the Startup Repair loop for now, I guess.
My System SpecsSystem Spec

30 Oct 2016   #4

Windows 7 Professional SP1 x64

Bumping (not sure if this is allowed), really no help from you guys :/?

Or how about ways to salvage data?
My System SpecsSystem Spec
30 Oct 2016   #5

Windows 7 HP 64

Did you updated your BIOS recently? Did you checked the BIOS settings?
What OS you have on the USB, Win 7 installation disk or Kali Linux?
Do you have any kind of encryption on the disk?
You said that you can't boot Kali Linux? You should always boot another OS on another disk, UNLESS:
- Your BIOS is set to boot UEFI mode and the disk is Legacy - MBR (or vice-versa)
-Your USB disk is corrupted. In this case, on another computer, format and rebuild the the bootable disk.

I've seen that your laptop can have different configurations.
Please edit you profile and add all hardware information you have.
Is your disk a M.2 SSD?
My System SpecsSystem Spec
30 Oct 2016   #6

Windows 7 Professional SP1 x64

Thank you so much for your reply!

- I have not updated my BIOS recently. I have access to the BIOS settings yes, nothing abnormal there.
- I have a bootable Kali Linux on USB, and a Windows Recovery Disc. The computer itself has Windows 7 Professional.
- There is no encryption on the disk to my knowledge.
- Prior to everything, I could boot anything from USB (as long as it's installed properly onto the USB) just fine. There wasn't a problem with the BIOS settings being set to the wrong mode/or the usb disk being corrupted.

Only when I made C: drive the active partition (as mentioned in my first post) as an attempt to solve my original issue, after the process, I somehow ended up with "Bootmgr is missing" message if I tried to boot by USB (I do this by going to Boot Options, and select the USB). The Windows 7 Recovery Disc still runs fine.

My disk is a 1TB HDD, there is no SSD at all. Also, I think the main issue is still the laptop not being able to boot up due to the errors encountered rather than not being able to boot from USB.
My System SpecsSystem Spec
30 Oct 2016   #7

Windows 7 HP 64

Did you launch HP update? It could update the BIOS.
Did you did any kind of partition change to the disk?
Your BIOS type is UEFI not Legacy. The commands you gave are for Legacy.
I've looked at he manual
To boot to a divice: (pag86)
To dynamically choose the boot device, by pressing esc while the “Press the ESC key for Startup Menu” message is displayed at the bottom of the screen, and then pressing f9 to enter the Boot Device Options menu.
Did you try to boot the Kali Linux on USB on UEFI mode?

Look this link Drivers & Software - HP Support Center.
My System SpecsSystem Spec
30 Oct 2016   #8

Windows 7 HP 64

My System SpecsSystem Spec
30 Oct 2016   #9

Windows 7 Professional SP1 x64

Hmm ok... how does it help?

Any idea on what options I should use or any instructions that I can follow? I do not want to mess up further :/
My System SpecsSystem Spec
30 Oct 2016   #10

Windows 7 HP 64

Make a bootable CD or USB flash drive of partition Wizard. Use Rufus
When you get a image of your disk, take a photo and post as an attachment (Go advanced - Mange Attachments - Browse - Upload)
My System SpecsSystem Spec

 Windows 7 Startup Repair Loop (Boot manager failed to find OS Loader)

Thread Tools

Similar help and support threads
Thread Forum
Boot manager failed to find Os Loader. win 7
Hallo all, yesterday im update my laptop with 3/4 latest optional update after restart, my laptop open startup repair and always open everytime i open it. and always with same result. Startup Repair Windows cannot repair this computer automatically with same error, below the detail:
Performance & Maintenance
Startup Repair Infinite Loop, Cannot Find Hard Disk, Registry Corrupt?
So I tried using the Startup Repair Infinite Loop Recovery ( and It did not work for me. I tried the Startup Repair and It said "Hard Disk could not be found" On another instance, It said "Registry is...
Backup and Restore
Windows 7 is in a boot loop and I can't launch startup repair
Hello, I have an Acer Aspire V3-551 and recently, it can't boot, I tried a backup & restore using Acer's eRecovery management software. It was able to backup my files but hasn't made it past restoring, now I can't even go in start up repair and it keeps rebooting on windows 7 installation no...
General Discussion
Failed to Find OS Load. Startup Repair FAILED
I am currently using windows 7 ultimate x64. I was in the middle of a process restoring my computer to a few days back and suddenly it froze. i did a power shut down and when i turned it back on, i wasn't able to get back into windows. i was brought to startup repair and it gave me errors. 'Boot...
General Discussion
Windows 7 update failed and laptop won't boot. Startup repair failed
I installed the latest round of Windows updates for my Win7 x64 install and it never completed (ran for about 24 hours) so I powered off the machine. Upon restarting, it said: "Windows failed to start. A recent hardware or software change might be the cause" and has instructions for using system...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:36.
Twitter Facebook