Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wrong copy speed and time in Windows 7 x64

28 Dec 2016   #1
Sirios

Windows 7 x64 Home Premium
 
 
Wrong copy speed and time in Windows 7 x64

Hello!

I am having a strange issue with speed and time calculation during coping large files from my laptop's SSD (Samsung PRO 840 with speed drive function enabled) to USB 2.0 external drive. Whenever I use explorer (not a browser) functions or TotalCommander, when I copy files large than 1Gb, the speed goes way up to 1 500 mb\s (sic!) or 500 mb\s, then the progress bar stutters on 15% or 20% while led on the external drive keeps blinking. After some time progress bar goes further but speed goes to 40-50 mb\s and stays like that until copy is finished.

It was not like that before.

What I was tried to do:

1. I have tried to turn off all not-windows related services;
2. I have tried to turn off antivirus (malawarebytes) and speed-drive function of the SSD on top of that with no luck;
3. I have tried other USB2.0 ports;
4. I have checked my CPU and Memory and HDD- no errors whatsoever;

P.S. My external drive and cable are USB3.0, but I am using USB2.0 port, be cause there is only one USB3.0 port on my laptop and it used by another external drive.

You can see what happens on the video in the attach.

I would be glad to get any advice on that issue. Thank you very much.




Attached Files
File Type: zip Screencast 2016-12-29.zip (409.5 KB, 3 views)
My System SpecsSystem Spec
.
29 Dec 2016   #2
Sirios

Windows 7 x64 Home Premium
 
 

I have just checked, it also happens if external drive connected through USB3.0 too.
My System SpecsSystem Spec
29 Dec 2016   #3
Eric3742

Windows 7 x64
 
 

Welcome to sevenforum Sirios

Please do fill your system specs.

Also do show the Device Management of your system.

Have you try to put a checkmark on the box, on Copy NTFS if there is any difference.
My System SpecsSystem Spec
.

29 Dec 2016   #4
Megahertz07

Windows 7 HP 64
 
 

The bottle neck isn't the USB connection, the bottle neck is the HDD.
Samsung PRO 840 read speeds are high but HDD write speeds are low.
When you begin the transfer it's high speed because you are transferring to HDD buffer, not to the disk.
USB 2.0 has a transfer speed of 480 Mb/s or 60 MB/s
USB 3.0 has a transfer speed of 5 Gb/s or ~ 600 MB/s

If you having 40-50 Mb\s transfer rate that is normal to a HDD.
My System SpecsSystem Spec
29 Dec 2016   #5
Eric3742

Windows 7 x64
 
 

Hi

You are doing the wrong way by copying to another HDD, which i would say, it would not work.

Do note that these files are located in Lenovo recovery folder.

So to say that all these files are for Recovery and you cannot recover without that Lenovo recovery program.

Do note that once you made a copy, that is run the program and make it as Recovery disc.

These files would be deleted as this is how Recovery work.

Also, the Lenovo utilities on making 1 set of Recovery discs work for 1 time.

After making a set of Recovery discs, you can make additional copies by copying the Recovery discs.



Check the link for more info regarding this extension .swm

SWM File - What is it and how do I open it?


By copying to another HDD, beside the buffer cannot meet the speed of the SSD, so it look like hang.

But actually, these files are compact and to make the matter worse, is that SSD is much faster (8x) then HDD, even the cache &or buffer have filled to the maximum.



Eric.
My System SpecsSystem Spec
29 Dec 2016   #6
lehnerus2000

W7 Ultimate SP1, LM18.2 MATE, W10 Home, #All 64 bit
 
 
Guesswork

Windows has always just "guessed" what file transfer speeds are.

If you watch large file operations, the time remaining, data remaining and transfer speed don't make any sense (e.g. 5 seconds, 20 MB remaining, 60MB/s).
My System SpecsSystem Spec
Reply

 Wrong copy speed and time in Windows 7 x64




Thread Tools




Similar help and support threads
Thread Forum
Time on Windows is always wrong after using a different Os.
Everytime I am done using Linux and reboot into Windows the time is always a few hours off. Why?
General Discussion
Wrong time on clock after windows re-install
Following windows updates on Wed my pc wouldn't start any more and I had to factory rset it and lose 14 years od data unless my cloud storage system will work which it wont at the moment. One problem I have is my windows clock is showing 10 hours ahead and tomorrows date despite being in the...
General Discussion
Right Place, Wrong Time: 9 Technologies Born Before Their Time
Read more at: Maximum PC | Right Place, Wrong Time: 9 Technologies Born Before Their Time
Chillout Room
Windows 7 reports wrong cpu speed?
Iíve been running my CPU (Q9400) overclocked at 3.2 Ghz since I put windows 7 in, I have just changed my RAM and can now get my CPU to 3.3Ghz, only a little more I know but Windows reports the CPU at 3.2 Ghz still, CPUz is reporting 3.3Ghz, same as bios. No big deal but does anyone know why it...
Hardware & Devices
Windows 7 slow copy speed
Hi! I have several computers connected to a file server using direct 4Gbit fibre (facilis 24tb Terrablock - 24 1TB drives in raid 5) connections, and using testing tools to test speed of the mounted volumes I get about 400 MB/sec, and using the utility to copy files given by Facilis, I can copy...
Performance & Maintenance
Windows 7 showing wrong CPU speed.
I recently upgraded to Windows 7, and in Xp my overclock showed correctly. As 333X10.5=3500 but even though my bios settings are still the same and all c1e is turned off, windows 7 is showing that i have 266x10.5=2800. cpu-z shows this aswell, including asus utility (every program i've tried has...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App