Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Constant Explorer/thumbnail crash. MSVCR80.dll culprit? How to fix?

04 Jan 2017   #1

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
Constant Explorer/thumbnail crash. MSVCR80.dll culprit? How to fix?

Hello new friends. I’m not sure if this is the exact area to post my problem here, but I cannot find anywhere else more appropriate. Forgive me if I missed it.

Here is my dilemma:

As of late, my machine’s Explorer has started to “BEX64” crash when I have icons shown as thumbnails ... PDF, AI, TIF, JPG, PSD, Word, Excel and FireFox URLs (I use a program called “Sage Thumbs” to render them). I also use “Display Fusion” to control my two-monitor system. FWIW, I also use Kaspersky as an anti-virus, etc. My system is clean.

About a year ago, the problem started, but it was just an errant Google search URL. When I deleted that using a CMD command, all was fine again. Then it was eBay links that crashed it. Same fix. Now I have slowly progressed to the point where the system will not tolerate anything, i.e., the BEX64 crash happens every time I start Windows (unless I render all as icons).

As a workaround, I tried creating a new User, and all was good at first. But just as I was getting everything set up as before, the crash came back. FYI, the problem exists in Safe Mode as well with any Admin-based user. So, to reiterate, the only way I can now use my system is to keep all files relegated as icons, period. That option will not work for me.

I have spent days and days considering the problem on my own, trying all sorts of suggested tests and CMD-based remedies, including the CMD command "takeown /f MSVCR80.dll" and "regsvr32 MSVCR80.dll" but I get a Runtime Error, "the module MSVCR80.dll failed to load." Not sure if I did something wrong.

Anyway, the problem exists ... I am totally out of ideas. I really don’t want to bother with a new machine if I don’t have to.

My last resort is to ask all the collective experts here if they have some input.

The crash report is consistent with this infor:
* Problem Event Name: BEX64
* Fault Module Name: MSVCR80.dll
* Faulting application path: C:\windows\Explorer.EXE
* Faulting module path: C:\windows\WinSxS\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_88e41e092fab0294\MSV CR80.dll

That “faulting module path” pointing to the DLL, MSVCR80 (784 KB) always comes up as culprit.

Any suggestions? Anything you need from me to help figure this out?

Your input is MOST WELCOME. Thanks all! : )

My System SpecsSystem Spec
04 Jan 2017   #2
Layback Bear

Windows 7 Pro. 64/SP-1

Welcome to our forum RProsser.

I am no expert in anything but I do have a suggestion.

Completing this tutorial by Brink might fix or at least shine some light on the problem.

SFC /SCANNOW Command - System File Checker

My System SpecsSystem Spec
05 Jan 2017   #3

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Jack, thanks for the reply. I will try this again and report my results.
My System SpecsSystem Spec

05 Jan 2017   #4

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Well, I ran the test as suggested -- twice in fact. As you see below, I found no errors.
C:\windows\system32>SFC /SCANNOW
Beginning system scan. This process will take some time.
Beginning verification phase of system scan.
Verification 100% complete.
Windows Resource Protection did not find any integrity violations.
Does anyone know of other tests that I can run? Or how to perhaps, for lack of a better term, "repair" this DLL file?

\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_88e41e092fab0294\MSV CR80.dll

It's the one that always comes up as the culprit. Thanks in advance for any input.
My System SpecsSystem Spec
05 Jan 2017   #5
Layback Bear

Windows 7 Pro. 64/SP-1

My System SpecsSystem Spec
05 Jan 2017   #6

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Well, I tried some of the suggestions on that thread, Jack, but nothing seems to work. Yes the author is dealing with a BEX64 crash, but the culprit is not MSVCR80.dll. My particular problem (apparently with the DLL file named in my initial post) seems to be similar to others who have also posted, but I have still not found out how to repair it -- yet.

I have tried Clean Boot Troubleshooting / Advanced Boot Options, loading nothing but Windows-based files at startup, but the problem still exists -- in Safe Mode or normal mode.

I wanted to do a Repair Install, but I do not have the OEM disc. My Lenovo came with factory installed Windows 7, and apparently a repair disc DVD will not suffice. (Repair Install)

I find sites that claim they can fix MSVCR80.dll issues, but I suspect they're bogus. For instance, does anyone know if these guys are legitimate? How to remove msvcr80.dll error

Thanks for any thoughts. Much appreciated.
My System SpecsSystem Spec
05 Jan 2017   #7

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I'm not expert on this but I reckon it might be a corrupted Visual C++ dll file MSVCR80.dll

Or else an application on your machine that is written to use Visual C++ needs updating/ reinstalling.

Check this post and ignore that it mentions a different VC++ dll

explorer crashes

See possible fix here: explorer crashes and note download links for other versions in the last link.

Also try Geek Uninstaller mentioned in this post and include the scan for leftovers.

explorer crashes

Use it to uninstall all VC++ Runtime versions before rebooting and reinstalling them.

Also check for missing updates/ patches for all installed software. Fully uninstall any third party software that you never use especially if it hasn't been updated for a couple of years.
My System SpecsSystem Spec
06 Jan 2017   #8

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Thank you Callender.

Using Geek Uninstaller, I am going to uninstall all references to MS Visual C++, then reboot, and then reinstall each starting with the oldest version first.

I hope/assume rebooting is the correct step in this procedure. I guess I will find out.

I will report back on the results.

Best Regards
My System SpecsSystem Spec
06 Jan 2017   #9

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Yes rebooting after removal is the way to go. You should expect errors with some programs not working properly until you reinstall new versions [Edit: versions of MS VC++] and reboot. I'm not saying that it will 100% fix the issue but it's worth a try.
My System SpecsSystem Spec
06 Jan 2017   #10

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Well, I uninstalled all references to MS Visual C++, rebooted, reinstalled, ran update, restarted.

FYI, besides the standard Admin User, I have two others with admin privileges:

User A has setting “Always show icons, never thumbnails” CHECKED
User B has setting “Always show icons, never thumbnails” UNCHECKED

TEST 1: User A. Upon starting, immediately the “Explorer has stopped working” message came up.
I clicked “Restart the Program” ... the message came back immediately. did a Ctl+Alt+Del to log out.

Reliability Monitor says this:

Windows Explorer
Stopped working
Faulting Application Path: C:\Windows\explorer.exe
Problem signature
Problem Event Name: BEX64
Application Name: Explorer.EXE
Application Version: 6.1.7601.23537
Application Timestamp: 57c44efe
Fault Module Name: MSVCR80.dll
Fault Module Version: 8.0.50727.6195
Fault Module Timestamp: 4dcdd833
Exception Offset: 000000000001df67
Exception Code: c000000d
Exception Data: 0000000000000000
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: a355
Additional Information 2: a35573e51d71aed720069fcff312fc42
Additional Information 3: 9e00
Additional Information 4: 9e00bc16f14316387558ac4a99ccd2bd

TEST 2: User B, Upon starting, I immediately got this message windows:,2015/06/01 18:41:51
CreateExpBtn, err:System Error. Code: 1410.
Class already exists
Not sure what that meant, so I just clicked OK.

So far, the computer seems stable but obviously I cannot see thumbnails to the files — only the icons.

I am about ready to buy a new computer, but I doubt I can find one with Windows 7, and most of my software would need an upgrade if I go with a later versions of Windows. I'd rather fix this problem.

Any other suggestions are very welcome. Thanks again : )
My System SpecsSystem Spec

 Constant Explorer/thumbnail crash. MSVCR80.dll culprit? How to fix?

Thread Tools

Similar help and support threads
Thread Forum
BlackSOD crashing Explorer.exe referring msvcr80.dll after Login
Hi. After a lot of searching and experimenting, I'm desperate and hope You guys can help. System specs in profile. Problem started wit a Stop command that just flickered quickly short after the colored dots start animating in the very start of the boot process. It was a STOP: 0x0000007B. I...
General Discussion
【Explorer Crash】netcfgx.dll caused explorer.exe crash
When I opened the local connection properties, or saved the settings, explorer.exe crashed. I found the fault module is netcfgx.dll, how to fix it? Thanks in advance. Below is the application log info: Log Name: C:\Users\Admin\AppData\Local\Temp\notesC4A9C8\applicationProgram.evt...
BSOD Help and Support
PDF Thumbnail Preview in Windows Explorer
I have win 7 ultimate(32bit) and I installed acrobat reader 9 and foxit pro ,but I can't preview the pdf first page in win explorer ( folder option->view> always show icon ,not thumbnail is not checked) . I used this trick Enable or Disable Thumbnail Preview in Windows Explorer for PDF files...
Windows Explorer: Thumbnail OK + Icon Error
Got this weird error & dunno how to fix it: I want & can see the thumbnails in Explorer but there is also an icon with the same name as the main file. The size is much smaller & when clicking on it, I get the error as you can see below. Also, if I click on a thumbnail & see the image in Windows...
General Discussion
Thumbnail Preview in Explorer
I'm looking for a way to enlarge the thumbnail preview in Explorer. A person is scanning in PDF documents in large amounts and then using the thumbnail preview wants to be able to rename them from the default scanner assigned name. The current thumbnail size isn't big enough to see enough detail to...
General Discussion
Taskbar Thumbnail Preview crashes Explorer.exe
Hello, I currently run the RTM 7600 Build and had come across a very strange problem. Whenever I hover my mouse over the "Superbar" to preview the window via "thumbnail preview" (I believe that is AERO function), I get the "Explorer.exe has stopped working" and then it restarts itself,...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App