Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Tracking Down SharpShell errors in Event Viewer

16 Jan 2017   #1
Foxfan100

Win 7 Ultimate 64
 
 
Tracking Down SharpShell errors in Event Viewer

I have suddenly started getting a slew of SharpShell "0" Application errors in my Event Viewer. These aren't a major problem, but I would like to know exactly what the source application that's causing them is.

There is nothing specific that I can see in the error messages, and whilst I could probably spend time toggling between running applications and the Event Viewer, in hopes of snapshotting the cause and effect, I haven't got the time.

If anyone has information on how to identify the application easily, I'd welcome it. I've spent a lot of time searching for suggestions and relevant stuff, but there don't seem to be any.


My System SpecsSystem Spec
.
17 Jan 2017   #2
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Quote:
SharpShell

SharpShell makes it easy to create Windows Shell Extensions using the .NET Framework.

Source: SharpShell - Home
A quick and dirty way would be to do a search for sharpshell: Go to the start orb in the lower left corner and type/copy/paste sharpshell into the search box and see how many entries show up, it would depend on how many projects/source application's you installed that would determine the amount you'd see. But, that won't identify the culprit, can you post one of the events, one with the most detail so we can look it over?

If you want more detailed information these two utilities may also help: https://Process Monitor | technet.microsoft.com, and https://Process Explorer | technet.microsoft.com I'd try Process Monitor first. The best way to set the filters for either would be to check their Help files. You're looking for sharpshell.dll

Related: Tips For Debugging a Windows Shell Extension
My System SpecsSystem Spec
18 Jan 2017   #3
Foxfan100

Win 7 Ultimate 64
 
 
Sharpshell

Thanks for the response.

I'll work through the points on this as methodically as I can.

1) the only occurrence of sharpshell.dll is in Program Files\Box\Box Sync.
2) the errors crop up randomly at intervals during the day. There is no scheduled Box task set to run, and the Box Sync Update Service is set to Manual.
3) the Sharpshell errors occur at the same time as a .NET error (shot attached) and I notice that the last Win 7 Update Rollup contained some .NET features. These errors have only started in the last 7 days or so.
4) I've tried to tie the .NET error PID to something, but of course it's transient, and gone before I can see what it is. As you suggest, logging via Procmon is probably the only way to track it down.
5) there are shots of the Sharpshell and .NET errors attached.


Attached Thumbnails
Tracking Down SharpShell errors in Event Viewer-sha1.jpg   Tracking Down SharpShell errors in Event Viewer-sha2.jpg   Tracking Down SharpShell errors in Event Viewer-sha3.jpg   Tracking Down SharpShell errors in Event Viewer-sha4.jpg   Tracking Down SharpShell errors in Event Viewer-sha5.jpg  

My System SpecsSystem Spec
.

18 Jan 2017   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Foxfan,
The access denied shown is from windows search/indexing.
normal fix is to turn off reboot turn back on.

Roy
My System SpecsSystem Spec
18 Jan 2017   #5
Foxfan100

Win 7 Ultimate 64
 
 

Quote   Quote: Originally Posted by torchwood View Post
Hi Foxfan,
The access denied shown is from windows search/indexing.
normal fix is to turn off reboot turn back on.

Roy
Thanks.

I've turned Search on and off, but it doesn't seem to make any difference.

What I don't understand (because I don't know much about the guts of SharpShell) is why a SharpShell 0 error should have anything to do with the Program Data\Microsoft\Search etc folder.
My System SpecsSystem Spec
18 Jan 2017   #6
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

The relationship between sharpshell and search is, even though search resides in programdata it searches everywhere else and sharpshell is in a program in the Programs Folder (Box\Box Sync). Normally search doesn't search in programdata:

information   Information
Even if you uncheck and re-check your system drive C: in an attempt to have it fully indexed, the following folders will always be excluded:
C:\programdata\
C:\Users\Default\AppData
C:\Users\[YOUR_USERNAME]\AppData
C:\Windows
Source: Windows Search - Configure and Use

I did find a small reference to turning search on and off, mainly the Search Service, if you go this route substitute Icaros with Box\Box Sync, from what I've seen Icaros uses .NET Framework 4.0 and possibly sharpshell. I offer this because the post above, this one, has event errors similar to yours:
Quote:
There are basically 4 ways (that I know of) to avoid the error:

1. Disable all Icaros Property Filetypes in IcarosConfig (this will disable the Property Handler).
2. Disable Windows Search (Indexing) in Services (if you don't use it).
3. Remove any file locations containing Icaros' Property Filetypes (mkv, ogm, flv etc.), from the 'Included locations' list in the 'Indexing options' utility.
4. Exclude the Icaros Property Filetypes from being indexed, by unchecking them in the 'Indexing options' utility, under Advanced -> File Types.
5. Ignore the error.

Just understand that this error is harmless, it's more of a reminder than an actual error.

Source from the Icaros Developer: Archived posts
Have you tried allowing Box Sync Update to run its service automatically?

If you believe this is from a recent .NET update go to programs and features and run a repair on your .NET 4 program., maybe even a sfc /scannow.

The sharpshell (SS) developer has this page near the bottom showing how to use the debugger for it. Make sure SS is signed and registered. He is open to discussions.

Latest version of SS (2.2) I thought of uninstalling Box but seen posts that it didn't help doing that with programs that use SS. Do you have the latest Box Sync?

If you're paying for Box try asking there: Help - Box
My System SpecsSystem Spec
04 Feb 2017   #7
Foxfan100

Win 7 Ultimate 64
 
 
Got it!

This has happened because Box uses these dlls in the Explorer shell (and also the FreeCommander file manager which is based on Explorer). Disabling them using Autoruns gets rid of the EV errors.

If it were not for the generous space allocation on Box, I'd uninstall it right now!


Attached Thumbnails
Tracking Down SharpShell errors in Event Viewer-box-dll.jpg  
My System SpecsSystem Spec
04 Feb 2017   #8
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

I hope that's great news, do you think that disabling those .dlls will cause any problems?

Just curious, what type of plan do you have with Box?
My System SpecsSystem Spec
05 Feb 2017   #9
Foxfan100

Win 7 Ultimate 64
 
 

Quote   Quote: Originally Posted by Anak View Post
I hope that's great news, do you think that disabling those .dlls will cause any problems?

Just curious, what type of plan do you have with Box?
I don't have Box running all the time (or any other cloud services) and start it up when I need to use it. I haven't seen any problems from the disabled DLLs, but the EV now doesn't log hundreds of Sharpshell errors, which seem to arise any time the shell is invoked.


I still haven't worked out why this went from never producing errors to always doing so. Obviously something was updated or changed, but I'm not sure I'll be able to identify what and when.


I'm still using the basic free Box plan. Where I am, broadband is very slow, especially on uploads, which severely limits the amount of data I can sensibly load to clouds.
My System SpecsSystem Spec
05 Feb 2017   #10
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Do you use PowerArchiver (PA)? Here's a recent thread were one of the admins says about sharpshell and PA:
Quote:
it is a backup bug, it doesnt have anything to do with icons in any way, it is just that backup writes wrong values in PA registry once completed and causes issues…
Even if you don't use PA; Is FreeCommander similar? It may still be a clue to what's going on. Maybe Box has the same problem with sharpshell and Box's registry. You've already touched on that in your #7 post.

I agree with your assumption that:
Quote:
Obviously something was updated or changed,
Being that sharpshell and possibly Box works with .net, have you tried repairing your .net versions? I don't remember if repairing was suggested earlier or not.

Go to: Control Panel\All Control Panel Items\Programs and Features, let it populate then look for .net framework >left click on the entry [if more than one do each separately] >click on uninstall/change >make sure the repair radio button is selected and click on next and follow the prompts to finish.
The initial screen does say: repair to its original state, so you may want to consider a windows update check, I never did a check thinking that windows would catch-up during the next monthly update, in the mean time it fixed a problem that I had and it never came back. At one time I had several .net entries back to v2.0 but over the years microsoft consolidated them all to v4.6.1 .

In case you see an error that the native repair can not continue because the installer (MSI) is missing or corrupt [that could be the cause of your problem] try this: Introducing the Microsoft .NET Framework Repair Tool/.net blog
Make sure you click on the download center link shown in the "get the latest version section", the blog states that the tool goes up to v4.5.1 but the details section at the download page has a note that it is revised to work on v4.6.1 back to v2.0 SP1 . Related: .NET Framework Versions and Dependencies


I looked around and Box is one of few storage solutions that offer free/10GB/250MB upload, the only other that offers greater is google drive at 15GB free, upload limits vary.
Some users hate google because of its ubiquity and privacy concerns but I use gmail and I've set the privacy controls to max, they've been running HTTPS for 12years now and gmail's been encrypted since 2010, we've been using gmail since 2004 and the only problem, if you can call it a problem was the other day when my wife started up her new laptop and signed-in to her gmail, we both received an email notifying us if we recognize the new sign-in, all we had to do is click on yes, it's OK, and that was that.

I could go on and make this tl;dnr so if you have any questions about google drive just ask.
My System SpecsSystem Spec
Reply

 Tracking Down SharpShell errors in Event Viewer




Thread Tools




Similar help and support threads
Thread Forum
Event errors (11, 7000, 7026), intellipoint and event viewer freeze.
Hi, keep getting the errors above every startup regarding; 11 - "Custom dynamic link libraries are being loaded for every application. The system administrator should review the list of libraries to ensure they are related to trusted applications." 7000 - "The Crypkey License service...
General Discussion
Event Viewer errors
I found a huge list. But I can't copy and need to type them out I'm listing just two for now What the heck is wrong and how do I fix it?? Faulting application name STaSV64.exe, version 1.0.6393.0, time stamp; 0x4f5ed3b7. Faulting module name: STaSV64.exe, version 1.0.6393.0, time stamp;...
General Discussion
Event viewer errors
I recently called two separate tech support people who remotely accessed my computer, and used the event viewer. Inthis, they showed me that in the application list, there were 36,246 entries, and in the system catagory, 58,424 entries, with lots of errors. They also said that I would need level 3...
Performance & Maintenance
WHEA-Logger event 18/19 errors in Event Viewer (W7 Home Premium)
Hi, I was hoping somebody could offer an insight on the below, as searching around I've not found much to go on other than "overheating" Basically my laptop has been having very high temperatures for a long time (usually ~60C for CPU and often 100-110 for GPU...insanely high, in other words)...
Hardware & Devices
Two errors in Event Viewer
Hello SF! I have two errors constantly being registered every time reboot(or turn on) my computer that i cant resolve: The first one is a Event 3006 LoadPerf: And a second one a Event 1530 User Profile Settings:
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App